Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

field( 'related_field.file_field ') only returns first related file_field #831

Closed
danfarrow opened this Issue Dec 6, 2012 · 10 comments

Comments

Projects
None yet
2 participants
$therapist = pods('therapists', pods_url_variable(-1)); 
$logos = $therapist->field('credentials.logo'); // The credentials field has 3 items selected
pods_debug($logos); // Only one upload is listed
Owner

sc0ttkclark commented Dec 7, 2012

What version of WP was this on?

3.5

Owner

sc0ttkclark commented Dec 7, 2012

And which Pods version?

2.1 RC 1

On 7 December 2012 09:11, Scott Kingsley Clark notifications@github.comwrote:

And which Pods version?


Reply to this email directly or view it on GitHubhttps://github.com/pods-framework/pods/issues/831#issuecomment-11131080.

Owner

sc0ttkclark commented Feb 11, 2013

Can this be retested in Pods 2.3?

@sc0ttkclark sc0ttkclark was assigned Feb 11, 2013

I just retested - it's still the case that only one upload is listed
Pods 2.3 A13
WP 3.5.1

Owner

sc0ttkclark commented Feb 22, 2013

Is it showing all files in the admin, but not all files when calling field() from the front?

Just to reiterate the issue:

I have a pod therapist with a multipick relationship to another pod credentials. The credentials pod has an image-upload / attachment field logo.

$therapist->field('credentials') returns an array with several member arrays representing the related credentials

$therapist->field('credentials.logo') returns an array with one member array representing the WP attachment

The selected credentials display in the admin yes, however I'm not using logo as the display field (incidentally, if I do select logo as the display field I get an SQL error!)

I should also add that this is no longer an issue for me personally :)

@sc0ttkclark sc0ttkclark reopened this Feb 22, 2013

Owner

sc0ttkclark commented Feb 28, 2013

Can you export the pods in question as a package for me to test with?

Owner

sc0ttkclark commented Mar 12, 2013

Looks like this is working now. If you see it again on any related item, resave that related item. If you continue to see it, then we know there's something else going on. For now, it works for me and my tests.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment