New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

npm WARN react-redux@4.4.5 requires a peer of redux@^2.0.0 || ^3.0.0 but none was installed. #33

Closed
dvmorris opened this Issue Jun 13, 2016 · 5 comments

Comments

Projects
None yet
5 participants
@dvmorris

dvmorris commented Jun 13, 2016

Steps to reproduce (using this design.zip file):

meteor create stanza-test
cd stanza-test
stanza -c
cp ~/Downloads/design.zip ./
stanza -u
npm install
...
...
└── UNMET PEER DEPENDENCY redux@^2.0.0 || ^3.0.0

npm WARN react-redux@4.4.5 requires a peer of redux@^2.0.0 || ^3.0.0 but none was installed.

Environment:

$ node --version
v6.2.1
$ npm --version
3.9.5
$ meteor --version
Meteor 1.3.2.4
$ npm ls --global=true --depth=0
/usr/local/lib
├── chimp@0.35.0
├── mantra-cli@0.3.12
├── npm@3.9.5
├── poetic-stanza@0.4.1
├── webpack@1.13.1
└── webpack-dev-server@1.14.1
@dvmorris

This comment has been minimized.

Show comment
Hide comment
@dvmorris

dvmorris Jun 13, 2016

My solution was to manually add this to the stanza-generated package.json file, but it seems like this should be automatically included. This was working fine last week.

    "react-super-components": "^0.3.5",
    "redux": "^3.5.2",  <-- had to manually add this line to package.json
    "redux-thunk": "^2.1.0"

dvmorris commented Jun 13, 2016

My solution was to manually add this to the stanza-generated package.json file, but it seems like this should be automatically included. This was working fine last week.

    "react-super-components": "^0.3.5",
    "redux": "^3.5.2",  <-- had to manually add this line to package.json
    "redux-thunk": "^2.1.0"
@pferdone

This comment has been minimized.

Show comment
Hide comment
@pferdone

pferdone Jun 22, 2016

@dvmorris I followed your advice and manually installed redux: npm i --save redux now it works

pferdone commented Jun 22, 2016

@dvmorris I followed your advice and manually installed redux: npm i --save redux now it works

@Chun-Yang

This comment has been minimized.

Show comment
Hide comment
@Chun-Yang

Chun-Yang Jun 26, 2016

Contributor

Done.

Contributor

Chun-Yang commented Jun 26, 2016

Done.

@mtrabelsi

This comment has been minimized.

Show comment
Hide comment
@mtrabelsi

mtrabelsi Dec 25, 2016

I ran into this too, and I just wonder why does this breaks? Normally should be automatically installed..

mtrabelsi commented Dec 25, 2016

I ran into this too, and I just wonder why does this breaks? Normally should be automatically installed..

@PocketNinjaDesign

This comment has been minimized.

Show comment
Hide comment
@PocketNinjaDesign

PocketNinjaDesign Sep 23, 2017

Yeah it's a weird one, that you have to have redux installed before installing react-redux. Just went through the same issue myself just now.

Could do with seeing on npm react-redux to make sure redux is installed first. Would be the best place to add it on this page

https://www.npmjs.com/package/react-redux

Then nobody will have any problems.

PocketNinjaDesign commented Sep 23, 2017

Yeah it's a weird one, that you have to have redux installed before installing react-redux. Just went through the same issue myself just now.

Could do with seeing on npm react-redux to make sure redux is installed first. Would be the best place to add it on this page

https://www.npmjs.com/package/react-redux

Then nobody will have any problems.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment