Specific code to make some compatibilities between Polylang and Gutenberg
Switch branches/tags
Nothing to show
Clone or download
manooweb Fix incompatibility when a request is not a REST request from legacy …
…metaboxes from other plugins as ACF or Yoast SEO for example

Add data store for future development where data persistence is needed
Latest commit b335aa7 Nov 14, 2018

readme.txt

=== Polylang with Gutenberg ===
Contributors: Chouby, manooweb
Donate link: https://polylang.pro
Tags: multilingual, bilingual, translate, translation, language, multilanguage, international, localization, gutenberg
Requires at least: 4.4
Tested up to: 4.9
Stable tag: 0.2.0
License: GPLv2 or later

Making compatibilities between Polylang and Gutenberg

== Description ==

For the moment, this plugin is a temporary playground for us to understand technologies used by Gutenberg like React and React Redux and
allow us to improve our skills with these technologies.
We decided to migrate our "Language" metabox in a specific plugin sidebar. Also this plugin remove the metabox from the Gutenberg sidebar.

The work is still running and Polylang is not ready yet for Gutenberg.

== Installation ==

1. Clone on your local environment from github https://github.com/polylang/polylang-gutenberg.git
2. Create a symbolic link "polylang-gutenberg" in wp-content\plugins which points to your git clone
3. Verify Polylang PRO is activated. Only this version already has REST API compatibility integrated
4. Activate Poylang With Gutenberg

== Changelog ==

= 0.2.0 (2018-08-17) =

* Be careful! No metabox features are implemented yet
* Started development language metabox as a React component

= 0.1.0 (2018-05-02) =

* Add a specific plugin sidebar in Gutenberg UI for Polylang and inject the metabox (older version)
* Fix some issues with Gutenberg
* Explore how language metabox works with Gutenberg
* Started the project