Client library & drivers for interacting with polyswarmd
Branch: master
Clone or download
Latest commit 4715419 Feb 16, 2019

README.md

PolySwarm Client Library

pipeline status coverage report Read the Docs Build Status

For the convenience of those who wish to join the PolySwarm marketplace, this is a client library to simplify interacting with a polyswarmd instance from your Python code.

It includes:

  • abstract classes for ambassador, arbiter, and microengine implementations
  • exemplar ambassador, arbiter, and microengine implementations
  • helper classes

For important changes releases, see the Release History.

Installation

You need python3 >= 3.5.4. Then to install polyswarm-client, use pip

pip install polyswarm-client

Documentation

We have extensive documentation on how to use this package available in our docs.