New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Admin user can't load model via the cli #121

Closed
elutfall opened this Issue Feb 1, 2012 · 4 comments

Comments

Projects
None yet
2 participants
@elutfall

elutfall commented Feb 1, 2012

In 4.1.1, an admin user can load the model via the UI.
The uri fetches fine using wget or curl as the glu user from the console machine.

Using the same model uri on the cli gives this error:

Traceback (most recent call last):
File "./bin/../../glu-tools/console_cli/bin/console-cli.py", line 248, in
main()
File "./bin/../../glu-tools/console_cli/bin/console-cli.py", line 219, in main
modelLoaded = client.loadModel(modelUrl = options.model, modelFile = options.modelFile)
File "/home/elutfallah/orbitz-fabrics/glu-tools/console_cli/lib/python/gluconsole/rest.py", line 243, in loadModel
response = self._doRequest("model/static", "POST", body)
File "/home/elutfallah/orbitz-fabrics/glu-tools/console_cli/lib/python/gluconsole/rest.py", line 81, in _doRequest
raise restkit.errors.RequestFailed(response.body_string(), response.status_int, response)
restkit.errors.RequestFailed:

<title>Error 400 A JSONObject text must begin with '{' at character 1</title>

HTTP ERROR 400

Problem accessing /console/grails/model/rest_upload_model.dispatch. Reason:

    A JSONObject text must begin with '{' at character 1


Powered by Jetty://



















@ypujante

This comment has been minimized.

Member

ypujante commented Feb 1, 2012

Is this a specific issue with 4.1.1? Or was it also an issue with 4.1.0?

@elutfall

This comment has been minimized.

elutfall commented Feb 6, 2012

Haven't tested in 4.1.0. Most recent version we use and that we know it works with is 3.4.1.

@ypujante

This comment has been minimized.

Member

ypujante commented Feb 15, 2012

I can reproduce in 4.1.1. Will work on a fix for 4.2.0

@ghost ghost assigned ypujante Feb 15, 2012

ypujante added a commit that referenced this issue Feb 16, 2012

@ypujante

This comment has been minimized.

Member

ypujante commented Feb 16, 2012

Fixed in 4.2.0

@ypujante ypujante closed this Feb 16, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment