Skip to content
Permalink
Browse files

Fix library dependencies

  • Loading branch information...
ponkotuy committed Aug 7, 2017
1 parent 51546c0 commit 7409b9c3b43d2b73619e7a5790d48b1859924071
Showing with 11 additions and 14 deletions.
  1. +7 −10 build.sbt
  2. +3 −3 project/plugins.sbt
  3. +1 −1 project/project/plugins.sbt
@@ -5,27 +5,24 @@ import com.typesafe.sbt.SbtScalariform.ScalariformKeys

name := "TrainStampRally"

scalaVersion := "2.11.11"
scalaVersion := "2.12.3"

val play2AuthVer = "0.14.2"
val googleLibVer = "1.22.0"

libraryDependencies ++= Seq(
ws,
cache,
ehcache,
"org.skinny-framework" %% "skinny-orm" % "2.3.5",
"org.scalikejdbc" %% "scalikejdbc-play-initializer" % "2.5.1",
"org.scalikejdbc" %% "scalikejdbc-play-initializer" % "2.6.0",
"org.mariadb.jdbc" % "mariadb-java-client" % "1.4.0",
"org.flywaydb" %% "flyway-play" % "3.0.1",
"jp.t2v" %% "play2-auth" % play2AuthVer,
"jp.t2v" %% "play2-auth-social" % play2AuthVer,
"com.github.tototoshi" %% "play-json4s-native" % "0.5.0",
"com.github.tototoshi" %% "play-json4s-test-native" % "0.5.0" % "test",
"org.flywaydb" %% "flyway-play" % "4.0.0",
"com.github.tototoshi" %% "play-json4s-native" % "0.8.0",
"com.github.tototoshi" %% "play-json4s-test-native" % "0.8.0" % "test",
"org.scalatest" %% "scalatest" % "3.0.0" % "test",
"org.springframework.security" % "spring-security-web" % "4.1.3.RELEASE",
"ch.qos.logback" % "logback-classic" % "1.1.7" % "runtime",
"org.slf4j" % "slf4j-api" % "1.7.21",
"net.liftweb" %% "lift-util" % "2.6.2",
"net.liftweb" %% "lift-util" % "3.1.0",
"org.scala-lang.modules" %% "scala-xml" % "1.0.6",
"com.google.maps" % "google-maps-services" % "0.1.17",
"com.amazonaws" % "aws-java-sdk" % "1.11.75"
@@ -1,7 +1,7 @@

resolvers += "Typesafe repository" at "http://repo.typesafe.com/typesafe/releases/"

addSbtPlugin("io.get-coursier" % "sbt-coursier" % "1.0.0-M15")
addSbtPlugin("com.typesafe.play" % "sbt-plugin" % "2.5.5")
addSbtPlugin("io.get-coursier" % "sbt-coursier" % "1.0.0-RC3")
addSbtPlugin("com.typesafe.play" % "sbt-plugin" % "2.6.2")
addSbtPlugin("org.scalariform" % "sbt-scalariform" % "1.6.0")
addSbtPlugin("com.typesafe.sbt" % "sbt-native-packager" % "1.2.0-M8")
addSbtPlugin("com.typesafe.sbt" % "sbt-native-packager" % "1.2.0")
@@ -1,2 +1,2 @@

addSbtPlugin("io.get-coursier" % "sbt-coursier" % "1.0.0-M15")
addSbtPlugin("io.get-coursier" % "sbt-coursier" % "1.0.0-RC3")

0 comments on commit 7409b9c

Please sign in to comment.
You can’t perform that action at this time.