Skip to content
Permalink
Browse files

travis: fix

  • Loading branch information
ponty
ponty committed Dec 18, 2018
1 parent 7c49695 commit 88f641474ba6113da101644c6d23085d73a7673f
Showing with 4 additions and 3 deletions.
  1. +4 −3 .travis.yml
@@ -9,23 +9,24 @@ python:
# no python3-wx before bionic
# no pyqt5 before xenial
# no pygtk for py3
# pygdk3 plugin is not compatible with trusty
matrix:
include:
- python: "2.7_with_system_site_packages"
dist: trusty
env: DIST="trusty" PACKAGES="python-gtk2 python-gi gir1.2-gtk-3.0 python-wxgtk2.8 python-qt4 python-pyside " TESTS2="test_pygtk.py test_pygdk3.py test_wx.py test_pyqt4.py "
env: DIST="trusty" PACKAGES="python-gtk2 python-wxgtk2.8 python-qt4 python-pyside " TESTS2="test_pygtk.py test_wx.py test_pyqt4.py "

- python: "2.7_with_system_site_packages"
dist: xenial
env: DIST="xenial" PACKAGES="python-gtk2 python-gi gir1.2-gtk-3.0 python-wxgtk3.0 python-qt4 python-pyside python-pyqt5" TESTS2="test_pygtk.py test_pygdk3.py test_wx.py test_pyqt4.py test_pyqt5.py"

- python: "3.4_with_system_site_packages"
dist: trusty
env: DIST="trusty" PACKAGES=" python3-gi gir1.2-gtk-3.0 python3-pyqt4 " TESTS2=" test_pygdk3.py test_pyqt4.py "
env: DIST="trusty" PACKAGES=" python3-pyqt4 " TESTS2=" test_pyqt4.py "

- python: "3.5_with_system_site_packages"
dist: xenial
env: DIST="xenial" PACKAGES=" python3-gi gir1.2-gtk-3.0 python3-pyqt4 python3-pyqt5" TESTS2=" test_pygdk3.py test_pyqt4.py test_pyqt5.py"
env: DIST="xenial" PACKAGES=" python3-gi gir1.2-gtk-3.0 python3-pyqt4 python3-pyqt5" TESTS2=" test_pygdk3.py test_pyqt4.py test_pyqt5.py"

- python: 3.7
dist: xenial

0 comments on commit 88f6414

Please sign in to comment.
You can’t perform that action at this time.