Add the compatibility with PYPY by psycopg2cffi. #179

Merged
merged 1 commit into from Jun 22, 2016

Projects

None yet

2 participants

@OctavianLee
Contributor

It is unable to install psycopg2 when using pypy. I use the lib psycopg2cffi in order to make pony works.

Steps:

  • install pypy-dev;
  • pip install psycopg2cffi.

SEE:

http://stackoverflow.com/questions/9350422/how-do-you-get-pypy-django-and-postgresql-to-work-together#

@OctavianLee
Contributor
@kozlovsky kozlovsky merged commit 5e40aba into ponyorm:orm Jun 22, 2016
@kozlovsky
Contributor

Sorry, we were a bit overloaded lately. Thanks for the pull request!

@kozlovsky kozlovsky added a commit that referenced this pull request Aug 22, 2016
@kozlovsky kozlovsky PonyORM Release 0.6.6 (2016-08-22)
# New features

* Added native JSON data type support in all supported databases: https://docs.ponyorm.com/json.html

# Backward incompatible changes

* Dropped Python 2.6 support

# Improvements

* #179 Added the compatibility with PYPY using psycopg2cffi
* Added an experimental @db_session `strict` parameter: https://docs.ponyorm.com/transactions.html#strict

# Bugfixes

* #182 - LEFT JOIN doesn't work as expected for inherited entities when foreign key is None
* Some small bugs were fixed
5f98491
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment