New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Not compatible with Jekyll 3.0 #124

Open
joacimmelin opened this Issue Jul 1, 2015 · 13 comments

Comments

Projects
None yet
@joacimmelin

joacimmelin commented Jul 1, 2015

Hi,

I get this error message when trying Lanyon with Jekyll-3.0.0.pre.beta8:

"Since v3.0, permalinks for pages in subfolders must be relative to the site source directory, not the parent directory. Check http://jekyllrb.com/docs/upgrading/ for more info."

Any plans to update this great theme for 3.0?

Thanks,

Joacim

@nickmccurdy

This comment has been minimized.

Contributor

nickmccurdy commented Jul 2, 2015

👍 for working on support for this. Is Poole itself ready for Jekyll 3.0? If not, should that happen first?

@mdo mdo added this to the v2.0.0 milestone Jul 2, 2015

@joacimmelin

This comment has been minimized.

joacimmelin commented Aug 24, 2015

Any news on this? I still can't build my Lanyon based site with Jekyll 3.0.0.pre.beta8.

@heathyates

This comment has been minimized.

heathyates commented Nov 11, 2015

I did some googling and found some things that might help you. I needed to make two changes to _config.yml to get it to work.

Change 1:
gems: [jekyll-paginate]
paginate: 5
paginate_path: "page:num"

Change 2:
Remove relative_permalinks: true

If you want I can make a pull request to Lanyon if this works for everyone.

@patrickhempel

This comment has been minimized.

patrickhempel commented Nov 15, 2015

Unfortunately, it dosen't work for me.
jekyll creates odd urls for all the posts on the index page.
The url for the first post was generated as http://0.0.7.222/01/02/introducing-lanyon.html.

I use jekyll 3.0.0 with ruby 2.1.4p265 on Mac OS 10.11.1

Any idea how to solve this?

Greetings, Patrick

@ravicious

This comment has been minimized.

ravicious commented Nov 15, 2015

See #108.

@patrickhempel

This comment has been minimized.

patrickhempel commented Nov 15, 2015

Thank you.
Everything is working now as expected.
I totally overlooked issue #108

@akaak

This comment has been minimized.

akaak commented Dec 19, 2015

It works for me as well after I made the two changes that were mentioned above by @heathyates.

@tgharib

This comment has been minimized.

tgharib commented Dec 23, 2015

I can confirm that heathyates's two changes worked.

bbelderbos added a commit to bbelderbos/bbelderbos.github.io that referenced this issue Jan 27, 2016

@rfelten

This comment has been minimized.

rfelten commented Feb 19, 2016

@ralphilius

This comment has been minimized.

ralphilius commented Feb 23, 2016

Changes suggested by @heathyates work for me :)
Thanks.

AtJofo pushed a commit to AtJofo/atjofo.github.io that referenced this issue Mar 18, 2016

AtJofo
config edit #2
added fixes from:
poole/lanyon#124
@Hany3ssam

This comment has been minimized.

Hany3ssam commented Apr 7, 2016

@heathyates Thank You, That Worked

@IanJang

This comment has been minimized.

IanJang commented Jan 25, 2017

@heathyates Thanks a lot. I could build it because of your help.

@keeprock

This comment has been minimized.

keeprock commented Mar 6, 2018

@heathyates you're the man!

yeug added a commit to yeug/yeug.github.io that referenced this issue Oct 8, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment