New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Comment feed: Links to comments are not working #437

Closed
mdosch opened this Issue May 7, 2018 · 7 comments

Comments

Projects
None yet
4 participants
@mdosch

mdosch commented May 7, 2018

I am running the master pulled from yesterday and so far it works nice and comment feeds are great as finally users have the possibility to stay updated but I found a malfunction.

In the comment feed for this site you don't get to the comment if you click on a comment link as there is a wrong URL shown.

Maybe it is due to me using relative links everywhere to make my site also work as hidden service without changing links in the compiled website. Or maybe I made something wrong while updating as this was try and error.

@blatinier

This comment has been minimized.

Collaborator

blatinier commented May 7, 2018

Can you post your isso.conf?

@mdosch

This comment has been minimized.

mdosch commented May 7, 2018

[general]
dbpath = /home/md85/etc/isso/comments.db
host =
    https://blog.mdosch.de/
    http://blog.mdosch.de/
notify = smtp
max-age = 2h
log-file = /home/md85/isso.log

[smtp]
host = localhost
port = 25
security = none
to = REDACTED
from = "Kommentarsystem blog.mdosch.de" <no-reply@mdosch.de>

[guard]
enabled = true
ratelimit = 5
direct-reply = 10
reply-to-self = false

[moderation]
enabled = false
purge-after = 30d

[rss]
base = /
limit = 100

Looking at the config I am pretty sure I *** it up with base = /.

@vincentbernat

This comment has been minimized.

Contributor

vincentbernat commented May 7, 2018

When using base = /, //2018/... get interpreted as an URI whose host is 2018 as an IP address. Maybe you could use base = ../..? Otherwise, we could fix that by stripping / from the URL when building the Atom feed.

vincentbernat added a commit to vincentbernat/isso that referenced this issue May 7, 2018

feed: remove trailing / from base URL
This way, one can use "/" as base URL. This is only valid if we are
sure that URI should always have a leading "/". Is that the case?

Fix posativ#437.
@mdosch

This comment has been minimized.

mdosch commented May 7, 2018

Didn't help but with base = . the links look like https://blog.mdosch.de/fcgi-bin/isso/2018/05/04/seite-fuer-xmpp-einsteiger-sucht-unterstuetzer/#isso-605 so I am one step closer as I only have to get rid of /fcgi-bin/isso/ in between.

@mdosch

This comment has been minimized.

mdosch commented May 7, 2018

I'm sorry, I tried again with ../.. and it works now. Maybe it was a caching issue that it didn't work earlier.
Thank you very much for your incredible fast help.

@blatinier

This comment has been minimized.

Collaborator

blatinier commented May 7, 2018

That's a great news! I close then.

@blatinier blatinier closed this May 7, 2018

@pozitron57

This comment has been minimized.

Contributor

pozitron57 commented Jul 29, 2018

I set data-isso-feed="true" for client and configured server with limit=100. However it seems that the base setting has no effect on the place where "Atom feed" link points. Do I need to do something else?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment