Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
..
Failed to load latest commit information.
debian
locale ADDITIONS/delete-mailq-by-domain.pl, Aug 3, 2011
po ADDITIONS/delete-mailq-by-domain.pl, Aug 3, 2011
INSTALL INSTALL.TXT, ADDITIONS/squirrelmail-plugin/INSTALL Oct 20, 2014
LICENSE.txt list-virtual.php: Sep 26, 2010
README.md Update README.md May 26, 2017
common.php Reformat everything with PHP-Cs-Fixer Jan 26, 2018
config.php.sample list-virtual.php: Sep 26, 2010
functions.inc.php Reformat everything with PHP-Cs-Fixer Jan 26, 2018
index.php Reformat everything with PHP-Cs-Fixer Jan 26, 2018
postfixadmin_changepass.php Reformat everything with PHP-Cs-Fixer Jan 26, 2018
postfixadmin_forward.php Reformat everything with PHP-Cs-Fixer Jan 26, 2018
postfixadmin_vacation.php
setup.php Reformat everything with PHP-Cs-Fixer Jan 26, 2018
version list-virtual.php: Sep 26, 2010

README.md

Squirrelmail Plugin Postfixadmin

The Postfixadmin SquirrelMail plugin let users change their virtual alias, vacation status/message and password

Your users can therefore use this plugin within Squirrelmail to :

  • Turn vacation on/off
  • Change their email password
  • Setup forwarding rules

Note, this plugin does not require access to the Postfixadmin database. It communicates with Postfixadmin using the XMLRPC protocol.

Notes

  • We now depend upon the Zend Framework (preferably v1.9.x at the time of writing) (Download from http://framework.zend.com/download/latest - the minimal one should be sufficient)
  • Traffic to the XmlRpc interface needs encrypting (e.g. https) - this is something you need to do
  • When trying to use the plugin, the user will be prompted to enter their mailbox password - this is necessary to authenticate with the remote XmlRpc? interface

REQUIREMENTS

  • SquirrelMail 1.4x
  • PostfixAdmin version 3 or higher.
  • PHP 5.4+ with XMLRPC support