Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

Add support for aclocal/automake 1.12

  • Loading branch information...
commit c1a168f5356bd984a09fcb424214ba33b555cdc4 1 parent 718ef96
Dave Page dpage authored

Showing 1 changed file with 30 additions and 17 deletions. Show diff stats Hide diff stats

  1. +30 17 bootstrap
47 bootstrap
@@ -12,47 +12,60 @@
12 12
13 13 # Check for aclocal 1.9/1.10/1.11
14 14 echo "Checking aclocal..."
15   -RET=`type aclocal-1.11 > /dev/null 2>&1 || echo fail`
  15 +
  16 +RET=`type aclocal-1.12 > /dev/null 2>&1 || echo fail`
16 17 if [ x$RET != xfail ];
17 18 then
18   - ACLOCAL=aclocal-1.11
  19 + ACLOCAL=aclocal-1.12
19 20 else
20   - RET=`type aclocal-1.10 > /dev/null 2>&1 || echo fail`
  21 + RET=`type aclocal-1.11 > /dev/null 2>&1 || echo fail`
21 22 if [ x$RET != xfail ];
22 23 then
23   - ACLOCAL=aclocal-1.10
  24 + ACLOCAL=aclocal-1.11
24 25 else
25   - RET=`type aclocal-1.9 > /dev/null 2>&1 || echo fail`
  26 + RET=`type aclocal-1.10 > /dev/null 2>&1 || echo fail`
26 27 if [ x$RET != xfail ];
27 28 then
28   - ACLOCAL=aclocal-1.9
  29 + ACLOCAL=aclocal-1.10
29 30 else
30   - echo "ERROR: this script requires aclocal-1.9, aclocal-1.10 or aclocal-1.11"
31   - exit 1
  31 + RET=`type aclocal-1.9 > /dev/null 2>&1 || echo fail`
  32 + if [ x$RET != xfail ];
  33 + then
  34 + ACLOCAL=aclocal-1.9
  35 + else
  36 + echo "ERROR: this script requires aclocal-1.9, aclocal-1.10, aclocal-1.11 or aclocal-1.12"
  37 + exit 1
  38 + fi
32 39 fi
33 40 fi
34 41 fi
35 42
36 43
37   -# Check for automake 1.9/1.10/1.11
  44 +# Check for automake 1.9/1.10/1.11/1.12
38 45 echo "Checking automake..."
39   -RET=`type automake-1.11 > /dev/null 2>&1 || echo fail`
  46 +RET=`type automake-1.12 > /dev/null 2>&1 || echo fail`
40 47 if [ x$RET != xfail ];
41 48 then
42   - AUTOMAKE=automake-1.11
  49 + AUTOMAKE=automake-1.12
43 50 else
44   - RET=`type automake-1.10 > /dev/null 2>&1 || echo fail`
  51 + RET=`type automake-1.11 > /dev/null 2>&1 || echo fail`
45 52 if [ x$RET != xfail ];
46 53 then
47   - AUTOMAKE=automake-1.10
  54 + AUTOMAKE=automake-1.11
48 55 else
49   - RET=`type automake-1.9 > /dev/null 2>&1 || echo fail`
  56 + RET=`type automake-1.10 > /dev/null 2>&1 || echo fail`
50 57 if [ x$RET != xfail ];
51 58 then
52   - AUTOMAKE=automake-1.9
  59 + AUTOMAKE=automake-1.10
53 60 else
54   - echo "ERROR: this script requires automake-1.9, automake-1.10 or automake-1.11"
55   - exit 1
  61 + RET=`type automake-1.9 > /dev/null 2>&1 || echo fail`
  62 + if [ x$RET != xfail ];
  63 + then
  64 + AUTOMAKE=automake-1.9
  65 + else
  66 + echo "ERROR: this script requires automake-1.9, automake-1.10, automake-1.11 or automake-1.12"
  67 + exit 1
  68 + fi
56 69 fi
57 70 fi
58 71 fi

0 comments on commit c1a168f

Please sign in to comment.
Something went wrong with that request. Please try again.