Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Upgraded to rspec 2.0.0.

  • Loading branch information...
commit 2213aedf8a914314f847e459248d4d7b971ae29c 1 parent 14d2a61
Postmodern authored
1  .rspec
View
@@ -0,0 +1 @@
+--colour --format documentation
12 Rakefile
View
@@ -12,7 +12,7 @@ begin
gem.email = 'postmodern.mod3@gmail.com'
gem.homepage = 'http://github.com/postmodern/combinatorics'
gem.authors = ['Postmodern']
- gem.add_development_dependency 'rspec', '~> 1.3.0'
+ gem.add_development_dependency 'rspec', '~> 2.0.0'
gem.add_development_dependency 'yard', '~> 0.6.0'
gem.add_development_dependency 'jeweler', '~> 1.4.0'
end
@@ -21,14 +21,8 @@ rescue LoadError
puts 'Jeweler (or a dependency) not available. Install it with: gem install jeweler'
end
-require 'spec/rake/spectask'
-Spec::Rake::SpecTask.new(:spec) do |spec|
- spec.libs += %w[lib spec]
- spec.spec_files = FileList['spec/**/*_spec.rb']
- spec.spec_opts = %w[--options .specopts]
-end
-
-task :spec => :check_dependencies
+require 'rspec/core/rake_task'
+RSpec::Core::RakeTask.new
task :default => :spec
begin
8 combinatorics.gemspec
View
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Postmodern"]
- s.date = %q{2010-10-03}
+ s.date = %q{2010-10-10}
s.description = %q{A collection of modules and methods for performing Combinatoric calculations.}
s.email = %q{postmodern.mod3@gmail.com}
s.extra_rdoc_files = [
@@ -66,16 +66,16 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<rspec>, ["~> 1.3.0"])
+ s.add_development_dependency(%q<rspec>, ["~> 2.0.0"])
s.add_development_dependency(%q<yard>, ["~> 0.6.0"])
s.add_development_dependency(%q<jeweler>, ["~> 1.4.0"])
else
- s.add_dependency(%q<rspec>, ["~> 1.3.0"])
+ s.add_dependency(%q<rspec>, ["~> 2.0.0"])
s.add_dependency(%q<yard>, ["~> 0.6.0"])
s.add_dependency(%q<jeweler>, ["~> 1.4.0"])
end
else
- s.add_dependency(%q<rspec>, ["~> 1.3.0"])
+ s.add_dependency(%q<rspec>, ["~> 2.0.0"])
s.add_dependency(%q<yard>, ["~> 0.6.0"])
s.add_dependency(%q<jeweler>, ["~> 1.4.0"])
end
4 spec/spec_helper.rb
View
@@ -1,4 +1,4 @@
require 'rubygems'
-gem 'rspec', '>= 1.3.0'
-require 'spec'
+gem 'rspec', '~> 2.0.0'
+require 'rspec'
Please sign in to comment.
Something went wrong with that request. Please try again.