Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Removed the runtime group.

  • Loading branch information...
commit 3e9baa6f789663fc10480c8ec33f670e3a33e2a7 1 parent 0917378
@postmodern authored
Showing with 73 additions and 69 deletions.
  1. +65 −67 Gemfile
  2. +7 −1 dm-is-counter_cacheable.gemspec
  3. +1 −1  spec/spec_helper.rb
View
132 Gemfile
@@ -3,75 +3,73 @@ source 'http://rubygems.org'
DATA_MAPPER = 'git://github.com/datamapper'
DM_VERSION = '~> 1.0.0'
-group :runtime do
- # We bundle both AS and extlib while extlib compatibility needs to be kept
- # around. require 'dm-core' will ensure that only one is activated at any
- # time though. This is done by trying to require AS components and
- # fallback to requiring extlib in case a LoadError was rescued when
- # requiring AS code.
- #
- # Due to bundle exec activating all groups in the Gemfile, it's
- # recommended to run
- #
- # bundle install --without quality
- #
- # to have a development environment that is able to run the specs.
- # The problem is that metric_fu activates active_support=2.2.3 if we
- # comment out the gem 'activesupport' declaration - have a look below for
- # why we would want to do that (and a bit later, for why that's actually
- # not *strictly* necessary, but recommended)
- #
- # To run the specs using AS, leave this Gemfile as it is and just run:
- #
- # bundle install --without qality
- # ADAPTERS=sqlite3 bundle exec rake spec # or whatever adapter
- #
- # To run the specs using extlib, comment out the: gem 'activesupport' line
- # and run:
- #
- # bundle install --without quality
- # ADAPTERS=sqlite3 bundle exec rake spec # or whatever adapter
- #
- # If you want to run the quality tasks as provided by metric_fu and
- # related gems, you have to run:
- #
- # bundle install
- # bundle exec rake metrics:all
- #
- # Switch back to a bundle without quality gems before trying to run the
- # specs again:
- #
- # bundle install --without quality
- # ADAPTERS=sqlite3 bundle exec rake spec # or whatever adapter
- #
- # It was mentioned above that all this is not *strictly* necessary, and
- # this is true. Currently dm-core does the following as the first require
- # when checking for AS:
- #
- # require 'active_support/core_ext/object/singleton_class'
- #
- # Because this method is not present in activesupport <= 3.0.0.beta,
- # dm-core's feature detection will actually do the "right thing" and fall
- # back to extlib. However, since this is not the case for all dm-more gems
- # as well, the safest thing to do is to respect the more tedious workflow
- # for now, as it will at least be guaranteed to work the same for both
- # dm-core and dm-more.
- #
- # Note that this won't be an issue anymore once we dropped support for
- # extlib completely, or bundler folks decide to support something like
- # "bundle exec --without=foo rake spec" (which probably is not going to
- # happen anytime soon).
- #
-
- if ENV['EXTLIB']
- gem 'extlib', '~> 0.9.15'
- else
- gem 'activesupport', '~> 3.0.0', :require => 'active_support'
- end
-
- gem 'dm-core', DM_VERSION, :git => "#{DATA_MAPPER}/dm-core.git"
+# We bundle both AS and extlib while extlib compatibility needs to be kept
+# around. require 'dm-core' will ensure that only one is activated at any
+# time though. This is done by trying to require AS components and
+# fallback to requiring extlib in case a LoadError was rescued when
+# requiring AS code.
+#
+# Due to bundle exec activating all groups in the Gemfile, it's
+# recommended to run
+#
+# bundle install --without quality
+#
+# to have a development environment that is able to run the specs.
+# The problem is that metric_fu activates active_support=2.2.3 if we
+# comment out the gem 'activesupport' declaration - have a look below for
+# why we would want to do that (and a bit later, for why that's actually
+# not *strictly* necessary, but recommended)
+#
+# To run the specs using AS, leave this Gemfile as it is and just run:
+#
+# bundle install --without qality
+# ADAPTERS=sqlite3 bundle exec rake spec # or whatever adapter
+#
+# To run the specs using extlib, comment out the: gem 'activesupport' line
+# and run:
+#
+# bundle install --without quality
+# ADAPTERS=sqlite3 bundle exec rake spec # or whatever adapter
+#
+# If you want to run the quality tasks as provided by metric_fu and
+# related gems, you have to run:
+#
+# bundle install
+# bundle exec rake metrics:all
+#
+# Switch back to a bundle without quality gems before trying to run the
+# specs again:
+#
+# bundle install --without quality
+# ADAPTERS=sqlite3 bundle exec rake spec # or whatever adapter
+#
+# It was mentioned above that all this is not *strictly* necessary, and
+# this is true. Currently dm-core does the following as the first require
+# when checking for AS:
+#
+# require 'active_support/core_ext/object/singleton_class'
+#
+# Because this method is not present in activesupport <= 3.0.0.beta,
+# dm-core's feature detection will actually do the "right thing" and fall
+# back to extlib. However, since this is not the case for all dm-more gems
+# as well, the safest thing to do is to respect the more tedious workflow
+# for now, as it will at least be guaranteed to work the same for both
+# dm-core and dm-more.
+#
+# Note that this won't be an issue anymore once we dropped support for
+# extlib completely, or bundler folks decide to support something like
+# "bundle exec --without=foo rake spec" (which probably is not going to
+# happen anytime soon).
+#
+
+if ENV['EXTLIB']
+ gem 'extlib', '~> 0.9.15'
+else
+ gem 'activesupport', '~> 3.0.0', :require => 'active_support'
end
+gem 'dm-core', DM_VERSION, :git => "#{DATA_MAPPER}/dm-core.git"
+
group :development do
gem 'rake', '~> 0.8.7'
gem 'jeweler', '~> 1.5.0.pre'
View
8 dm-is-counter_cacheable.gemspec
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Postmodern"]
- s.date = %q{2010-08-31}
+ s.date = %q{2010-09-04}
s.description = %q{A DataMapper plugin for adding counter-cache properties to related models.}
s.email = %q{postmodern.mod3@gmail.com}
s.extra_rdoc_files = [
@@ -56,15 +56,21 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<activesupport>, ["~> 3.0.0"])
+ s.add_runtime_dependency(%q<dm-core>, ["~> 1.0.0"])
s.add_development_dependency(%q<rake>, ["~> 0.8.7"])
s.add_development_dependency(%q<jeweler>, ["~> 1.5.0.pre"])
s.add_development_dependency(%q<rspec>, ["~> 1.3.0"])
else
+ s.add_dependency(%q<activesupport>, ["~> 3.0.0"])
+ s.add_dependency(%q<dm-core>, ["~> 1.0.0"])
s.add_dependency(%q<rake>, ["~> 0.8.7"])
s.add_dependency(%q<jeweler>, ["~> 1.5.0.pre"])
s.add_dependency(%q<rspec>, ["~> 1.3.0"])
end
else
+ s.add_dependency(%q<activesupport>, ["~> 3.0.0"])
+ s.add_dependency(%q<dm-core>, ["~> 1.0.0"])
s.add_dependency(%q<rake>, ["~> 0.8.7"])
s.add_dependency(%q<jeweler>, ["~> 1.5.0.pre"])
s.add_dependency(%q<rspec>, ["~> 1.3.0"])
View
2  spec/spec_helper.rb
@@ -2,7 +2,7 @@
require 'bundler'
begin
- Bundler.setup(:runtime, :test)
+ Bundler.setup(:test)
rescue Bundler::BundlerError => e
STDERR.puts e.message
STDERR.puts "Run `bundle install` to install missing gems"
Please sign in to comment.
Something went wrong with that request. Please try again.