Permalink
Browse files

Upgraded gem dependencies

  • Loading branch information...
1 parent 46def26 commit 011caeb9a20fd0071f166ba54a8d389558a3f82b @dkubb dkubb committed Sep 1, 2011
Showing with 26 additions and 46 deletions.
  1. +6 −6 Gemfile
  2. +2 −2 Rakefile
  3. +18 −38 dm-migrations.gemspec
View
@@ -13,18 +13,18 @@ gem 'dm-core', DM_VERSION, SOURCE => "#{DATAMAPPER}/dm-core#{REPO_POSTFIX}"
group :development do
- gem 'jeweler', '~> 1.5.2'
- gem 'rake', '~> 0.8.7'
- gem 'rspec', '~> 1.3.1'
+ gem 'jeweler', '~> 1.6.4'
+ gem 'rake', '~> 0.9.2'
+ gem 'rspec', '~> 1.3.2'
end
platforms :mri_18 do
group :quality do
- gem 'rcov', '~> 0.9.9'
- gem 'yard', '~> 0.6'
- gem 'yardstick', '~> 0.2'
+ gem 'rcov', '~> 0.9.10'
+ gem 'yard', '~> 0.7.2'
+ gem 'yardstick', '~> 0.4'
end
end
View
@@ -2,7 +2,7 @@ require 'rubygems'
require 'rake'
begin
- gem 'jeweler', '~> 1.5.2'
+ gem 'jeweler', '~> 1.6.4'
require 'jeweler'
Jeweler::Tasks.new do |gem|
@@ -21,5 +21,5 @@ begin
FileList['tasks/**/*.rake'].each { |task| import task }
rescue LoadError
- puts 'Jeweler (or a dependency) not available. Install it with: gem install jeweler -v 1.5.2'
+ puts 'Jeweler (or a dependency) not available. Install it with: gem install jeweler -v 1.6.4'
end
View
@@ -4,14 +4,14 @@
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
- s.name = %q{dm-migrations}
+ s.name = "dm-migrations"
s.version = "1.1.1"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Paul Sadauskas"]
- s.date = %q{2011-04-28}
- s.description = %q{DataMapper plugin for writing and speccing migrations}
- s.email = %q{psadauskas [a] gmail [d] com}
+ s.date = "2011-09-01"
+ s.description = "DataMapper plugin for writing and speccing migrations"
+ s.email = "psadauskas [a] gmail [d] com"
s.extra_rdoc_files = [
"LICENSE",
"README.rdoc"
@@ -26,6 +26,7 @@ Gem::Specification.new do |s|
"db/migrations/2_add_dob_to_people.rb",
"db/migrations/config.rb",
"dm-migrations.gemspec",
+ "examples/Rakefile",
"examples/sample_migration.rb",
"examples/sample_migration_spec.rb",
"lib/dm-migrations.rb",
@@ -73,52 +74,31 @@ Gem::Specification.new do |s|
"tasks/yard.rake",
"tasks/yardstick.rake"
]
- s.homepage = %q{http://github.com/datamapper/dm-migrations}
+ s.homepage = "http://github.com/datamapper/dm-migrations"
s.require_paths = ["lib"]
- s.rubyforge_project = %q{datamapper}
- s.rubygems_version = %q{1.6.2}
- s.summary = %q{DataMapper plugin for writing and speccing migrations}
- s.test_files = [
- "examples/sample_migration.rb",
- "examples/sample_migration_spec.rb",
- "spec/integration/auto_migration_spec.rb",
- "spec/integration/auto_upgrade_spec.rb",
- "spec/integration/migration_runner_spec.rb",
- "spec/integration/migration_spec.rb",
- "spec/integration/sql_spec.rb",
- "spec/isolated/require_after_setup_spec.rb",
- "spec/isolated/require_before_setup_spec.rb",
- "spec/isolated/require_spec.rb",
- "spec/spec_helper.rb",
- "spec/unit/migration_spec.rb",
- "spec/unit/sql/column_spec.rb",
- "spec/unit/sql/postgres_spec.rb",
- "spec/unit/sql/sqlite_extensions_spec.rb",
- "spec/unit/sql/table_creator_spec.rb",
- "spec/unit/sql/table_modifier_spec.rb",
- "spec/unit/sql/table_spec.rb",
- "spec/unit/sql_spec.rb"
- ]
+ s.rubyforge_project = "datamapper"
+ s.rubygems_version = "1.8.10"
+ s.summary = "DataMapper plugin for writing and speccing migrations"
if s.respond_to? :specification_version then
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<dm-core>, ["~> 1.1.0"])
- s.add_development_dependency(%q<jeweler>, ["~> 1.5.2"])
- s.add_development_dependency(%q<rake>, ["~> 0.8.7"])
- s.add_development_dependency(%q<rspec>, ["~> 1.3.1"])
+ s.add_development_dependency(%q<jeweler>, ["~> 1.6.4"])
+ s.add_development_dependency(%q<rake>, ["~> 0.9.2"])
+ s.add_development_dependency(%q<rspec>, ["~> 1.3.2"])
else
s.add_dependency(%q<dm-core>, ["~> 1.1.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
- s.add_dependency(%q<rake>, ["~> 0.8.7"])
- s.add_dependency(%q<rspec>, ["~> 1.3.1"])
+ s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
+ s.add_dependency(%q<rake>, ["~> 0.9.2"])
+ s.add_dependency(%q<rspec>, ["~> 1.3.2"])
end
else
s.add_dependency(%q<dm-core>, ["~> 1.1.0"])
- s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
- s.add_dependency(%q<rake>, ["~> 0.8.7"])
- s.add_dependency(%q<rspec>, ["~> 1.3.1"])
+ s.add_dependency(%q<jeweler>, ["~> 1.6.4"])
+ s.add_dependency(%q<rake>, ["~> 0.9.2"])
+ s.add_dependency(%q<rspec>, ["~> 1.3.2"])
end
end

0 comments on commit 011caeb

Please sign in to comment.