Permalink
Browse files

Updated the Gemfile and use ore-tasks ~> 0.3.0, rspec ~> 2.4.0 and kr…

…amdown.
  • Loading branch information...
1 parent 1d85c1b commit 75480dc9d41eaabba67ab5697cc68910b94f1e76 @postmodern committed Feb 6, 2011
Showing with 15 additions and 70 deletions.
  1. +1 −6 .gitignore
  2. +7 −12 Gemfile
  3. +0 −50 Gemfile.lock
  4. +7 −2 dm-visualizer.gemspec
View
@@ -1,10 +1,5 @@
doc
pkg
-tmp/*
-.DS_Store
+Gemfile.lock
.bundle
.yardoc
-*.db
-*.log
-*.swp
-*~
View
19 Gemfile
@@ -1,17 +1,12 @@
-source 'https://rubygems.org'
+require 'ore/specification'
+
+source :rubygems
gemspec
group(:development) do
- case RUBY_PLATFORM
- when 'java'
- gem 'maruku', '~> 0.6.0'
- else
- gem 'rdiscount', '~> 1.6.3'
- end
-
- gem 'rake', '~> 0.8.7'
- gem 'ore-core', '~> 0.1.0'
- gem 'ore-tasks', '~> 0.2.0'
- gem 'rspec', '~> 2.0.0'
+ gem 'kramdown', '~> 0.12.0'
+ gem 'rake', '~> 0.8.7'
+ gem 'ore-tasks', '~> 0.3.0'
+ gem 'rspec', '~> 2.4.0'
end
View
@@ -1,50 +0,0 @@
-PATH
- remote: .
- specs:
- dm-visualizer (0.1.0)
- dm-core (~> 1.0.0)
- ruby-graphviz (>= 0.9.10)
- thor (~> 0.14.0)
-
-GEM
- remote: https://rubygems.org/
- specs:
- addressable (2.2.0)
- diff-lcs (1.1.2)
- dm-core (1.0.0)
- addressable (~> 2.1)
- extlib (~> 0.9.15)
- extlib (0.9.15)
- ore-core (0.1.0)
- ore-tasks (0.2.0)
- rake (0.8.7)
- rdiscount (1.6.5)
- rspec (2.0.1)
- rspec-core (~> 2.0.1)
- rspec-expectations (~> 2.0.1)
- rspec-mocks (~> 2.0.1)
- rspec-core (2.0.1)
- rspec-expectations (2.0.1)
- diff-lcs (>= 1.1.2)
- rspec-mocks (2.0.1)
- rspec-core (~> 2.0.1)
- rspec-expectations (~> 2.0.1)
- ruby-graphviz (0.9.17)
- thor (0.14.0)
- yard (0.6.0)
-
-PLATFORMS
- ruby
-
-DEPENDENCIES
- bundler (~> 1.0.0)
- dm-core (~> 1.0.0)
- dm-visualizer!
- ore-core (~> 0.1.0)
- ore-tasks (~> 0.2.0)
- rake (~> 0.8.7)
- rdiscount (~> 1.6.3)
- rspec (~> 2.0.0)
- ruby-graphviz (>= 0.9.10)
- thor (~> 0.14.0)
- yard (~> 0.6.0)
View
@@ -5,6 +5,11 @@ begin
# custom logic here
end
rescue NameError
- STDERR.puts "The 'dm-visualizer.gemspec' file requires Ore."
- STDERR.puts "Run `gem install ore-core` to install Ore."
+ begin
+ require 'ore/specification'
+ retry
+ rescue LoadError
+ STDERR.puts "The 'dm-visualizer.gemspec' file requires Ore."
+ STDERR.puts "Run `gem install ore-core` to install Ore."
+ end
end

0 comments on commit 75480dc

Please sign in to comment.