Permalink
Browse files

Dropped Bundler / Jeweler for Ore.

  • Loading branch information...
postmodern committed Oct 28, 2010
1 parent 527fc1c commit ab40e4191476fcd70e9afb3cbb70d920f36fc0b2
Showing with 45 additions and 81 deletions.
  1. +0 −2 .gitignore
  2. +0 −21 Gemfile
  3. +0 −35 Gemfile.lock
  4. +25 −22 Rakefile
  5. +0 −1 VERSION
  6. +20 −0 gemspec.yml
View
@@ -1,4 +1,2 @@
doc
pkg
-.bundle
-.yardoc
View
21 Gemfile
@@ -1,21 +0,0 @@
-source 'https://rubygems.org'
-
-gem 'ffi', '~> 0.6.0'
-
-group(:development) do
- gem 'rake', '~> 0.8.7'
- gem 'jeweler', '~> 1.5.0.pre'
-end
-
-group(:doc) do
- case RUBY_PLATFORM
- when 'java'
- gem 'maruku', '~> 0.6.0'
- else
- gem 'rdiscount', '~> 1.6.3'
- end
-
- gem 'yard', '~> 0.6.0'
-end
-
-gem 'rspec', '~> 2.0.0', :group => [:development, :test]
View
@@ -1,35 +0,0 @@
-GEM
- remote: https://rubygems.org/
- specs:
- diff-lcs (1.1.2)
- ffi (0.6.3)
- rake (>= 0.8.7)
- git (1.2.5)
- jeweler (1.5.0.pre2)
- bundler (>= 1.0.0.rc.5)
- git (>= 1.2.5)
- rake
- rake (0.8.7)
- rdiscount (1.6.5)
- rspec (2.0.0)
- rspec-core (= 2.0.0)
- rspec-expectations (= 2.0.0)
- rspec-mocks (= 2.0.0)
- rspec-core (2.0.0)
- rspec-expectations (2.0.0)
- diff-lcs (>= 1.1.2)
- rspec-mocks (2.0.0)
- rspec-core (= 2.0.0)
- rspec-expectations (= 2.0.0)
- yard (0.6.0)
-
-PLATFORMS
- ruby
-
-DEPENDENCIES
- ffi (~> 0.6.0)
- jeweler (~> 1.5.0.pre)
- rake (~> 0.8.7)
- rdiscount (~> 1.6.3)
- rspec (~> 2.0.0)
- yard (~> 0.6.0)
View
@@ -1,32 +1,35 @@
require 'rubygems'
-require 'bundler'
+require 'rake'
begin
- Bundler.setup(:development, :doc)
-rescue Bundler::BundlerError => e
+ gem 'ore-tasks', '~> 0.1.2'
+ require 'ore/tasks'
+
+ Ore::Tasks.new
+rescue LoadError => e
STDERR.puts e.message
- STDERR.puts "Run `bundle install` to install missing gems"
- exit e.status_code
+ STDERR.puts "Run `gem install ore-tasks` to install 'ore/tasks'."
end
-require 'rake'
-require 'jeweler'
+begin
+ gem 'rspec', '~> 2.0.0'
+ require 'rspec/core/rake_task'
-Jeweler::Tasks.new do |gem|
- gem.name = 'ffi-msgpack'
- gem.licenses = ['MIT']
- gem.summary = %Q{FFI bindings for msgpack}
- gem.description = %Q{Ruby FFI bindings for the msgpack library.}
- gem.email = 'postmodern.mod3@gmail.com'
- gem.homepage = %Q{http://github.com/postmodern/ffi-msgpack}
- gem.authors = ['Postmodern']
- gem.requirements = ['libmsgpack, 0.5.0 or greater']
- gem.has_rdoc = 'yard'
+ RSpec::Core::RakeTask.new
+rescue LoadError => e
+ task :spec do
+ abort "Please run `gem install rspec` to install RSpec."
+ end
end
-
-require 'rspec/core/rake_task'
-RSpec::Core::RakeTask.new
task :default => :spec
-require 'yard'
-YARD::Rake::YardocTask.new
+begin
+ gem 'yard', '~> 0.6.0'
+ require 'yard'
+
+ YARD::Rake::YardocTask.new
+rescue LoadError => e
+ task :yard do
+ abort "Please run `gem install yard` to install YARD."
+ end
+end
View
@@ -1 +0,0 @@
-0.1.4
View
@@ -0,0 +1,20 @@
+name: ffi-msgpack
+version: 0.1.4
+summary: FFI bindings for msgpack
+description: Ruby FFI bindings for the msgpack library.
+license: MIT
+authors: Postmodern
+email: postmodern.mod3@gmail.com
+homepage: http://github.com/postmodern/ffi-msgpack
+has_yard: true
+
+requirements: libmsgpack, 0.5.0 or greater
+
+dependencies:
+ ffi: ~> 0.6.0
+
+development_dependencies:
+ ore: ~> 0.2.0
+ ore-tasks: ~> 0.1.2
+ rspec: ~> 2.0.0
+ yard: ~> 0.6.0

0 comments on commit ab40e41

Please sign in to comment.