Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Truffleruby Error: No available formula with the name "llvm@4" #360

Closed
0xdevalias opened this issue Nov 25, 2019 · 2 comments
Closed

Truffleruby Error: No available formula with the name "llvm@4" #360

0xdevalias opened this issue Nov 25, 2019 · 2 comments

Comments

@0xdevalias
Copy link

Hit this when trying to install truffleruby since brew removed llvm@4 in Homebrew/homebrew-core#46801

oracle/truffleruby#1820 says that llvm isn't required as an external dependency since >= 19.3

This was documented in oracle/truffleruby#1820 and fixed in rvm in rvm/rvm#4815

Ref: oracle/truffleruby#1820 (comment)

ruby-install --install-dir '/Users/devalias/.rbenv/versions/truffleruby-19.3.0' 'truffleruby' '19.3.0'

Error: No available formula with the name "llvm@4"
!!! Installing dependencies failed!

⇒  ruby-install --version
ruby-install: 0.7.0

⇒  brew upgrade ruby-install
Warning: ruby-install 0.7.0 already installed
0xdevalias added a commit to 0xdevalias/dotfiles that referenced this issue Nov 25, 2019
0xdevalias added a commit to 0xdevalias/dotfiles that referenced this issue Nov 25, 2019
0xdevalias added a commit to 0xdevalias/dotfiles that referenced this issue Nov 25, 2019
- workaround for postmodern/ruby-install#360
- workaround for oracle/truffleruby#1820

Signed-off-by: Glenn 'devalias' Grant <glenn@devalias.net>
@eregon
Copy link
Contributor

eregon commented Nov 25, 2019

I made a PR to fix this: #359

@postmodern @havenwood I think we should do a release to let users get that fix.

Until then a workaround (only needed on macOS) is:

$ brew install openssl
$ ruby-install --no-install-deps truffleruby

@havenwood
Copy link
Collaborator

Closing now that the fixed has been released with version 0.7.1.

okuramasafumi added a commit to okuramasafumi/truffleruby that referenced this issue Aug 10, 2020
postmodern/ruby-install#360
According this issue, ruby-install version 0.7.0 has a bug and it's fixed with 0.7.1.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

3 participants