New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Insert mode keeps switching on #482

Open
Nasgarath opened this Issue Jul 28, 2017 · 0 comments

Comments

Projects
None yet
1 participant
@Nasgarath

Nasgarath commented Jul 28, 2017

So I'm noticing yet another weird behavior... as per the title above.

I'm not saying it's impossible for me to hit the insert key inadvertently, but certainly not at this rate! I've never had this problem in SimpleMU (or any other app for that matter) so this seems really unusual. I keep hitting INS to switch back to normal but 5 or 10 minutes later it's back to overwrite mode!!!

I haven't yet been able to make out a pattern, but it might well be some sequence of keys that provokes this. I'll keep an eye out for it and update this comment if I can pinpoint this better.

EDIT: So I think I figured out what's going on as I'm now able to systematically reproduce this behavior. Apparently, overwrite mode is switched on every time I use Shift-Ins to paste text into the input window!!! It does paste the text but it also switches mode...

EDIT2: Just realized I kept writing 'Insert' mode when in reality the problem is that it goes into 'Overwrite' mode! I corrected the above text consequently. Sorry if that lead to any confusion :-o

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment