Skip to content
Browse files

Tagging 1.2.5 and using generic activesupport includes for future ver…

…sions
  • Loading branch information...
1 parent 7c0e4c6 commit e98266c83fdcfa8d5840856411c5eb4dae6d7340 @potatosalad committed Dec 22, 2011
Showing with 81 additions and 69 deletions.
  1. +75 −61 Gemfile.lock
  2. +5 −7 lib/mongoid/data_table.rb
  3. +1 −1 lib/mongoid/data_table/version.rb
View
136 Gemfile.lock
@@ -1,85 +1,94 @@
PATH
remote: .
specs:
- mongoid-data_table (1.2.4)
+ mongoid-data_table (1.2.5)
kaminari (~> 0.12.4)
rails (>= 3.0.0)
GEM
remote: http://rubygems.org/
specs:
- abstract (1.0.0)
- actionmailer (3.0.9)
- actionpack (= 3.0.9)
- mail (~> 2.2.19)
- actionpack (3.0.9)
- activemodel (= 3.0.9)
- activesupport (= 3.0.9)
- builder (~> 2.1.2)
- erubis (~> 2.6.6)
- i18n (~> 0.5.0)
- rack (~> 1.2.1)
- rack-mount (~> 0.6.14)
- rack-test (~> 0.5.7)
- tzinfo (~> 0.3.23)
- activemodel (3.0.9)
- activesupport (= 3.0.9)
- builder (~> 2.1.2)
- i18n (~> 0.5.0)
- activerecord (3.0.9)
- activemodel (= 3.0.9)
- activesupport (= 3.0.9)
- arel (~> 2.0.10)
- tzinfo (~> 0.3.23)
- activeresource (3.0.9)
- activemodel (= 3.0.9)
- activesupport (= 3.0.9)
- activesupport (3.0.9)
- arel (2.0.10)
- bson (1.3.1)
- bson_ext (1.3.1)
- builder (2.1.2)
- diff-lcs (1.1.2)
- erubis (2.6.6)
- abstract (>= 1.0.0)
- i18n (0.5.0)
+ actionmailer (3.1.3)
+ actionpack (= 3.1.3)
+ mail (~> 2.3.0)
+ actionpack (3.1.3)
+ activemodel (= 3.1.3)
+ activesupport (= 3.1.3)
+ builder (~> 3.0.0)
+ erubis (~> 2.7.0)
+ i18n (~> 0.6)
+ rack (~> 1.3.5)
+ rack-cache (~> 1.1)
+ rack-mount (~> 0.8.2)
+ rack-test (~> 0.6.1)
+ sprockets (~> 2.0.3)
+ activemodel (3.1.3)
+ activesupport (= 3.1.3)
+ builder (~> 3.0.0)
+ i18n (~> 0.6)
+ activerecord (3.1.3)
+ activemodel (= 3.1.3)
+ activesupport (= 3.1.3)
+ arel (~> 2.2.1)
+ tzinfo (~> 0.3.29)
+ activeresource (3.1.3)
+ activemodel (= 3.1.3)
+ activesupport (= 3.1.3)
+ activesupport (3.1.3)
+ multi_json (~> 1.0)
+ arel (2.2.1)
+ bson (1.5.2)
+ bson_ext (1.5.2)
+ bson (= 1.5.2)
+ builder (3.0.0)
+ diff-lcs (1.1.3)
+ erubis (2.7.0)
+ hike (1.2.1)
+ i18n (0.6.0)
+ json (1.6.3)
kaminari (0.12.4)
rails (>= 3.0.0)
- mail (2.2.19)
- activesupport (>= 2.3.6)
+ mail (2.3.0)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
- mime-types (1.16)
+ mime-types (1.17.2)
mocha (0.9.12)
- mongo (1.3.1)
- bson (>= 1.3.1)
- mongoid (2.1.7)
- activemodel (~> 3.0)
+ mongo (1.5.2)
+ bson (= 1.5.2)
+ mongoid (2.3.4)
+ activemodel (~> 3.1)
mongo (~> 1.3)
tzinfo (~> 0.3.22)
- polyglot (0.3.2)
- rack (1.2.3)
- rack-mount (0.6.14)
+ multi_json (1.0.4)
+ polyglot (0.3.3)
+ rack (1.3.5)
+ rack-cache (1.1)
+ rack (>= 0.4)
+ rack-mount (0.8.3)
rack (>= 1.0.0)
- rack-test (0.5.7)
+ rack-ssl (1.3.2)
+ rack
+ rack-test (0.6.1)
rack (>= 1.0)
- rails (3.0.9)
- actionmailer (= 3.0.9)
- actionpack (= 3.0.9)
- activerecord (= 3.0.9)
- activeresource (= 3.0.9)
- activesupport (= 3.0.9)
+ rails (3.1.3)
+ actionmailer (= 3.1.3)
+ actionpack (= 3.1.3)
+ activerecord (= 3.1.3)
+ activeresource (= 3.1.3)
+ activesupport (= 3.1.3)
bundler (~> 1.0)
- railties (= 3.0.9)
- railties (3.0.9)
- actionpack (= 3.0.9)
- activesupport (= 3.0.9)
+ railties (= 3.1.3)
+ railties (3.1.3)
+ actionpack (= 3.1.3)
+ activesupport (= 3.1.3)
+ rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
- thor (~> 0.14.4)
- rake (0.9.2)
- rdoc (3.9.1)
+ thor (~> 0.14.6)
+ rake (0.9.2.2)
+ rdoc (3.12)
+ json (~> 1.4)
rspec (2.6.0)
rspec-core (~> 2.6.0)
rspec-expectations (~> 2.6.0)
@@ -89,11 +98,16 @@ GEM
diff-lcs (~> 1.1.2)
rspec-mocks (2.6.0)
shoulda (2.11.3)
+ sprockets (2.0.3)
+ hike (~> 1.2)
+ rack (~> 1.0)
+ tilt (~> 1.1, != 1.3.0)
thor (0.14.6)
+ tilt (1.3.3)
treetop (1.4.10)
polyglot
polyglot (>= 0.3.1)
- tzinfo (0.3.29)
+ tzinfo (0.3.31)
watchr (0.7)
PLATFORMS
View
12 lib/mongoid/data_table.rb
@@ -1,9 +1,7 @@
-require 'active_support/core_ext/object/blank'
-require 'active_support/core_ext/object/to_json'
-require 'active_support/json/encoding'
-require 'active_support/core_ext/string/output_safety'
-require 'active_support/core_ext/string/inflections'
-require 'active_support/core_ext/class/inheritable_attributes'
+require 'active_support/core_ext/object'
+require 'active_support/json'
+require 'active_support/core_ext/string'
+require 'active_support/core_ext/class'
require 'active_support/concern'
require 'mongoid/relations/proxy'
@@ -46,4 +44,4 @@ def to_data_table(controller, options = {}, &block)
end
end
-end
+end
View
2 lib/mongoid/data_table/version.rb
@@ -1,5 +1,5 @@
module Mongoid
module DataTable
- VERSION = "1.2.4"
+ VERSION = "1.2.5"
end
end

0 comments on commit e98266c

Please sign in to comment.
Something went wrong with that request. Please try again.