C Python Shell JavaScript
Switch branches/tags
Nothing to show
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
bindings
champlain-gtk
champlain
demos
docs
m4
tidy
.gitignore
AUTHORS
COPYING
ChangeLog
INSTALL
MAINTAINTERS
Makefile.am
NEWS
README
autogen.sh
champlain-gtk-uninstalled.pc.in
champlain-gtk.pc.in
champlain-memphis-uninstalled.pc.in
champlain-memphis.pc.in
champlain-uninstalled.pc.in
champlain.pc.in
configure.ac
libchamplain.doap

README

libchamplain 0.5 README
=========================

libchamplain is a Clutter based widget to display rich, eye-candy and
interactive maps.

libchamplain requires:

  * glib >= 2.10
  * gio >= 2.16
  * gdk >= 2.10
  * clutter >= 1.0
  * cairo >= 1.4
  * sqlite >= 3.0
  * libsoup >= 2.4.1

If you are building libchamplain-gtk, you will also need:

  * gtk >= 2.12
  * clutter-gtk >= 0.10

If you are building libchamplain with local rendering support, you will
also need:

  *  libmemphis >= 0.2.1

If you are building the Python bindings, you will also need:

  * pygtk >= 2.12
  * pycobject >= 2.10
  * pyclutter >= 1.0

and optionally:

  * pyclutter-gtk >= 0.10
  * pymemphis >= 0.2

The usual rules for building apply -

configure; make; sudo make install; sudo ldconfig

should do the right thing. For more details consult the INSTALL file in this 
directory.

The official website is:
   http://projects.gnome.org/libchamplain

The official mailing list archive is:
   http://mail.gnome.org/mailman/listinfo/libchamplain-list

New bug page on Bugzilla:
   http://bugzilla.gnome.org/simple-bug-guide.cgi?product=libchamplain

libchamplain is licensed under the terms of the GNU Lesser General Public
License, version 2.1 or (at your option) later.