Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Node.js support on windows #174

Closed
daleharvey opened this Issue · 10 comments

3 participants

@daleharvey
Owner

The levelup library we use doesnt work in windows

Level/levelup#5

is the issue for the library, its also worth mentioning that @janl is working on a pure js implementation of leveldb that shouldnt be a problem on windows

@rvagg

@janl have you got anything to share on that yet? Sounds like a lot of fun.

@gedw99

There is a new project that it working at getting leveldb working on windows natively. So no boost headers needed. Its also making c# bindings.
https://github.com/Reactive-Extensions/LevelDB/tree/master/leveldbNative

@Ragg this is probably going to help a fair bit.

@rvagg

"Windows port for LevelDB based on Boost libraries."

Sadly it still needs Boost. I'll look into it though, we may just have to ship some of Boost in the end but I'm pretty sure we have other options too.

@gedw99
@daleharvey
Owner

Seems like levelDown is the best option for this?

@daleharvey daleharvey closed this
@daleharvey daleharvey reopened this
@rvagg

No! Jut keep using LevelUP and you'll get windows support in the next release, no need to change on your end.
Should have the release out in a week (or two) that will give you Windows.

@gedw99

thanks Ragg. This will be amazing

@daleharvey
Owner

ah awesome, yeh I read through the README too quickly, I didnt realise DOWN was just the bindings

@daleharvey
Owner

yay, dep has landed, all should be good

@daleharvey daleharvey closed this
@rvagg

FYI, see requirements for node-gyp on Windows for information on what you'll need to install in order to have npm compile properly for you: https://github.com/TooTallNate/node-gyp#installation

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.