New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

fetch polyfills break `valid` function for Safari after 10.1 #7085

Closed
sgenoud opened this Issue Feb 15, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@sgenoud
Contributor

sgenoud commented Feb 15, 2018

Issue

Following this comment, I looked a bit deeper why pouchdb was telling that I could not use idb in Safari 11 (while it should be available).

The culprit seems to be this line. Safari on a page with a polyfill that replaces fetch is detected as older than 10.1.

So it seems that we need to find a better way to detect version of Safari after 10.1...

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment