Skip to content
This repository

Simple, lightweight HTTP server with accelerated PHP support

Fetching latest commit…

Cannot retrieve the latest commit at this time

README
Pancake is a fast, simple and lightweight HTTP-Server written in PHP with acceleration for PHP-powered websites.

System requirements:

Linux (should also run on other unixoid, POSIX-compliant operating systems with some work)
PHP 5.3.0 or newer compiled with --enable-pcntl --enable-sysvmsg --enable-sockets (PHP 5.4 recommended!)
DeepTrace 1.4.2 or newer (DeepTrace is bundled with Pancake for x86, x86_64 and ARM (armv6l, armv7l) processors)

Installation:

1. cd /usr/local/
2. git clone git://github.com/pp3345/Pancake/
3. cd Pancake/sys
4. chmod +x pancake.sh

Running Pancake:

/usr/local/Pancake/sys/pancake.sh

(as root, you may use sudo)

Compiling DeepTrace:

1. cd
2. git clone git://github.com/NeoXiD/DeepTrace
3. cd DeepTrace
4. phpize
5. ./configure
6. make
7. cp modules/DeepTrace.so /usr/local/Pancake/sys/ext/<arch>_<phpver>.so (for example x86_64_54.so for x86_64 and PHP 5.4)

By downloading and using Pancake you agree to our license: http://pancakehttp.net/license/
This license does not allow using Pancake for commercial websites. If you want to use Pancake for such sites, please contact support [at] pancakehttp [dot] net
Something went wrong with that request. Please try again.