Frequently Asked Questions

Yussuf Khalil edited this page Aug 27, 2013 · 2 revisions

Q: Can I serve Jenkins CI (or other JServlet Containers) using Pancake?

A: Yes! This is possible since Pancake 1.2. Please read the Pancake Wiki page about AJP13 for further information.

Q: I want to use a native PHP SAPI for some reasons. How can I realize this?

A: Since Pancake 1.1 FastCGI is supported. You could install php-fpm and configure Pancake to use php-fpm for PHP requests on specific vHosts. Please read the Pancake Wiki page about FastCGI for further information.

Q: I am trying to use a FastCGI upstream server that does not support multiplexing and I am getting errors on concurrent requests. What can I do?

A: Pancake 1.5 and newer versions support non-multiplexing FastCGI servers. Simply set multiplex: false in the FastCGI configuration.

You have a question and can't find the answer in the Wiki? Please don't hesitate contacting support [at] pancakehttp [dot] net. We will try to answer any question you have about Pancake as fast as possible. :)