Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Setting up framework

  • Loading branch information...
commit 6cec45fd845f7a344f62112bf03699a88c302f50 1 parent fafa5a3
@prathamesh7pute authored
View
1  .gitignore
@@ -0,0 +1 @@
+node_modules
View
3  .travis.yml
@@ -0,0 +1,3 @@
+language: node_js
+node_js:
+ - 0.8
View
7 MAKEFILE
@@ -0,0 +1,7 @@
+REPORTER = dot
+
+test:
+ @./node_modules/.bin/mocha \
+ --reporter $(REPORTER)
+
+.PHONY: test
View
8 README.md
@@ -1,4 +1,4 @@
-coral
-=====
-
-Solid Node JS framework to dynamically create REST apps
+=====
+
+Node JS framework to dynamically create REST apps
View
1  index.js
@@ -0,0 +1 @@
+module.exports = require('./lib/coral');
View
1  lib/coral.js
@@ -0,0 +1 @@
+exports.version = '0.0.1';
View
34 package.json
@@ -0,0 +1,34 @@
+{
+ "name": "Coral",
+ "description": "Node JS framework to dynamically create REST apps",
+ "version": "0.0.1",
+ "author": {
+ "name": "Prathamesh Satpute (A-1 Enterprises)",
+ "email": "prathamesh.satpute@a-1enterprises.in"
+ },
+ "keywords": ["node", "backbone","mongoose"],
+ "scripts": {
+ "test": "make test"
+ },
+ "repository": {
+ "type": "git",
+ "url": "https://github.com/a-1/coral.git"
+ },
+ "dependencies": {
+ "express": "3.0.x",
+ "mongoose": "2.7.x",
+ "jade": "0.27.x",
+ "winston": "0.6.x",
+ "uglify-js": "1.3.x",
+ "underscore": "1.3.x"
+ },
+ "devDependencies": {
+ "jshint": "0.6.1",
+ "mocha": "*",
+ "should": "*"
+ },
+ "engines": {
+ "node": "0.8.x",
+ "npm": "1.1.x"
+ }
+}
View
17 test/coral.js
@@ -0,0 +1,17 @@
+/**
+ * Test dependencies.
+ */
+
+var coral = require('../lib/coral'),
+ should = require('should');
+
+/**
+ * Tests.
+ */
+describe('coral', function() {
+
+ it('must expose version number', function() {
+ coral.version.should.match(/[0-9]+\.[0-9]+\.[0-9]+/);
+ });
+
+});
Please sign in to comment.
Something went wrong with that request. Please try again.