Skip to content


Subversion checkout URL

You can clone with
Download ZIP


Suggestion to slightly improve the error report from a user's perspective #282

shevegen opened this Issue · 0 comments

2 participants


example_helper.rb requires this:

require 'rubygems'

However, when this is used, it seems as if you can only use a gem. I show you what I mean:

I am running "ruby example_helper.rb" and it fails with an error.

/Programs/Ruby/1.8.7p334/lib/ruby/gems/1.8/gems/bundler-1.0.18/lib/bundler/resolver.rb:280:in `resolve': Could not find gem 'ttfunk (~> 1.0.2)' in any of the gem sources listed in your Gemfile. (Bundler::GemNotFound)

This is correct - I did not install ttfunk as a gem. I simply downloaded a .tar.gz and used setup.rb to install it.

Requiring ttfunk alone also works for me after that:

require 'ttfunk' # => true

I think it would be nice if both ways would be supported - the gem-only requirement, and also the non-gem way to run it.

If that is unwanted by the author, then I suggest to give a more accurate error reporting and even suggest to the user that only the gem-way to install something is supported.

An alternative could be to use two test examples, one that requires you to have rubygems, and the other one that simply does the old, classical way of 'require', but without gems.

@yob yob closed this in e2ab0ff
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.