New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

how to solve bad page error #1

Closed
balasivagnanam opened this Issue Aug 6, 2015 · 18 comments

Comments

Projects
None yet
3 participants
@balasivagnanam

I have installed this plugin and then I made the configuration, enabled and then I saw the button in customer page and also in the customer grid, but if I click it it goes to a routing

http://synergo.com.sg/sample/ergoshop/index.php/admin/prxgt_lgas_front/login/as/

Which comes as a bad page that doesn't exist.

How to fix this?

@flancer64

This comment has been minimized.

Show comment
Hide comment
@flancer64

flancer64 Aug 6, 2015

Contributor

Could you give me a Magento version you use?

Contributor

flancer64 commented Aug 6, 2015

Could you give me a Magento version you use?

@balasivagnanam

This comment has been minimized.

Show comment
Hide comment
@balasivagnanam

balasivagnanam Aug 6, 2015

Magento ver. 1.9.2.0

Magento ver. 1.9.2.0

@flancer64

This comment has been minimized.

Show comment
Hide comment
@flancer64

flancer64 Aug 6, 2015

Contributor

I'll check this Mage version.

Contributor

flancer64 commented Aug 6, 2015

I'll check this Mage version.

@flancer64

This comment has been minimized.

Show comment
Hide comment
@flancer64

flancer64 Aug 6, 2015

Contributor

I have checked dev-master version on 1.9.2.0 - it works. Could you give me access to the sample shop?

Contributor

flancer64 commented Aug 6, 2015

I have checked dev-master version on 1.9.2.0 - it works. Could you give me access to the sample shop?

@balasivagnanam

This comment has been minimized.

Show comment
Hide comment
@balasivagnanam

balasivagnanam Aug 7, 2015

sure I will.. emailed you.. in your personal email..

On Fri, Aug 7, 2015 at 12:44 AM, Alex Gusev notifications@github.com
wrote:

I have checked dev-master version on 1.9.2.0 - it works. Could you give me
access to the sample shop?


Reply to this email directly or view it on GitHub
#1 (comment)
.

Thanks,
Bala

sure I will.. emailed you.. in your personal email..

On Fri, Aug 7, 2015 at 12:44 AM, Alex Gusev notifications@github.com
wrote:

I have checked dev-master version on 1.9.2.0 - it works. Could you give me
access to the sample shop?


Reply to this email directly or view it on GitHub
#1 (comment)
.

Thanks,
Bala

@flancer64

This comment has been minimized.

Show comment
Hide comment
@flancer64

flancer64 Aug 7, 2015

Contributor

Please email me to alex@flancer.lv

Contributor

flancer64 commented Aug 7, 2015

Please email me to alex@flancer.lv

@flancer64

This comment has been minimized.

Show comment
Hide comment
@flancer64

flancer64 Aug 11, 2015

Contributor

This was frontend routing bug. Fixed. Please use version 1.2.0 or above. This module is available at default PHP Composer repository (https://packagist.org/packages/praxigento/mage_ext_login_as).

Bala, thanks for you support!

Contributor

flancer64 commented Aug 11, 2015

This was frontend routing bug. Fixed. Please use version 1.2.0 or above. This module is available at default PHP Composer repository (https://packagist.org/packages/praxigento/mage_ext_login_as).

Bala, thanks for you support!

@flancer64 flancer64 closed this Aug 11, 2015

@balasivagnanam

This comment has been minimized.

Show comment
Hide comment
@balasivagnanam

balasivagnanam Aug 11, 2015

@flancer64 you are awesome :) thanks a lot for fixing this and helping in this :)

@flancer64 you are awesome :) thanks a lot for fixing this and helping in this :)

@balasivagnanam

This comment has been minimized.

Show comment
Hide comment
@balasivagnanam

balasivagnanam Aug 12, 2015

will you be publishing this to magento connect sooner?

will you be publishing this to magento connect sooner?

@flancer64

This comment has been minimized.

Show comment
Hide comment
@flancer64

flancer64 Aug 12, 2015

Contributor

Yes, I have published ext just now. You sample app has new updated version of the module.

Contributor

flancer64 commented Aug 12, 2015

Yes, I have published ext just now. You sample app has new updated version of the module.

@LuizSantos1

This comment has been minimized.

Show comment
Hide comment
@LuizSantos1

LuizSantos1 Jun 23, 2017

Please make it compatible with Magento 1.9.3.2 and 1.9.3.3 after Security patch 9767, it has stopped working

Please make it compatible with Magento 1.9.3.2 and 1.9.3.3 after Security patch 9767, it has stopped working

@flancer64

This comment has been minimized.

Show comment
Hide comment
@flancer64

flancer64 Jun 23, 2017

Contributor

Hello, @LuizSantos1 .

As I see, v. 1.9.3.3 has SUPEE-9767 included. I've just checked 2 stores under Magento 1.9.3.3 - LoginAs ext works correctly. Could you give some error messages (php_errors.log, apache_error.log or ./var/report/XXXXXXX) related to this issue?

Contributor

flancer64 commented Jun 23, 2017

Hello, @LuizSantos1 .

As I see, v. 1.9.3.3 has SUPEE-9767 included. I've just checked 2 stores under Magento 1.9.3.3 - LoginAs ext works correctly. Could you give some error messages (php_errors.log, apache_error.log or ./var/report/XXXXXXX) related to this issue?

@LuizSantos1

This comment has been minimized.

Show comment
Hide comment
@LuizSantos1

LuizSantos1 Jun 23, 2017

@LuizSantos1

This comment has been minimized.

Show comment
Hide comment
@LuizSantos1

LuizSantos1 Jun 23, 2017

@flancer64

This comment has been minimized.

Show comment
Hide comment
@flancer64

flancer64 Jun 24, 2017

Contributor

@LuizSantos1 , thanks for your investigation. I have changed "Admin routing compatibility mode for extensions" option to "Disabled" in "System - Configuration - Advanced - Security" section and have got the same error (404 - Page not found").

I'll try to fix it.

Contributor

flancer64 commented Jun 24, 2017

@LuizSantos1 , thanks for your investigation. I have changed "Admin routing compatibility mode for extensions" option to "Disabled" in "System - Configuration - Advanced - Security" section and have got the same error (404 - Page not found").

I'll try to fix it.

@flancer64

This comment has been minimized.

Show comment
Hide comment
@flancer64

flancer64 Jun 27, 2017

Contributor

@LuizSantos1 , fixed. You can try to use version 1.2.2 that works with disabled "Admin routing compatibility mode for extensions" option.

Thanks for your cooperation.

Contributor

flancer64 commented Jun 27, 2017

@LuizSantos1 , fixed. You can try to use version 1.2.2 that works with disabled "Admin routing compatibility mode for extensions" option.

Thanks for your cooperation.

@LuizSantos1

This comment has been minimized.

Show comment
Hide comment
@LuizSantos1

LuizSantos1 Jun 27, 2017

Thanks a lot, I will test it later.
Could you please tell us the files or lines changed? I am asking it because
other extensions have the same issue, so I need to enable "Admin routing compatibility mode for extensions" all the time in order to use them, which is very time consuming...

Thanks in advance!

LuizSantos1 commented Jun 27, 2017

Thanks a lot, I will test it later.
Could you please tell us the files or lines changed? I am asking it because
other extensions have the same issue, so I need to enable "Admin routing compatibility mode for extensions" all the time in order to use them, which is very time consuming...

Thanks in advance!

@flancer64

This comment has been minimized.

Show comment
Hide comment
@flancer64

flancer64 Jun 28, 2017

Contributor

The main reason is a router's name in admin area. Compare old version and new one.

Hope, it helps.

Contributor

flancer64 commented Jun 28, 2017

The main reason is a router's name in admin area. Compare old version and new one.

Hope, it helps.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment