Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Broken ruby_parser version #1429

Closed
epoberezhny opened this issue Nov 11, 2019 · 4 comments
Closed

Broken ruby_parser version #1429

epoberezhny opened this issue Nov 11, 2019 · 4 comments

Comments

@epoberezhny
Copy link

@epoberezhny epoberezhny commented Nov 11, 2019

Background

Brakeman version: 4.7.1
Rails version: 5.2.2.1
Ruby version: 2.6.5

Parse Error

Could you please rebuild brakeman with the 13.4.1 version of ruby_parser, because the 13.4.0 version is broken? I can not use brakeman due to seattlerb/ruby_parser#299

@presidentbeef

This comment has been minimized.

Copy link
Owner

@presidentbeef presidentbeef commented Nov 11, 2019

Hi @epoberezhny. I don't know when I will do another release. In the meantime, I suggest using the brakeman-lib gem and then you can install the version of ruby_parser that works for you.

@epoberezhny

This comment has been minimized.

Copy link
Author

@epoberezhny epoberezhny commented Nov 12, 2019

Hi @presidentbeef ! Thanks for the quick answer. I look forward to a new release

@presidentbeef

This comment has been minimized.

Copy link
Owner

@presidentbeef presidentbeef commented Nov 25, 2019

Brakeman 4.7.2 vendors the latest ruby_parser 3.14.1.

@epoberezhny

This comment has been minimized.

Copy link
Author

@epoberezhny epoberezhny commented Nov 26, 2019

Awesome, thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.