Skip CheckSymbolDos if ruby_version > 2.2 #928

Closed
mintuhouse opened this Issue Aug 26, 2016 · 1 comment

Projects

None yet

2 participants

@mintuhouse

https://github.com/presidentbeef/brakeman/blob/master/lib/brakeman/checks/check_symbol_dos.rb
Currently this is checking for Rails 5 for which 2.2 is required

@presidentbeef
Owner

Sure, no problem.

You can also exclude the check with -x CheckSymbolDoS.

@presidentbeef presidentbeef added a commit that referenced this issue Oct 15, 2016
@presidentbeef Attempt to get and use Ruby version from app
either .ruby-version or Gemfile

Closes #928
11f5fb4
@presidentbeef presidentbeef added a commit that referenced this issue Oct 15, 2016
@presidentbeef Attempt to get and use Ruby version from app
either .ruby-version or Gemfile

Closes #928
6d285b4
@presidentbeef presidentbeef added a commit that referenced this issue Oct 15, 2016
@presidentbeef Attempt to get and use Ruby version from app
either .ruby-version or Gemfile

Closes #928
87e5220
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment