Skip to content
Permalink
Browse files

Upgrade to PHPUnit 7.X, use pcov instead of phpdbg (#1746)

  • Loading branch information...
connerbw committed Jul 31, 2019
1 parent bbe4190 commit 3421ecc013a163f6ad4e5f5daca5043c12fd97e2
Showing with 132 additions and 230 deletions.
  1. +3 −2 .travis.yml
  2. +1 −2 composer.json
  3. +127 −222 composer.lock
  4. +1 −4 phpunit.xml
@@ -48,12 +48,13 @@ install:
- ulimit -n 4096
before_script:
- if php -v | grep -q 'Xdebug'; then phpenv config-rm xdebug.ini; fi
- pecl install pcov
- bash bin/install-wp-tests.sh wordpress_test root '' localhost $WP_VERSION
script:
- npm run lint
- npm run build:production
- if [[ ${TRAVIS_PHP_VERSION:0:3} == "7.1" ]]; then phpdbg -qrr -d memory_limit=-1 vendor/bin/phpunit --configuration phpunit.xml --coverage-clover coverage.xml; fi
- if [[ ${TRAVIS_PHP_VERSION:0:3} != "7.1" ]]; then vendor/bin/phpunit --configuration phpunit.xml; fi
- if [[ ${TRAVIS_PHP_VERSION:0:3} == "7.2" ]]; then composer require pcov/clobber; vendor/bin/pcov clobber; vendor/bin/phpunit --configuration phpunit.xml --coverage-clover coverage.xml; fi
- if [[ ${TRAVIS_PHP_VERSION:0:3} != "7.2" ]]; then vendor/bin/phpunit --configuration phpunit.xml; fi
- vendor/bin/phpcs --standard=phpcs.ruleset.xml *.php inc/ bin/
after_success:
- bash <(curl -s https://codecov.io/bash)
@@ -46,8 +46,7 @@
"fale/isbn": "^3.0"
},
"require-dev": {
"mybuilder/phpunit-accelerator": "^2.0",
"phpunit/phpunit": "^6.5",
"phpunit/phpunit": "^7",
"pressbooks/coding-standards": "^1.0"
},
"suggest": {

0 comments on commit 3421ecc

Please sign in to comment.
You can’t perform that action at this time.