Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

WooCommerce V3.0 and Flexslider #427

Closed
Nikeo opened this issue Apr 6, 2017 · 4 comments
Closed

WooCommerce V3.0 and Flexslider #427

Nikeo opened this issue Apr 6, 2017 · 4 comments

Comments

@Nikeo
Copy link
Collaborator

@Nikeo Nikeo commented Apr 6, 2017

https://wordpress.org/support/topic/no-images-in-index-scroller-after-update/#post-9000081

@Nikeo
Copy link
Collaborator Author

@Nikeo Nikeo commented Apr 6, 2017

Hi @eri-trabiccolo since you're working on WC compat, could you have a look to this one when you get the chance ?
thank you

'd

@eri-trabiccolo
Copy link
Contributor

@eri-trabiccolo eri-trabiccolo commented Apr 6, 2017

Ah,
just checked it worked on the product, I thought there would have been an issue there but not in home :D

@eri-trabiccolo
Copy link
Contributor

@eri-trabiccolo eri-trabiccolo commented Apr 6, 2017

Not able to reproduce this issue on my side.
Anyway...

  1. flexslider hueman's version has no rtl option
  2. woocommerce's version has rtl option and it forces to true when no rtl option is passed and the html direction is rtl
  3. because of the same script handle name (flexslider), when woocommerce is enabled the woocommerce's flexslider is loaded instead of the hueman's one (because of the registering order)

These points makes useless for us to pass the rtl option.
I don't think that's the real problem.

The only thing in 3) that maybe can cause problems is the fact that woocommerce's flexslider is printed in the footer, while we use to print it in the header... but we fire the slider on document ready so..

No clue honestly :(

eri-trabiccolo added a commit to eri-trabiccolo/hueman that referenced this issue Apr 6, 2017
+ pass rtl param on flexslider init

see presscustomizr#427
fixes flexslider not working in rtl websites
@eri-trabiccolo
Copy link
Contributor

@eri-trabiccolo eri-trabiccolo commented Apr 6, 2017

See the discussion on wp.org
The real problem is that the flexslider never displayed fine on rtl websites.
It needed some CSS rules which are not needed anymore, or better are in conflict, with the latest flexslider rtl behaviour (rtl param added in 2.6.1).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants