Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error: could not execute sql missing \"=\" after \"ports\", in connection info strings. #350

Open
guadaran opened this issue Apr 11, 2019 · 1 comment

Comments

2 participants
@guadaran
Copy link

commented Apr 11, 2019

Hi,

I have a prest instance running 24x7 on a server. I have a simple SQL script like this:

SELECT count(*) FROM table WHERE attribute = "{{.attr}}"

But sometimes this script returns this error:

{
"error": "could not execute sql missing "=" after "ports", in connection info strings",SELECT count(*)\nFROM table WHERE attribute = '\u003cno value\u003e'"
}

Environment:

CentOS Linux release 7.2.1511 (Core)
pRest instaled from binary
pRest v0.3.4
pRest endpoint: GET /_QUERIES/sql/count
PostgreSQL 10.7

Thank you.

@ohtejera

This comment has been minimized.

Copy link

commented Apr 15, 2019

Hi,

I saw the same behavior, I think that you can replicate this if you just execute something like this:

GET /dead ports,/blabla.bak

Whit this request you will see that all subsequent requests will show the error that you mention:

"error": "could not execute sql missing "=" after "ports", in connection info strings"
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.