Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Release script: Commit and push after updating dependents count #9183

Merged

Conversation

sosukesuzuki
Copy link
Member

I did this manually when I ran the release script before, but I think it useful to be able to do it automatically.

Try the playground for this PR

@fisker
Copy link
Member

fisker commented Sep 11, 2020

Do we need chack --dry-run?

@sosukesuzuki
Copy link
Member Author

Do we need chack --dry-run?

Sounds good. I'll try to use --dry-run for release script after merging this.

@sosukesuzuki sosukesuzuki merged commit 10a8eff into prettier:master Sep 11, 2020
@sosukesuzuki sosukesuzuki deleted the fix-update-dependents-count branch September 11, 2020 18:49
medikoo added a commit to medikoo/prettier-elastic that referenced this pull request May 7, 2021
Build(deps-dev): Bump @typescript-eslint/types from 3.10.0 to 3.10.1 (#9066)

Bumps [@typescript-eslint/types](https://github.com/typescript-eslint/typescript-eslint/tree/HEAD/packages/visitor-keys) from 3.10.0 to 3.10.1.
- [Release notes](https://github.com/typescript-eslint/typescript-eslint/releases)
- [Changelog](https://github.com/typescript-eslint/typescript-eslint/blob/master/packages/visitor-keys/CHANGELOG.md)
- [Commits](https://github.com/typescript-eslint/typescript-eslint/commits/v3.10.1/packages/visitor-keys)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump @typescript-eslint/typescript-estree from 3.10.0 to 3.10.1 (#9064)

Bumps [@typescript-eslint/typescript-estree](https://github.com/typescript-eslint/typescript-eslint/tree/HEAD/packages/typescript-estree) from 3.10.0 to 3.10.1.
- [Release notes](https://github.com/typescript-eslint/typescript-eslint/releases)
- [Changelog](https://github.com/typescript-eslint/typescript-eslint/blob/master/packages/typescript-estree/CHANGELOG.md)
- [Commits](https://github.com/typescript-eslint/typescript-eslint/commits/v3.10.1/packages/typescript-estree)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Fix yarn.lock

Build(deps): Bump editorconfig-to-prettier from 0.1.1 to 0.2.0 (#9067)

* Build(deps): Bump editorconfig-to-prettier from 0.1.1 to 0.2.0

Bumps [editorconfig-to-prettier](https://github.com/josephfrazier/editorconfig-to-prettier) from 0.1.1 to 0.2.0.
- [Release notes](https://github.com/josephfrazier/editorconfig-to-prettier/releases)
- [Commits](https://github.com/josephfrazier/editorconfig-to-prettier/compare/v0.1.1...v0.2.0)

Signed-off-by: dependabot[bot] <support@github.com>

* Remove `insertFinalNewline`

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Co-authored-by: fisker <lionkay@gmail.com>
Build(deps): Bump @angular/compiler from 10.0.12 to 10.0.14 (#9077)

Support `.wxs` &  `.wxss` (#9081)

* Support `.wxs` &  `.wxss`

* Spell check

* Add comments

* Spellcheck
Turn test setup file to lazy load (#9080)

Update js `languages` (#9073)

Rename native shims to `.mjs` (#9079)

Respect spacing between template values in embedded css (#9078)

* Respect no space for embedded css

* Fix by lint

* Add changelog
CI: remove `fetch-depth` (#9086)

Add pure css parser (#7933)

Build(deps-dev): Bump @types/node from 14.6.0 to 14.6.1 (#9090)

Bumps [@types/node](https://github.com/DefinitelyTyped/DefinitelyTyped/tree/HEAD/types/node) from 14.6.0 to 14.6.1.
- [Release notes](https://github.com/DefinitelyTyped/DefinitelyTyped/releases)
- [Commits](https://github.com/DefinitelyTyped/DefinitelyTyped/commits/HEAD/types/node)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump rollup from 2.26.5 to 2.26.6 (#9089)

Bumps [rollup](https://github.com/rollup/rollup) from 2.26.5 to 2.26.6.
- [Release notes](https://github.com/rollup/rollup/releases)
- [Changelog](https://github.com/rollup/rollup/blob/master/CHANGELOG.md)
- [Commits](https://github.com/rollup/rollup/compare/v2.26.5...v2.26.6)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump @glimmer/syntax from 0.59.0 to 0.60.0 (#9088)

Bumps [@glimmer/syntax](https://github.com/glimmerjs/glimmer-vm) from 0.59.0 to 0.60.0.
- [Release notes](https://github.com/glimmerjs/glimmer-vm/releases)
- [Changelog](https://github.com/glimmerjs/glimmer-vm/blob/master/CHANGELOG.md)
- [Commits](https://github.com/glimmerjs/glimmer-vm/compare/v0.59.0...v0.60.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @glimmer/reference from 0.59.0 to 0.60.0 (#9091)

cleanup: remove extra parent.object conditions (#8878)

from src/language-js/needs-parens.js
Updated plugin documentation (#8407)

* Updated plugin documentation

* Spellcheck

* Wording change: attributes -> properties

* Corrected explanation

* Wording fixes

* Proofreading/nitpicking

* Reformat

* Reformat with --prose-wrap always

* Revert "Reformat with --prose-wrap always"

This reverts commit 2518a08a32818caa640303aede1c54a7ee1e5ab9.

* Reformat with --prose-wrap always

* Reformat with --prose-wrap never

Co-authored-by: Georgii Dolzhykov <thorn.mailbox@gmail.com>
update stable docs (plugins.md)

Build(deps-dev): Bump @types/node from 14.6.1 to 14.6.2 (#9108)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump rollup-plugin-terser from 7.0.0 to 7.0.1 (#9110)

Bumps [rollup-plugin-terser](https://github.com/TrySound/rollup-plugin-terser) from 7.0.0 to 7.0.1.
- [Release notes](https://github.com/TrySound/rollup-plugin-terser/releases)
- [Commits](https://github.com/TrySound/rollup-plugin-terser/commits)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump mem from 6.1.0 to 6.1.1 (#9111)

Bumps [mem](https://github.com/sindresorhus/mem) from 6.1.0 to 6.1.1.
- [Release notes](https://github.com/sindresorhus/mem/releases)
- [Commits](https://github.com/sindresorhus/mem/compare/v6.1.0...v6.1.1)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump postcss from 7.0.30 to 7.0.32 (#9107)

Bumps [postcss](https://github.com/postcss/postcss) from 7.0.30 to 7.0.32.
- [Release notes](https://github.com/postcss/postcss/releases)
- [Changelog](https://github.com/postcss/postcss/blob/master/CHANGELOG.md)
- [Commits](https://github.com/postcss/postcss/compare/7.0.30...7.0.32)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump rollup from 2.26.6 to 2.26.8 (#9109)

Bumps [rollup](https://github.com/rollup/rollup) from 2.26.6 to 2.26.8.
- [Release notes](https://github.com/rollup/rollup/releases)
- [Changelog](https://github.com/rollup/rollup/blob/master/CHANGELOG.md)
- [Commits](https://github.com/rollup/rollup/compare/v2.26.6...v2.26.8)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Remove the need to add full GitHub links in changelog entry titles (#9104)

Redirect `babel` parser to `babel-flow` (#9071)

Co-authored-by: Georgii Dolzhykov <thorn.mailbox@gmail.com>
Glimmer: Use common `locationToOffset` (#9106)

Remove a unnecessary check in css printer (#9094)

Build(deps-dev): Bump @babel/preset-env from 7.11.0 to 7.11.5 (#9118)

Remove `css` parser from `isLessParser` check (#9092)

Build(deps-dev): Bump @babel/types from 7.11.0 to 7.11.5 (#9122)

Make `isSCSS*` function stricter (#9093)

Build(deps-dev): Bump @babel/core from 7.11.4 to 7.11.5 (#9117)

Refactor `RecoveredErrors` rethrow (#9075)

Build(deps-dev): Bump eslint from 7.7.0 to 7.8.0 (#9120)

Bumps [eslint](https://github.com/eslint/eslint) from 7.7.0 to 7.8.0.
- [Release notes](https://github.com/eslint/eslint/releases)
- [Changelog](https://github.com/eslint/eslint/blob/master/CHANGELOG.md)
- [Commits](https://github.com/eslint/eslint/compare/v7.7.0...v7.8.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Update cspell.json (#9105)

Build(deps): Bump @babel/parser from 7.11.2 to 7.11.5 (#8947)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Co-authored-by: fisker <lionkay@gmail.com>
Add Yarn 2 files to .gitignore (#9124)

Build(deps-dev): Bump eslint from 7.8.0 to 7.8.1 (#9126)

Bumps [eslint](https://github.com/eslint/eslint) from 7.8.0 to 7.8.1.
- [Release notes](https://github.com/eslint/eslint/releases)
- [Changelog](https://github.com/eslint/eslint/blob/master/CHANGELOG.md)
- [Commits](https://github.com/eslint/eslint/compare/v7.8.0...v7.8.1)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump rollup from 2.26.8 to 2.26.9 (#9127)

Bumps [rollup](https://github.com/rollup/rollup) from 2.26.8 to 2.26.9.
- [Release notes](https://github.com/rollup/rollup/releases)
- [Changelog](https://github.com/rollup/rollup/blob/master/CHANGELOG.md)
- [Commits](https://github.com/rollup/rollup/compare/v2.26.8...v2.26.9)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
GraphQL: Fix formatting for directives in fields (#9116)

* Fix formatting for directives in FragmentDefinition

* Add changelog

* Update src/language-graphql/printer-graphql.js

Co-authored-by: Georgii Dolzhykov <thorn.mailbox@gmail.com>

* Fix by Prettier

* Refactor

Co-authored-by: Georgii Dolzhykov <thorn.mailbox@gmail.com>
Build(deps-dev): Bump @types/node from 14.6.2 to 14.6.3 (#9133)

Bumps [@types/node](https://github.com/DefinitelyTyped/DefinitelyTyped/tree/HEAD/types/node) from 14.6.2 to 14.6.3.
- [Release notes](https://github.com/DefinitelyTyped/DefinitelyTyped/releases)
- [Commits](https://github.com/DefinitelyTyped/DefinitelyTyped/commits/HEAD/types/node)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump @glimmer/syntax from 0.60.0 to 0.61.2 (#9131)

Bumps [@glimmer/syntax](https://github.com/glimmerjs/glimmer-vm) from 0.60.0 to 0.61.2.
- [Release notes](https://github.com/glimmerjs/glimmer-vm/releases)
- [Changelog](https://github.com/glimmerjs/glimmer-vm/blob/master/CHANGELOG.md)
- [Commits](https://github.com/glimmerjs/glimmer-vm/compare/v0.60.0...v0.61.2)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @glimmer/reference from 0.60.0 to 0.61.2 (#9134)

Fix line breaks for CSS in JS (#9136)

* Fix 2.1 regression for css-in-js

* Add changelog
Build(deps): Bump decompress from 4.2.0 to 4.2.1 in /website (#9140)

Bumps [decompress](https://github.com/kevva/decompress) from 4.2.0 to 4.2.1.
- [Release notes](https://github.com/kevva/decompress/releases)
- [Commits](https://github.com/kevva/decompress/compare/v4.2.0...v4.2.1)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @babel/core from 7.11.5 to 7.11.6 (#9142)

Build(deps-dev): Bump @types/node from 14.6.3 to 14.6.4 (#9141)

Build(deps): Bump flow-parser from 0.132.0 to 0.133.0 (#9135)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Co-authored-by: fisker <lionkay@gmail.com>
Run full test on every parser (#9070)

* Refactor test

* Fix

* Improve `hasPragma` & `insertPragma` on files has BOM

* Fix `coreFormat` cursorOffset

* Code style

* Update snapshots

* Refactor

* Restore BOM test

* Add export

* Empty file

* return after SyntaxError

* EOL test

* Fix eol tests

* Named export

* Tweak matrix

* Disable on `requirePragma`

* Disable `cr` test

* Simplify logic

* Update `verbose`

* Remove `test:full-test`

* Typo
Build(deps-dev): Bump eslint-plugin-jest from 23.20.0 to 24.0.0 (#9159)

Bumps [eslint-plugin-jest](https://github.com/jest-community/eslint-plugin-jest) from 23.20.0 to 24.0.0.
- [Release notes](https://github.com/jest-community/eslint-plugin-jest/releases)
- [Changelog](https://github.com/jest-community/eslint-plugin-jest/blob/master/CHANGELOG.md)
- [Commits](https://github.com/jest-community/eslint-plugin-jest/compare/v23.20.0...v24.0.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump jest-watch-typeahead from 0.6.0 to 0.6.1 (#9157)

Bumps [jest-watch-typeahead](https://github.com/jest-community/jest-watch-typeahead) from 0.6.0 to 0.6.1.
- [Release notes](https://github.com/jest-community/jest-watch-typeahead/releases)
- [Changelog](https://github.com/jest-community/jest-watch-typeahead/blob/master/CHANGELOG.md)
- [Commits](https://github.com/jest-community/jest-watch-typeahead/compare/v0.6.0...v0.6.1)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump rollup-plugin-terser from 7.0.1 to 7.0.2 (#9160)

Build(deps-dev): Bump rollup from 2.26.9 to 2.26.10 (#9158)

YAML: Fix printing doubles a blank line before a comment (#9143)

* Print hardline for endComments only when under mappingValue

* Add changelog

* Fix from linter

* Update tests

* Use shouldPrintEndCommentsWithAlign

* Add tests

* Add test

* Fix format

* Update test

* Test map too

* Update tests

* `shouldPrintEndCommentsWithAlign` -> `shouldPrintEndComments`

Co-authored-by: fisker <lionkay@gmail.com>
Test: add test for issue 5961 (#9153)

community plugins: add prettier-plugin-go-template (#9163)

Build(deps): Bump linguist-languages from 7.10.0 to 7.11.0 (#9166)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Co-authored-by: fisker <lionkay@gmail.com>
Build(deps-dev): Bump rollup from 2.26.10 to 2.26.11 (#9170)

Bumps [rollup](https://github.com/rollup/rollup) from 2.26.10 to 2.26.11.
- [Release notes](https://github.com/rollup/rollup/releases)
- [Changelog](https://github.com/rollup/rollup/blob/master/CHANGELOG.md)
- [Commits](https://github.com/rollup/rollup/compare/v2.26.10...v2.26.11)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @rollup/plugin-babel from 5.2.0 to 5.2.1 (#9177)

Build(deps): Bump angular-estree-parser from 2.2.0 to 2.2.1 (#9176)

Build(deps): Bump @angular/compiler from 10.0.14 to 10.1.1 (#9178)

Bumps [@angular/compiler](https://github.com/angular/angular/tree/HEAD/packages/compiler) from 10.0.14 to 10.1.1.
- [Release notes](https://github.com/angular/angular/releases)
- [Changelog](https://github.com/angular/angular/blob/master/CHANGELOG.md)
- [Commits](https://github.com/angular/angular/commits/10.1.1/packages/compiler)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump yaml-unist-parser from 1.3.0 to 1.3.1 (#9169)

* Build(deps): Bump yaml-unist-parser from 1.3.0 to 1.3.1

Bumps [yaml-unist-parser](https://github.com/ikatyang/yaml-unist-parser) from 1.3.0 to 1.3.1.
- [Release notes](https://github.com/ikatyang/yaml-unist-parser/releases)
- [Changelog](https://github.com/ikatyang/yaml-unist-parser/blob/master/CHANGELOG.md)
- [Commits](https://github.com/ikatyang/yaml-unist-parser/compare/v1.3.0...v1.3.1)

Signed-off-by: dependabot[bot] <support@github.com>

* Update snapshot

* Update changelog

* spellcheck

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Co-authored-by: fisker <lionkay@gmail.com>
Build(deps-dev): Bump @types/node from 14.6.4 to 14.10.0 (#9185)

Bumps [@types/node](https://github.com/DefinitelyTyped/DefinitelyTyped/tree/HEAD/types/node) from 14.6.4 to 14.10.0.
- [Release notes](https://github.com/DefinitelyTyped/DefinitelyTyped/releases)
- [Commits](https://github.com/DefinitelyTyped/DefinitelyTyped/commits/HEAD/types/node)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump node-fetch from 2.1.2 to 2.6.1 in /scripts/release (#9186)

Bumps [node-fetch](https://github.com/bitinn/node-fetch) from 2.1.2 to 2.6.1.
- [Release notes](https://github.com/bitinn/node-fetch/releases)
- [Changelog](https://github.com/node-fetch/node-fetch/blob/master/docs/CHANGELOG.md)
- [Commits](https://github.com/bitinn/node-fetch/compare/v2.1.2...v2.6.1)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Refactor: Use set instead of array (#9164)

* Use set instead of array

* With WeakMap cache

* Refactor

* Fix typo
Added `Icons8` to user list (#9156)

Co-authored-by: fisker Cheung <lionkay@gmail.com>
[website] add Aircall in Users list (#9182)

Co-authored-by: fisker Cheung <lionkay@gmail.com>
Release script: Commit and push after updating dependents count (#9183)

* Modify to commit and push to remote after updating dependendts count

* Fix typo
Build(deps-dev): Bump @types/node from 14.10.0 to 14.10.1 (#9198)

Bumps [@types/node](https://github.com/DefinitelyTyped/DefinitelyTyped/tree/HEAD/types/node) from 14.10.0 to 14.10.1.
- [Release notes](https://github.com/DefinitelyTyped/DefinitelyTyped/releases)
- [Commits](https://github.com/DefinitelyTyped/DefinitelyTyped/commits/HEAD/types/node)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Website: Remove `add users` link (#9187)

Co-authored-by: Alexander Kachkaev <alexander@kachkaev.ru>
Build(deps-dev): Bump eslint-plugin-jest from 24.0.0 to 24.0.1 (#9200)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump eslint from 7.8.1 to 7.9.0 (#9201)

Bumps [eslint](https://github.com/eslint/eslint) from 7.8.1 to 7.9.0.
- [Release notes](https://github.com/eslint/eslint/releases)
- [Changelog](https://github.com/eslint/eslint/blob/master/CHANGELOG.md)
- [Commits](https://github.com/eslint/eslint/compare/v7.8.1...v7.9.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump tempy from 0.6.0 to 0.7.0 (#9199)

Bumps [tempy](https://github.com/sindresorhus/tempy) from 0.6.0 to 0.7.0.
- [Release notes](https://github.com/sindresorhus/tempy/releases)
- [Commits](https://github.com/sindresorhus/tempy/compare/v0.6.0...v0.7.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Typescript tagged template literal test (#9195)

Build(deps-dev): Bump terser-webpack-plugin from 4.1.0 to 4.2.0 (#9197)

Bumps [terser-webpack-plugin](https://github.com/webpack-contrib/terser-webpack-plugin) from 4.1.0 to 4.2.0.
- [Release notes](https://github.com/webpack-contrib/terser-webpack-plugin/releases)
- [Changelog](https://github.com/webpack-contrib/terser-webpack-plugin/blob/master/CHANGELOG.md)
- [Commits](https://github.com/webpack-contrib/terser-webpack-plugin/compare/v4.1.0...v4.2.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Bump Prettier dependency to 2.1.2

Update dependents count

Merge branch 'patch-release'

Build(deps-dev): Bump terser-webpack-plugin from 4.2.0 to 4.2.1 (#9213)

Bumps [terser-webpack-plugin](https://github.com/webpack-contrib/terser-webpack-plugin) from 4.2.0 to 4.2.1.
- [Release notes](https://github.com/webpack-contrib/terser-webpack-plugin/releases)
- [Changelog](https://github.com/webpack-contrib/terser-webpack-plugin/blob/master/CHANGELOG.md)
- [Commits](https://github.com/webpack-contrib/terser-webpack-plugin/compare/v4.2.0...v4.2.1)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @types/node from 14.10.1 to 14.10.2 (#9212)

Add ESM distributions for browser (#8983)

Co-authored-by: fisker <lionkay@gmail.com>
Test: Fix indexes calculation (#9152)

* Test: Fix indexes calculation

* Simplify logic

* Update snapshots
Switch `get-stream` to `get-stdin` (#9149)

Enable `CR` test (#9148)

* Enable `CR` test

* Fix tests

* Ignore `standalone.js`
Build(deps-dev): Bump rollup from 2.26.11 to 2.27.0 (#9221)

Bumps [rollup](https://github.com/rollup/rollup) from 2.26.11 to 2.27.0.
- [Release notes](https://github.com/rollup/rollup/releases)
- [Changelog](https://github.com/rollup/rollup/blob/master/CHANGELOG.md)
- [Commits](https://github.com/rollup/rollup/compare/v2.26.11...v2.27.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump @angular/compiler from 10.1.1 to 10.1.2 (#9222)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @types/node from 14.10.2 to 14.10.3 (#9219)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Use better fonts in Playground (#9193)

Build(deps-dev): Bump webpack from 4.44.1 to 4.44.2 in /website (#9227)

Build(deps-dev): Bump @types/node from 14.10.3 to 14.11.1 (#9228)

Build(deps-dev): Bump rollup from 2.27.0 to 2.27.1 (#9231)

Change test package name (#8848)

Build(deps): Bump flow-parser from 0.133.0 to 0.134.0 (#9230)

Build(deps-dev): Bump webpack from 4.44.1 to 4.44.2 (#9229)

Build(deps-dev): Bump eslint-plugin-unicorn from 21.0.0 to 22.0.0 (#9244)

Bumps [eslint-plugin-unicorn](https://github.com/sindresorhus/eslint-plugin-unicorn) from 21.0.0 to 22.0.0.
- [Release notes](https://github.com/sindresorhus/eslint-plugin-unicorn/releases)
- [Commits](https://github.com/sindresorhus/eslint-plugin-unicorn/compare/v21.0.0...v22.0.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump terser-webpack-plugin from 4.2.1 to 4.2.2 (#9242)

Build(deps-dev): Bump eslint-plugin-jest from 24.0.1 to 24.0.2 (#9239)

Build(deps): Bump codemirror-graphql from 0.12.1 to 0.12.2 in /website (#9243)

Bumps [codemirror-graphql](https://github.com/graphql/graphiql) from 0.12.1 to 0.12.2.
- [Release notes](https://github.com/graphql/graphiql/releases)
- [Changelog](https://github.com/graphql/graphiql/blob/main/CHANGELOG.md)
- [Commits](https://github.com/graphql/graphiql/compare/codemirror-graphql@0.12.1...codemirror-graphql@0.12.2)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump typescript from 4.0.2 to 4.0.3 (#9238)

Bumps [typescript](https://github.com/Microsoft/TypeScript) from 4.0.2 to 4.0.3.
- [Release notes](https://github.com/Microsoft/TypeScript/releases)
- [Commits](https://github.com/Microsoft/TypeScript/compare/v4.0.2...v4.0.3)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @glimmer/reference from 0.61.2 to 0.62.0 (#9249)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump rollup from 2.27.1 to 2.28.1 (#9250)

Bumps [rollup](https://github.com/rollup/rollup) from 2.27.1 to 2.28.1.
- [Release notes](https://github.com/rollup/rollup/releases)
- [Changelog](https://github.com/rollup/rollup/blob/master/CHANGELOG.md)
- [Commits](https://github.com/rollup/rollup/compare/v2.27.1...v2.28.1)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @rollup/plugin-commonjs from 14.0.0 to 15.1.0 (#9253)

* Build(deps-dev): Bump @rollup/plugin-commonjs from 14.0.0 to 15.1.0

Bumps [@rollup/plugin-commonjs](https://github.com/rollup/plugins) from 14.0.0 to 15.1.0.
- [Release notes](https://github.com/rollup/plugins/releases)
- [Commits](https://github.com/rollup/plugins/compare/commonjs-v14.0.0...commonjs-v15.1.0)

Signed-off-by: dependabot[bot] <support@github.com>

* Try `requireReturnsDefault: "preferred"`

* Size check `.mjs`

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Co-authored-by: fisker <lionkay@gmail.com>
Build(deps-dev): Bump @types/node from 14.11.1 to 14.11.2 (#9259)

Vue: Improve `v-for` format (#9225)

* Vue: break `v-for` around `in` or `of`

* Update changelog

* Minor refactor

Co-authored-by: fisker <lionkay@gmail.com>
Build(deps): Bump actions/checkout from v2.3.2 to v2.3.3 (#9265)

Bumps [actions/checkout](https://github.com/actions/checkout) from v2.3.2 to v2.3.3.
- [Release notes](https://github.com/actions/checkout/releases)
- [Changelog](https://github.com/actions/checkout/blob/main/CHANGELOG.md)
- [Commits](https://github.com/actions/checkout/compare/v2.3.2...a81bbbf8298c0fa03ea29cdc473d45769f953675)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump eslint-plugin-react from 7.20.6 to 7.21.1 (#9262)

Bumps [eslint-plugin-react](https://github.com/yannickcr/eslint-plugin-react) from 7.20.6 to 7.21.1.
- [Release notes](https://github.com/yannickcr/eslint-plugin-react/releases)
- [Changelog](https://github.com/yannickcr/eslint-plugin-react/blob/master/CHANGELOG.md)
- [Commits](https://github.com/yannickcr/eslint-plugin-react/compare/v7.20.6...v7.21.1)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump @angular/compiler from 10.1.2 to 10.1.3 (#9264)

Bumps [@angular/compiler](https://github.com/angular/angular/tree/HEAD/packages/compiler) from 10.1.2 to 10.1.3.
- [Release notes](https://github.com/angular/angular/releases)
- [Changelog](https://github.com/angular/angular/blob/master/CHANGELOG.md)
- [Commits](https://github.com/angular/angular/commits/10.1.3/packages/compiler)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Update `postcss` to v8 (#9209)

* Update `postcss` v8

* Parser custom properties

* Improve logic

* Update lint script

* Fix node location

* Fix comments inside

* Add a test

* Test on `less` and `scss` too

* Fix empty prop print

* Clean

* Update `postcss`

* Exclude `regenerator`

* Test `no-semi`

* Add changelog

* Typo

* Apply review suggestion

* Style

* Simplify logic

* Remove error test, we don't throw on this anymore

* Style

* Update postcss

* Update postcss
Build(deps-dev): Bump eslint-plugin-react from 7.21.1 to 7.21.2 (#9270)

Build(deps-dev): Bump rollup from 2.28.1 to 2.28.2 (#9268)

Build(deps): Bump postcss from 8.0.7 to 8.0.9 (#9263)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
MDX: fix JSX format (#9267)

Update `postcss-scss` to v3 (#9210)

Build(deps): Bump @glimmer/syntax from 0.61.2 to 0.62.0 (#9240)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Co-authored-by: fisker <lionkay@gmail.com>
Build(deps-dev): Bump @glimmer/reference from 0.62.0 to 0.62.1 (#9269)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump eslint-config-prettier from 6.11.0 to 6.12.0 (#9283)

Build(deps-dev): Bump tempy from 0.7.0 to 0.7.1 (#9280)

Disable Jest verbose, remove pattern for size check job (#9284)

Build(deps): Bump postcss from 8.0.9 to 8.1.0 (#9281)

Build(deps-dev): Bump eslint-plugin-import from 2.22.0 to 2.22.1 (#9279)

Build(deps): Bump postcss-scss from 3.0.1 to 3.0.2 (#9282)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Remove `.flowconfig` (#9286)

Update postcss@7 to latest (#9289)

Build(deps): Bump @glimmer/syntax from 0.62.0 to 0.62.1 (#9293)

Bumps [@glimmer/syntax](https://github.com/glimmerjs/glimmer-vm) from 0.62.0 to 0.62.1.
- [Release notes](https://github.com/glimmerjs/glimmer-vm/releases)
- [Changelog](https://github.com/glimmerjs/glimmer-vm/blob/master/CHANGELOG.md)
- [Commits](https://github.com/glimmerjs/glimmer-vm/compare/v0.62.0...v0.62.1)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump postcss from 8.1.0 to 8.1.1 (#9292)

Bumps [postcss](https://github.com/postcss/postcss) from 8.1.0 to 8.1.1.
- [Release notes](https://github.com/postcss/postcss/releases)
- [Changelog](https://github.com/postcss/postcss/blob/master/CHANGELOG.md)
- [Commits](https://github.com/postcss/postcss/compare/8.1.0...8.1.1)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump eslint from 7.9.0 to 7.10.0 (#9291)

Bumps [eslint](https://github.com/eslint/eslint) from 7.9.0 to 7.10.0.
- [Release notes](https://github.com/eslint/eslint/releases)
- [Changelog](https://github.com/eslint/eslint/blob/master/CHANGELOG.md)
- [Commits](https://github.com/eslint/eslint/compare/v7.9.0...v7.10.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Markdown: Fix missing blank lines in fenced code block (#8786)

Build(deps): Bump flow-parser from 0.134.0 to 0.135.0 (#9307)

Bumps [flow-parser](https://github.com/facebook/flow) from 0.134.0 to 0.135.0.
- [Release notes](https://github.com/facebook/flow/releases)
- [Changelog](https://github.com/facebook/flow/blob/master/Changelog.md)
- [Commits](https://github.com/facebook/flow/compare/v0.134.0...v0.135.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Website: Add Nova text editor (#9301)

* Add Nova app to editors.yml

Adding a link to the Prettier extension for Panic's new Nova editor.

* Add images for Nova editor

* Fix sort order on editor list.

* Delete nova-128px.png
Build(deps): Bump actions/setup-node from v2.1.1 to v2.1.2 (#9309)

Bumps [actions/setup-node](https://github.com/actions/setup-node) from v2.1.1 to v2.1.2.
- [Release notes](https://github.com/actions/setup-node/releases)
- [Commits](https://github.com/actions/setup-node/compare/v2.1.1...c6fd00ceb9747fb23ffdf72987450a2664414867)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump @angular/compiler from 10.1.3 to 10.1.4 (#9306)

Bumps [@angular/compiler](https://github.com/angular/angular/tree/HEAD/packages/compiler) from 10.1.3 to 10.1.4.
- [Release notes](https://github.com/angular/angular/releases)
- [Changelog](https://github.com/angular/angular/blob/master/CHANGELOG.md)
- [Commits](https://github.com/angular/angular/commits/10.1.4/packages/compiler)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
JS: Fix comments inside template (#9278)

Co-authored-by: Georgii Dolzhykov <thorn.mailbox@gmail.com>
Build(deps): Bump linguist-languages from 7.11.0 to 7.11.1 (#9320)

* Build(deps): Bump linguist-languages from 7.11.0 to 7.11.1

Bumps [linguist-languages](https://github.com/ikatyang/linguist-languages) from 7.11.0 to 7.11.1.
- [Release notes](https://github.com/ikatyang/linguist-languages/releases)
- [Commits](https://github.com/ikatyang/linguist-languages/compare/v7.11.0...v7.11.1)

Signed-off-by: dependabot[bot] <support@github.com>

* Update snapshot for linguist-languages

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Co-authored-by: sosukesuzuki <aosukeke@gmail.com>
Build(deps-dev): Bump eslint-plugin-react from 7.21.2 to 7.21.3 (#9321)

Bumps [eslint-plugin-react](https://github.com/yannickcr/eslint-plugin-react) from 7.21.2 to 7.21.3.
- [Release notes](https://github.com/yannickcr/eslint-plugin-react/releases)
- [Changelog](https://github.com/yannickcr/eslint-plugin-react/blob/master/CHANGELOG.md)
- [Commits](https://github.com/yannickcr/eslint-plugin-react/compare/v7.21.2...v7.21.3)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Cleanup changelog_unreleased (#9325)

These were released in 2.1.2
Remvoe duplicated condition (#9319)

TypeScript: Preserve a last separator for ignored object and interface types (#9318)

* Preserve ignored TypeScript signature

* Add Changelog
Build(deps-dev): Bump eslint-plugin-jest from 24.0.2 to 24.1.0 (#9334)

Bumps [eslint-plugin-jest](https://github.com/jest-community/eslint-plugin-jest) from 24.0.2 to 24.1.0.
- [Release notes](https://github.com/jest-community/eslint-plugin-jest/releases)
- [Changelog](https://github.com/jest-community/eslint-plugin-jest/blob/master/CHANGELOG.md)
- [Commits](https://github.com/jest-community/eslint-plugin-jest/compare/v24.0.2...v24.1.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @types/node from 14.11.2 to 14.11.4 (#9333)

Bumps [@types/node](https://github.com/DefinitelyTyped/DefinitelyTyped/tree/HEAD/types/node) from 14.11.2 to 14.11.4.
- [Release notes](https://github.com/DefinitelyTyped/DefinitelyTyped/releases)
- [Commits](https://github.com/DefinitelyTyped/DefinitelyTyped/commits/HEAD/types/node)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump jest from 26.4.2 to 26.5.0 (#9332)

Bumps [jest](https://github.com/facebook/jest) from 26.4.2 to 26.5.0.
- [Release notes](https://github.com/facebook/jest/releases)
- [Changelog](https://github.com/facebook/jest/blob/master/CHANGELOG.md)
- [Commits](https://github.com/facebook/jest/compare/v26.4.2...v26.5.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump synchronous-promise from 2.0.13 to 2.0.14 (#9330)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @types/node from 14.11.4 to 14.11.5 (#9343)

Bumps [@types/node](https://github.com/DefinitelyTyped/DefinitelyTyped/tree/HEAD/types/node) from 14.11.4 to 14.11.5.
- [Release notes](https://github.com/DefinitelyTyped/DefinitelyTyped/releases)
- [Commits](https://github.com/DefinitelyTyped/DefinitelyTyped/commits/HEAD/types/node)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump jest from 26.5.0 to 26.5.2 (#9344)

Bumps [jest](https://github.com/facebook/jest) from 26.5.0 to 26.5.2.
- [Release notes](https://github.com/facebook/jest/releases)
- [Changelog](https://github.com/facebook/jest/blob/master/CHANGELOG.md)
- [Commits](https://github.com/facebook/jest/compare/v26.5.0...v26.5.2)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Add missing prettier-ignore comment in changelog (#9346)

Fix placing leading comments for a body of while statement (#9345)

* Add leading comments for while

* Add tests

* Add changelog
Build(deps-dev): Bump rollup from 2.28.2 to 2.29.0 (#9352)

Bumps [rollup](https://github.com/rollup/rollup) from 2.28.2 to 2.29.0.
- [Release notes](https://github.com/rollup/rollup/releases)
- [Changelog](https://github.com/rollup/rollup/blob/master/CHANGELOG.md)
- [Commits](https://github.com/rollup/rollup/compare/v2.28.2...v2.29.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump terser-webpack-plugin from 4.2.2 to 4.2.3 (#9349)

Bumps [terser-webpack-plugin](https://github.com/webpack-contrib/terser-webpack-plugin) from 4.2.2 to 4.2.3.
- [Release notes](https://github.com/webpack-contrib/terser-webpack-plugin/releases)
- [Changelog](https://github.com/webpack-contrib/terser-webpack-plugin/blob/master/CHANGELOG.md)
- [Commits](https://github.com/webpack-contrib/terser-webpack-plugin/compare/v4.2.2...v4.2.3)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump @angular/compiler from 10.1.4 to 10.1.5 (#9351)

Bumps [@angular/compiler](https://github.com/angular/angular/tree/HEAD/packages/compiler) from 10.1.4 to 10.1.5.
- [Release notes](https://github.com/angular/angular/releases)
- [Changelog](https://github.com/angular/angular/blob/master/CHANGELOG.md)
- [Commits](https://github.com/angular/angular/commits/10.1.5/packages/compiler)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Improve formatting for AssignmentExpression with ClassExpression that has long superClass (#9341)

* Improve formatting for AssignmentExpression with ClassExpression that has long superClass

Fix by prettier

* Add changelog

* Remove unnecesary concat call

* Mention abount Google Closure Library in changelog
Add support for [[wiki-style]] links in markdown (#9275)

* Add support for [[wiki-style]] links in markdown

1.  Support for [[wiki-style]] links ensures that they do not get broken
    by the prettier formatting by being wrapped over multiple lines.
2.  The contents of the link (between the `[[]]` brackets) are treated
    as raw text. This is because the various tools that rely on the
    `[[]]` syntax do not agree on what is allowable between them.

* Add a changelog document

* Update pr-9275.md

* Add additional tests as requested

* Add a fix for AST tests

* Fix issues with prose-wrap: "preserve"

* Lint

* Add a clean action for wikiLinks

Co-authored-by: fisker Cheung <lionkay@gmail.com>
Use `Jest@26` (#9337)

CLI: Fix error on dir or file that name is a number (#9298)

Build(deps-dev): Bump synchronous-promise from 2.0.14 to 2.0.15 (#9359)

Bumps [synchronous-promise](https://github.com/fluffynuts/synchronous-promise) from 2.0.14 to 2.0.15.
- [Release notes](https://github.com/fluffynuts/synchronous-promise/releases)
- [Commits](https://github.com/fluffynuts/synchronous-promise/compare/v2.0.14...v2.0.15)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @types/node from 14.11.5 to 14.11.7 (#9360)

Bumps [@types/node](https://github.com/DefinitelyTyped/DefinitelyTyped/tree/HEAD/types/node) from 14.11.5 to 14.11.7.
- [Release notes](https://github.com/DefinitelyTyped/DefinitelyTyped/releases)
- [Commits](https://github.com/DefinitelyTyped/DefinitelyTyped/commits/HEAD/types/node)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Playground: Removed "user-scalable=no" (#9366)

Markdown: Align code block language detection with other tools (#9365)

LESS: fix comments in value lists (#9356)

Build(deps): Bump mem from 6.1.1 to 8.0.0 (#9374)

Bumps [mem](https://github.com/sindresorhus/mem) from 6.1.1 to 8.0.0.
- [Release notes](https://github.com/sindresorhus/mem/releases)
- [Commits](https://github.com/sindresorhus/mem/compare/v6.1.1...v8.0.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump camelcase from 6.0.0 to 6.1.0 (#9376)

Bumps [camelcase](https://github.com/sindresorhus/camelcase) from 6.0.0 to 6.1.0.
- [Release notes](https://github.com/sindresorhus/camelcase/releases)
- [Commits](https://github.com/sindresorhus/camelcase/compare/v6.0.0...v6.1.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump eslint from 7.10.0 to 7.11.0 (#9377)

Bumps [eslint](https://github.com/eslint/eslint) from 7.10.0 to 7.11.0.
- [Release notes](https://github.com/eslint/eslint/releases)
- [Changelog](https://github.com/eslint/eslint/blob/master/CHANGELOG.md)
- [Commits](https://github.com/eslint/eslint/compare/v7.10.0...v7.11.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
community plugins: add prettier-plugin-tailwind (#9378)

Add `espree` parser (#9000)

Co-authored-by: Chris Brody <chris.brody+brodybits@gmail.com>
Stop inferring the parser to be `json` for `.jsonl` files (#9371)

Co-authored-by: Georgii Dolzhykov <thorn.mailbox@gmail.com>
HTML: Fix crash on reading `Node.sourceSpan` (#9372)

Build(deps-dev): Bump tempy from 0.7.1 to 1.0.0 (#9386)

Bumps [tempy](https://github.com/sindresorhus/tempy) from 0.7.1 to 1.0.0.
- [Release notes](https://github.com/sindresorhus/tempy/releases)
- [Commits](https://github.com/sindresorhus/tempy/compare/v0.7.1...v1.0.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump eslint-plugin-react from 7.21.3 to 7.21.4 (#9383)

Bumps [eslint-plugin-react](https://github.com/yannickcr/eslint-plugin-react) from 7.21.3 to 7.21.4.
- [Release notes](https://github.com/yannickcr/eslint-plugin-react/releases)
- [Changelog](https://github.com/yannickcr/eslint-plugin-react/blob/master/CHANGELOG.md)
- [Commits](https://github.com/yannickcr/eslint-plugin-react/compare/v7.21.3...v7.21.4)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @types/node from 14.11.7 to 14.11.8 (#9385)

Bumps [@types/node](https://github.com/DefinitelyTyped/DefinitelyTyped/tree/HEAD/types/node) from 14.11.7 to 14.11.8.
- [Release notes](https://github.com/DefinitelyTyped/DefinitelyTyped/releases)
- [Commits](https://github.com/DefinitelyTyped/DefinitelyTyped/commits/HEAD/types/node)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Test: use `errors` options instead of `disableBabelTS` (#9387)

Build(deps-dev): Bump rollup from 2.29.0 to 2.30.0 (#9394)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump jest from 26.5.2 to 26.5.3 (#9396)

Bumps [jest](https://github.com/facebook/jest) from 26.5.2 to 26.5.3.
- [Release notes](https://github.com/facebook/jest/releases)
- [Changelog](https://github.com/facebook/jest/blob/master/CHANGELOG.md)
- [Commits](https://github.com/facebook/jest/compare/v26.5.2...v26.5.3)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump html-element-attributes from 2.2.1 to 2.3.0 (#9395)

Bumps [html-element-attributes](https://github.com/wooorm/html-element-attributes) from 2.2.1 to 2.3.0.
- [Release notes](https://github.com/wooorm/html-element-attributes/releases)
- [Commits](https://github.com/wooorm/html-element-attributes/compare/2.2.1...2.3.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Moved hack plugins to experimental section (#9392)

Build(deps-dev): Bump webpack-cli from 3.3.12 to 4.0.0 in /website (#9375)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Co-authored-by: fisker <lionkay@gmail.com>
Build(deps): Bump @angular/compiler from 10.1.5 to 10.1.6 (#9404)

Add `prettier-plugin-jsdoc` to plugins list (#9393)

Minor tweak (#9407)

Build(deps-dev): Bump @babel/types from 7.11.5 to 7.12.0 (#9411)

Bumps [@babel/types](https://github.com/babel/babel/tree/HEAD/packages/babel-types) from 7.11.5 to 7.12.0.
- [Release notes](https://github.com/babel/babel/releases)
- [Changelog](https://github.com/babel/babel/blob/main/CHANGELOG.md)
- [Commits](https://github.com/babel/babel/commits/v7.12.0/packages/babel-types)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @babel/preset-env from 7.11.5 to 7.12.0 (#9413)

Build(deps): Bump react from 16.13.1 to 16.14.0 in /website (#9402)

Bumps [react](https://github.com/facebook/react/tree/HEAD/packages/react) from 16.13.1 to 16.14.0.
- [Release notes](https://github.com/facebook/react/releases)
- [Changelog](https://github.com/facebook/react/blob/master/CHANGELOG.md)
- [Commits](https://github.com/facebook/react/commits/v16.14.0/packages/react)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump @glimmer/syntax from 0.62.1 to 0.62.3 (#9403)

Co-authored-by: Cyrille David <dcyriller@users.noreply.github.com>
Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Co-authored-by: fisker <lionkay@gmail.com>
Build(deps-dev): Bump @babel/core from 7.11.6 to 7.12.0 (#9409)

Build(deps-dev): Bump @glimmer/reference from 0.62.1 to 0.62.3 (#9412)

Update website deps (#9416)

Consistent parser errors (#9406)

Build(deps-dev): Bump webpack from 4.44.2 to 5.1.0 in /website (#9414)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump rollup from 2.30.0 to 2.31.0 (#9424)

Bumps [rollup](https://github.com/rollup/rollup) from 2.30.0 to 2.31.0.
- [Release notes](https://github.com/rollup/rollup/releases)
- [Changelog](https://github.com/rollup/rollup/blob/master/CHANGELOG.md)
- [Commits](https://github.com/rollup/rollup/compare/v2.30.0...v2.31.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump react-dom from 16.13.1 to 16.14.0 in /website (#9419)

Bumps [react-dom](https://github.com/facebook/react/tree/HEAD/packages/react-dom) from 16.13.1 to 16.14.0.
- [Release notes](https://github.com/facebook/react/releases)
- [Changelog](https://github.com/facebook/react/blob/master/CHANGELOG.md)
- [Commits](https://github.com/facebook/react/commits/v16.14.0/packages/react-dom)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @babel/preset-env from 7.12.0 to 7.12.1 (#9427)

Bumps [@babel/preset-env](https://github.com/babel/babel/tree/HEAD/packages/babel-preset-env) from 7.12.0 to 7.12.1.
- [Release notes](https://github.com/babel/babel/releases)
- [Changelog](https://github.com/babel/babel/blob/main/CHANGELOG.md)
- [Commits](https://github.com/babel/babel/commits/v7.12.1/packages/babel-preset-env)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump webpack from 5.1.0 to 5.1.2 in /website (#9421)

Bumps [webpack](https://github.com/webpack/webpack) from 5.1.0 to 5.1.2.
- [Release notes](https://github.com/webpack/webpack/releases)
- [Commits](https://github.com/webpack/webpack/compare/v5.1.0...v5.1.2)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @babel/preset-react from 7.10.4 to 7.12.1 in /website (#9420)

Bumps [@babel/preset-react](https://github.com/babel/babel/tree/HEAD/packages/babel-preset-react) from 7.10.4 to 7.12.1.
- [Release notes](https://github.com/babel/babel/releases)
- [Changelog](https://github.com/babel/babel/blob/main/CHANGELOG.md)
- [Commits](https://github.com/babel/babel/commits/v7.12.1/packages/babel-preset-react)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @babel/core from 7.12.0 to 7.12.1 (#9422)

Build(deps-dev): Bump @babel/types from 7.12.0 to 7.12.1 (#9423)

Build(deps): Bump flow-parser from 0.135.0 to 0.136.0 (#9425)

Bumps [flow-parser](https://github.com/facebook/flow) from 0.135.0 to 0.136.0.
- [Release notes](https://github.com/facebook/flow/releases)
- [Changelog](https://github.com/facebook/flow/blob/master/Changelog.md)
- [Commits](https://github.com/facebook/flow/compare/v0.135.0...v0.136.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Consistent format on invalid template literals (#9431)

Add `.git-blame-ignore-revs` (#9415)

Build(deps-dev): Bump eslint-plugin-unicorn from 22.0.0 to 23.0.0 (#9440)

Build(deps-dev): Bump webpack from 5.1.2 to 5.1.3 in /website (#9439)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump cspell from 4.1.0 to 4.1.2 (#9445)

Build(deps-dev): Bump @types/node from 14.11.8 to 14.11.10 (#9438)

Build(deps): Bump codecov/codecov-action from v1.0.13 to v1.0.14 (#9446)

Build(deps-dev): Bump @babel/core from 7.12.1 to 7.12.3 (#9437)

Build(deps-dev): Bump eslint-config-prettier from 6.12.0 to 6.13.0 (#9442)

Build(deps-dev): Bump rollup from 2.31.0 to 2.32.0 (#9444)

Build(deps-dev): Bump eslint-plugin-react from 7.21.4 to 7.21.5 (#9454)

JS: Fix `import {a as a}` and `export {a as a}` format (#9435)

Support Flow Enums with unknown members (#9432)

Build(deps-dev): Bump webpack-cli from 4.0.0 to 4.1.0 in /website (#9450)

Bumps [webpack-cli](https://github.com/webpack/webpack-cli) from 4.0.0 to 4.1.0.
- [Release notes](https://github.com/webpack/webpack-cli/releases)
- [Changelog](https://github.com/webpack/webpack-cli/blob/master/CHANGELOG.md)
- [Commits](https://github.com/webpack/webpack-cli/compare/webpack-cli@4.0.0...webpack-cli@4.1.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump babel-jest from 26.5.2 to 26.6.0 (#9451)

Bumps [babel-jest](https://github.com/facebook/jest/tree/HEAD/packages/babel-jest) from 26.5.2 to 26.6.0.
- [Release notes](https://github.com/facebook/jest/releases)
- [Changelog](https://github.com/facebook/jest/blob/master/CHANGELOG.md)
- [Commits](https://github.com/facebook/jest/commits/v26.6.0/packages/babel-jest)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump jest from 26.5.3 to 26.6.0 (#9455)

Update @babel/parser to 7.12 (#9408)

* Install babel/parser 7.12

* Add tests for babel/babel#12161

* Add test for babel/babel#12076

* Add test for babel/babel#12085

* Add test for babel/babel#12108

* Add test for babel/babel#12120

* Add test for babel/babel#12054

* Add test for babel/babel#12061

* Add test babel/babel#12093

* Add test for babel/babel#12065

* Add test for babel/babel#12111

* Add test for babel/babel#12072

* Switch syntax-module-attributes to syntax-import-assertion

* Support "String import/export specifier"

* Remove tests for module-attributes

* Add changelog

* Update to 7.12.3

* Fix by linter

* Fix by spellchecker

* Add tests for module attributes to errors

* Add error test for module string name with import

* Remove TSTypeCastExpression

* Add tests for funny import-assertions

* Update snapshots|

* Add more tests
Build(deps): Bump resolve from 1.17.0 to 1.18.1 (#9452)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @types/node from 14.11.10 to 14.14.0 (#9461)

Bumps [@types/node](https://github.com/DefinitelyTyped/DefinitelyTyped/tree/HEAD/types/node) from 14.11.10 to 14.14.0.
- [Release notes](https://github.com/DefinitelyTyped/DefinitelyTyped/releases)
- [Commits](https://github.com/DefinitelyTyped/DefinitelyTyped/commits/HEAD/types/node)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump codemirror-graphql from 0.12.2 to 0.12.3 in /website (#9462)

Bumps [codemirror-graphql](https://github.com/graphql/graphiql) from 0.12.2 to 0.12.3.
- [Release notes](https://github.com/graphql/graphiql/releases)
- [Changelog](https://github.com/graphql/graphiql/blob/main/CHANGELOG.md)
- [Commits](https://github.com/graphql/graphiql/compare/codemirror-graphql@0.12.2...codemirror-graphql@0.12.3)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Refactor JS embed (#9433)

Build(deps-dev): Bump webpack from 4.44.2 to 5.1.0 (#9373)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Co-authored-by: fisker <lionkay@gmail.com>
Build(deps): Bump @angular/compiler from 10.1.6 to 10.2.0 (#9472)

Build(deps-dev): Bump eslint-config-prettier from 6.13.0 to 6.14.0 (#9468)

Build(deps-dev): Bump rollup from 2.32.0 to 2.32.1 (#9469)

Support TypeScript 4.1 via Babel (#9473)

* Support Key Remapping In Mapped Types

* Fix by Prettier

* Add changelog

* Fix jsfmt.spec.js

* Update cspell.json
Build(deps-dev): Bump webpack from 5.1.3 to 5.2.0 in /website (#9477)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump react and react-dom in /website (#9479)

Bumps [react](https://github.com/facebook/react/tree/HEAD/packages/react) and [react-dom](https://github.com/facebook/react/tree/HEAD/packages/react-dom). These dependencies needed to be updated together.

Updates `react` from 16.14.0 to 17.0.1
- [Release notes](https://github.com/facebook/react/releases)
- [Changelog](https://github.com/facebook/react/blob/master/CHANGELOG.md)
- [Commits](https://github.com/facebook/react/commits/v17.0.1/packages/react)

Updates `react-dom` from 16.14.0 to 17.0.1
- [Release notes](https://github.com/facebook/react/releases)
- [Changelog](https://github.com/facebook/react/blob/master/CHANGELOG.md)
- [Commits](https://github.com/facebook/react/commits/v17.0.1/packages/react-dom)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump webpack from 5.1.3 to 5.2.0 (#9478)

Support class-static-block proposal (#9476)

* Support class-static-block proposal

* Update changelog
Support Flow this parameter annotations (#9457)

Co-authored-by: fisker <lionkay@gmail.com>
Add parens to object value that it's an assignment (#9484)

Build(deps): Bump postcss from 8.1.1 to 8.1.2 (#9443)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Co-authored-by: fisker <lionkay@gmail.com>
Test "import assertions" on other parsers (#9475)

Build(deps): Bump react and react-dom in /website (#9463)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Co-authored-by: fisker <lionkay@gmail.com>
Build(deps): Bump postcss from 8.1.2 to 8.1.3 (#9486)

Build(deps-dev): Bump jest from 26.6.0 to 26.6.1 (#9487)

Bumps [jest](https://github.com/facebook/jest) from 26.6.0 to 26.6.1.
- [Release notes](https://github.com/facebook/jest/releases)
- [Changelog](https://github.com/facebook/jest/blob/master/CHANGELOG.md)
- [Commits](https://github.com/facebook/jest/compare/v26.6.0...v26.6.1)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Simplify cursor and range logic (#9389)

Build(deps-dev): Bump babel-jest from 26.6.0 to 26.6.1 (#9488)

Refactor `needs-parens.js` (#9485)

Fix missing `esm` files in `dist/package.json` (#9491)

Refactor function parameters print (#9489)

Co-authored-by: Sosuke Suzuki <aosukeke@gmail.com>
Playground: only build needed files (#9480)

Build(deps): Bump postcss-less from 3.1.4 to 4.0.0 (#9471)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Co-authored-by: fisker <lionkay@gmail.com>
Build(deps-dev): Bump eslint from 7.11.0 to 7.12.0 (#9497)

Bumps [eslint](https://github.com/eslint/eslint) from 7.11.0 to 7.12.0.
- [Release notes](https://github.com/eslint/eslint/releases)
- [Changelog](https://github.com/eslint/eslint/blob/master/CHANGELOG.md)
- [Commits](https://github.com/eslint/eslint/compare/v7.11.0...v7.12.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump terser-webpack-plugin from 5.0.0 to 5.0.1 (#9495)

Bumps [terser-webpack-plugin](https://github.com/webpack-contrib/terser-webpack-plugin) from 5.0.0 to 5.0.1.
- [Release notes](https://github.com/webpack-contrib/terser-webpack-plugin/releases)
- [Changelog](https://github.com/webpack-contrib/terser-webpack-plugin/blob/master/CHANGELOG.md)
- [Commits](https://github.com/webpack-contrib/terser-webpack-plugin/compare/v5.0.0...v5.0.1)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump postcss from 8.1.3 to 8.1.4 (#9496)

Bumps [postcss](https://github.com/postcss/postcss) from 8.1.3 to 8.1.4.
- [Release notes](https://github.com/postcss/postcss/releases)
- [Changelog](https://github.com/postcss/postcss/blob/master/CHANGELOG.md)
- [Commits](https://github.com/postcss/postcss/compare/8.1.3...8.1.4)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @rollup/plugin-commonjs from 15.1.0 to 16.0.0 (#9512)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump eslint from 7.12.0 to 7.12.1 (#9505)

Bumps [eslint](https://github.com/eslint/eslint) from 7.12.0 to 7.12.1.
- [Release notes](https://github.com/eslint/eslint/releases)
- [Changelog](https://github.com/eslint/eslint/blob/master/CHANGELOG.md)
- [Commits](https://github.com/eslint/eslint/compare/v7.12.0...v7.12.1)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump @glimmer/syntax from 0.62.3 to 0.62.4 (#9508)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @rollup/plugin-node-resolve from 9.0.0 to 10.0.0 (#9509)

Build(deps-dev): Bump @rollup/plugin-replace from 2.3.3 to 2.3.4 (#9504)

Build(deps-dev): Bump @glimmer/reference from 0.62.3 to 0.62.4 (#9511)

Build(deps): Bump typescript from 4.0.3 to 4.0.5 (#9510)

Bumps [typescript](https://github.com/Microsoft/TypeScript) from 4.0.3 to 4.0.5.
- [Release notes](https://github.com/Microsoft/TypeScript/releases)
- [Commits](https://github.com/Microsoft/TypeScript/compare/v4.0.3...v4.0.5)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Run tests on `Node.js` 15 (#9494)

* Run tests on `Node.js` 15

* Switch `exclude` to `include`
Build(deps-dev): Bump webpack from 5.2.0 to 5.3.0 in /website (#9517)

Bumps [webpack](https://github.com/webpack/webpack) from 5.2.0 to 5.3.0.
- [Release notes](https://github.com/webpack/webpack/releases)
- [Commits](https://github.com/webpack/webpack/compare/v5.2.0...v5.3.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump webpack from 5.2.0 to 5.3.0 (#9518)

Bumps [webpack](https://github.com/webpack/webpack) from 5.2.0 to 5.3.0.
- [Release notes](https://github.com/webpack/webpack/releases)
- [Commits](https://github.com/webpack/webpack/compare/v5.2.0...v5.3.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump eslint-config-prettier from 6.14.0 to 6.15.0 (#9516)

Bumps [eslint-config-prettier](https://github.com/prettier/eslint-config-prettier) from 6.14.0 to 6.15.0.
- [Release notes](https://github.com/prettier/eslint-config-prettier/releases)
- [Changelog](https://github.com/prettier/eslint-config-prettier/blob/master/CHANGELOG.md)
- [Commits](https://github.com/prettier/eslint-config-prettier/compare/v6.14.0...v6.15.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump terser-webpack-plugin from 5.0.1 to 5.0.2 (#9515)

Build(deps): Bump camelcase from 6.1.0 to 6.2.0 (#9529)

Build(deps-dev): Bump execa from 4.0.3 to 4.1.0 (#9527)

Build(deps): Bump @angular/compiler from 10.2.0 to 10.2.1 (#9532)

Build(deps-dev): Bump terser-webpack-plugin from 5.0.2 to 5.0.3 (#9530)

Build(deps-dev): Bump webpack from 5.3.0 to 5.3.1 in /website (#9526)

Build(deps-dev): Bump webpack from 5.3.0 to 5.3.1 (#9531)

Improve `massageAST` (#9519)

Build(deps): Bump flow-parser from 0.136.0 to 0.137.0 (#9528)

Bumps [flow-parser](https://github.com/facebook/flow) from 0.136.0 to 0.137.0.
- [Release notes](https://github.com/facebook/flow/releases)
- [Changelog](https://github.com/facebook/flow/blob/master/Changelog.md)
- [Commits](https://github.com/facebook/flow/compare/v0.136.0...v0.137.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Consistent type print (#9521)

Flow: support `BigIntLiteralTypeAnnotation` and `BigIntTypeAnnotation` (#9523)

Add `index` to `FastPath#each()` callback (#9499)

Co-authored-by: Georgii Dolzhykov <thorn.mailbox@gmail.com>
Build(deps-dev): Bump webpack from 5.3.1 to 5.3.2 in /website (#9542)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps): Bump graphql from 15.3.0 to 15.4.0 (#9506)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Co-authored-by: fisker <lionkay@gmail.com>
Build(deps-dev): Bump webpack from 5.3.1 to 5.3.2 (#9541)

Refactor: Improve readability (#9539)

Refactor `needs-parens.js` (part 2) (#9498)

Treat more types as simple type (#9543)

Revert breaking changes related to adding pure css parser for minor releasing (#9500)

* revert without tests

* Downgrade postcss-scss and postcss-less

* Fix tests

* Revert "Make `isSCSS*` function stricter (#9093)"

This reverts commit 01f986bea959927375e1d551844ca7f50ec6fcff.

* Revert "Remove `css` parser from `isLessParser` check (#9092)"

This reverts commit c0bca1805de45d5f1aab9628cf45af64e4ef00fc.

* Revert "Add pure css parser (#7933)"

This reverts commit 589ebf670b8db4b21661fb551ff0b4822f8b63d6.

* Disable `parser-postcss.js` minify

* Try to fix build script

* Update fs.mjs

* Update fs.mjs

* Style

Co-authored-by: fisker <lionkay@gmail.com>
Playground: serialize ast contains BigInt (#9525)

Remove dead code (#9557)

Refactor: `getParserName` -> `inferParserByLanguage` (#9556)

Flow: Fix missing parentheses around prettier-ignored arguments (#9553)

Co-authored-by: Georgii Dolzhykov <thorn.mailbox@gmail.com>
Build(deps-dev): Bump cspell from 4.1.2 to 4.1.3 (#9567)

Build(deps-dev): Bump rollup from 2.32.1 to 2.33.0 (#9566)

Add HIGHTLIGHT mark to CHANGELOG (#9562)

Build(deps-dev): Bump rollup from 2.33.0 to 2.33.1 (#9579)

Bumps [rollup](https://github.com/rollup/rollup) from 2.33.0 to 2.33.1.
- [Release notes](https://github.com/rollup/rollup/releases)
- [Changelog](https://github.com/rollup/rollup/blob/master/CHANGELOG.md)
- [Commits](https://github.com/rollup/rollup/compare/v2.33.0...v2.33.1)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump jest from 26.6.1 to 26.6.2 (#9581)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump babel-jest from 26.6.1 to 26.6.2 (#9580)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Refactor: Use `locStart` and `locEnd` directly from `language-js/loc.js` (#9576)

Remove `for-each-in` syntax (#9585)

Flow: Improve comment types detection (#9563)

Build(deps): Bump actions/checkout from v2.3.3 to v2.3.4 (#9598)

Build(deps-dev): Bump @babel/types from 7.12.1 to 7.12.5 (#9595)

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump webpack from 5.3.2 to 5.4.0 in /website (#9594)

Bumps [webpack](https://github.com/webpack/webpack) from 5.3.2 to 5.4.0.
- [Release notes](https://github.com/webpack/webpack/releases)
- [Commits](https://github.com/webpack/webpack/compare/v5.3.2...v5.4.0)

Signed-off-by: dependabot[bot] <support@github.com>

Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>
Build(deps-dev): Bump @babel/preset-react in /website (#9596)

Bumps [@babel/preset-react](https://github.com/babel/babel/tree/HEAD/packages/babel-preset-react) from 7.12.1 to …
@github-actions github-actions bot locked as resolved and limited conversation to collaborators Sep 12, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

3 participants