Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Charts exported to PNG show wrong legend position #4967

Closed
robertoferreirajrr opened this issue Jul 4, 2019 · 6 comments

Comments

Projects
None yet
3 participants
@robertoferreirajrr
Copy link

commented Jul 4, 2019

Hi! When I export a charts to a png, the legends of the chart appears in wrong position! In the showcase it happens too!... I using primefaces 7.0, i see that in show case the version is 7.1, and still happening... I know that this issue not follow the recommended template, but like I describe, the problem occurs in showcase...

Image of Problem

@robertoferreirajrr robertoferreirajrr changed the title Chartjs exported to PNG show wrong legend position Charts exported to PNG show wrong legend position Jul 4, 2019

@melloware melloware added the defect label Jul 4, 2019

@melloware

This comment has been minimized.

Copy link
Contributor

commented Jul 4, 2019

I believe its related to this issue: jqPlot/jqPlot#144

Have you tried the newer ChartsJS? https://www.primefaces.org/showcase/ui/chartjs/export.xhtml

The Charts you are using are the old JQPlot Charts which still have bugs and the library is not updated much anymore.

@robertoferreirajrr

This comment has been minimized.

Copy link
Author

commented Jul 4, 2019

Hi @melloware , thanks for your answer..

I don't believe that this issue is related, like you said the library is too old, probably the same version of library is used in both, Primefaces 6.2 and 7... in the 6.2 all works perfect!

Unfortunately my code have a lot of customization using charts in Jqplot, combining jqplot plugins, I planing work in a code change to a newer library, like chartjs, only when I can't use jqplot more lol :D...

@melloware

This comment has been minimized.

Copy link
Contributor

commented Jul 4, 2019

Ahh yes between 6.2 and 7.0 we upgraded to latest JQPlot : #1030

So that must have broken your issue. If you can figure out the change I would be happy to fix it.

@mertsincan mertsincan self-assigned this Jul 4, 2019

@mertsincan mertsincan added this to the 7.1 milestone Jul 4, 2019

@mertsincan mertsincan added the 7.0.5 label Jul 4, 2019

@mertsincan mertsincan closed this in 639db6e Jul 4, 2019

@mertsincan

This comment has been minimized.

Copy link
Member

commented Jul 4, 2019

This issue is related to Jquery version. Fixed for 7.0.5 and 7.1.

image

@robertoferreirajrr

This comment has been minimized.

Copy link
Author

commented Jul 4, 2019

Nice! =) Thanks guys! Excellent support! Primefaces rocks!

@robertoferreirajrr

This comment has been minimized.

Copy link
Author

commented Jul 4, 2019

When this changes will be available in maven repositories?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.