Use your vim settings anywhere
Python Shell
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
notes
release
scripts
vimswitch
.coveragerc
.gitignore
LICENCE
README.md
__main__.py
make_release.py
requirements.txt
run_tests.bat
run_tests.sh
setup.py
setup_py2exe.py
tox.ini

README.md

VimSwitch

For an overview and installation steps visit https://priomsrb.github.io/vimswitch/.

Requirements

Running VimSwitch only requires Python 2.7 or 3.2+. However, if you want to build and test VimSwitch you need to install its dependencies using pip install -r requirements.txt

Testing

VimSwitch needs to support multiple Python versions over multiple operating systems. Therefore, it's important to maintain a high test coverage.

To run the test suite against the current Python version use run_tests.sh or run_tests.bat.

To run tests against all supported versions of Python use tox.