Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Creating Yubico Token causes message about setting config #1572

Open
ahmedbodi opened this issue Apr 15, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@ahmedbodi
Copy link

commented Apr 15, 2019

I've setup PrivacyIdea from the latest version on PiP.
Encountering the following Issue, i've gone through the setup, configured what i needed. Setup Policies for the things i didnt want users to use. Obtained an API key from the yubico website as instructed.
The issue im encountering is this.
When a user (non-admin) is trying to enroll their yubikey. This is the message that is displayed on the page:

For Yubico tokens to work properly you need to set the Yubico Token Config!

Now the first issue is, the user can successfully add their yubikey which is fine. However that message shouldnt be there.

The second issue, is a normal user shouldnt be able to click that link and view the settings?

If theres anyway i can help get to the bottom of the issue lmk

@cornelinux

This comment has been minimized.

Copy link
Member

commented Apr 15, 2019

This happens in this template:
https://github.com/privacyidea/privacyidea/blob/master/privacyidea/static/components/token/views/token.enroll.yubico.html#L2

It is actually difficult to verify, if the admin has configured the yubico settings. - I assume roughly ten lines of code.
But we could simply add an ng-if to display this help block only if the logged in user is of role "admin".

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.