Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Check if we can remove Support for Python 2.7 #2128

Open
plettich opened this issue Mar 23, 2020 · 0 comments
Open

Check if we can remove Support for Python 2.7 #2128

plettich opened this issue Mar 23, 2020 · 0 comments
Assignees
Milestone

Comments

@plettich
Copy link
Member

@plettich plettich commented Mar 23, 2020

Keeping the support for Python 2.7 makes the code more and more unmaintainable.
We need to jump through hoops to keep the requirements working, etc.
We should check if and how the main distributions support Python 3 and if we can fade out support for Python 2.

@plettich plettich added this to the 4.0 milestone Mar 23, 2020
@plettich plettich self-assigned this Mar 23, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant
You can’t perform that action at this time.