Skip to content
qt based ebook reader
Branch: master
Clone or download
Pull request Compare This branch is 51 commits behind BasioMeusPuga:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
lector
.gitignore
AUTHORS
LICENSE
Lector.pro
README.md
TODO
com.basiomeuspuga.Lector.json
setup.cfg
setup.py

README.md

Lector

Qt based ebook reader

Currently supports:

  • pdf
  • epub
  • fb2
  • mobi
  • azw / azw3 / azw4
  • cbr / cbz

Support for a bunch of other formats is coming. Please see the TODO for additional information.

Requirements

Package Version tested
Qt5 5.10.1
Python 3.6
PyQt5 5.10.1
python-beautifulsoup4 4.6.0
poppler-qt5 0.61.1
python-poppler-qt5 0.24.2

poppler-qt5 and python-poppler-qt5 are optional.

Installation

Manual

  1. Install dependencies - I recommend using your package manager for this.

  2. Clone repository

  3. Type the following in the root directory:

     $ python setup.py build
     # python setup.py install
    
  4. OR launch with lector/__main__.py

Available packages

Translations

  1. There is a SAMPLE.ts file here. Open it in Qt Linguist.
  2. Pick the language you wish to translate to.
  3. Translate relevant strings.
  4. Try to resist the urge to include profanity.
  5. Save the file as Lector_<language> and send it to me, preferably as a pull request.

Please keep the translations short. There's only so much space for UI elements.

Screenshots

Main window

alt tag

Table view

alt tag

Book reading view

alt tag

Distraction free view

alt tag

Annotation support

alt tag

Comic reading view

alt tag

Bookmark support

alt tag

View profiles

alt tag

Metadata editor

alt tag

In program dictionary

alt tag

Settings window

alt tag

Reporting issues

When reporting issues:

  • If you're having trouble with a book while the rest of the application / other books work, please link to a copy of the book itself.
  • If nothing is working, please make sure the requirements mentioned above are all installed, and are at least at the version mentioned.

Attributions

You can’t perform that action at this time.