New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Horizontal two finger scroll doesn't work in OS X #180

Closed
processing-bugs opened this Issue Feb 10, 2013 · 6 comments

Comments

Projects
None yet
4 participants
@processing-bugs

processing-bugs commented Feb 10, 2013

Original author: b...@processing.org (June 07, 2010 01:10:23)

This bug automatically added from:
http://dev.processing.org/bugs/show_bug.cgi?id=1046

Comment from ewjordan, 2008-11-23 16:22

Very low priority RFE: horizontal two finger scrolling doesn't work in the
PDE the way it does in most other applications on OS X.

Somehow this is probably possible in Java (Eclipse manages to get it to
work), but it might not be easy, and a quick Google didn't pop up any
information (doesn't help that Apple's support for Java is pretty much
non-existent these days).

Maybe one for the distant future if someone happens to stumble across a way
to enable it...

Original issue: http://code.google.com/p/processing/issues/detail?id=141

@processing-bugs

This comment has been minimized.

Show comment
Hide comment
@processing-bugs

processing-bugs Feb 10, 2013

From b...@processing.org on June 07, 2010 01:10:23
Comment from fry, 2008-11-23 16:33

Wonder if they've implemented it in 1.5 but not 1.6... Eclipse is using swt so that doesn't tell us much unfortunately.

processing-bugs commented Feb 10, 2013

From b...@processing.org on June 07, 2010 01:10:23
Comment from fry, 2008-11-23 16:33

Wonder if they've implemented it in 1.5 but not 1.6... Eclipse is using swt so that doesn't tell us much unfortunately.

@processing-bugs

This comment has been minimized.

Show comment
Hide comment
@processing-bugs

processing-bugs Feb 10, 2013

From b...@processing.org on June 07, 2010 01:10:24
Comment from kiwidesign, 2008-11-26 00:55

just pointing out: (sadly) the bug applies in general to horizontal scrolling, so this happens also
using a mighty mouse (or any other horizontal-scrolling enabled mouse like some logitech ones).

processing-bugs commented Feb 10, 2013

From b...@processing.org on June 07, 2010 01:10:24
Comment from kiwidesign, 2008-11-26 00:55

just pointing out: (sadly) the bug applies in general to horizontal scrolling, so this happens also
using a mighty mouse (or any other horizontal-scrolling enabled mouse like some logitech ones).

@processing-bugs

This comment has been minimized.

Show comment
Hide comment
@processing-bugs

processing-bugs Feb 10, 2013

From jeffgem...@gmail.com on April 21, 2011 16:32:41
Two finger scrolling works fine for me in the PDE. This may be outdated and could probably be closed.

processing-bugs commented Feb 10, 2013

From jeffgem...@gmail.com on April 21, 2011 16:32:41
Two finger scrolling works fine for me in the PDE. This may be outdated and could probably be closed.

@benfry benfry added the help wanted label Nov 19, 2014

@Akarshit

This comment has been minimized.

Show comment
Hide comment
@Akarshit

Akarshit Feb 8, 2015

Member

I am using linux and still horizontal two finger scrolling is not working. Insted right click is happening.

Member

Akarshit commented Feb 8, 2015

I am using linux and still horizontal two finger scrolling is not working. Insted right click is happening.

@benfry

This comment has been minimized.

Show comment
Hide comment
@benfry

benfry Apr 4, 2015

Member

@Akarshit That's a separate issue, as the title says, this is specific to OS X. If it's broken on Linux, please file a report for it and look into what might be causing the problem.

Member

benfry commented Apr 4, 2015

@Akarshit That's a separate issue, as the title says, this is specific to OS X. If it's broken on Linux, please file a report for it and look into what might be causing the problem.

@twinpixels

This comment has been minimized.

Show comment
Hide comment
@twinpixels

twinpixels Oct 11, 2016

I'm still having this issue on the latest version of PDE running osx el capitan

twinpixels commented Oct 11, 2016

I'm still having this issue on the latest version of PDE running osx el capitan

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment