New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ant deb fails. $version has not been set #2973

Closed
kfeuz opened this Issue Nov 19, 2014 · 1 comment

Comments

Projects
None yet
2 participants
@kfeuz
Contributor

kfeuz commented Nov 19, 2014

The $version property is only set when the dist target is called. However, ant deb requires this property be set but it does not depend on dist. When I created the .deb support I tried a few different approaches and ultimately just made ant dist invoke the deb build. However, another approach is to make the deb target depend on dist. This may be more desirable because it let's you build the tarball without building the deb. I'll submit a pull request.

@benfry

This comment has been minimized.

Show comment
Hide comment
@benfry

benfry Nov 20, 2014

Member

Yep, that was the intent. I can't make the .deb target the default Linux build. Linux might be only ~3% of our users, but a generic build that works for everyone is the top priority.

Member

benfry commented Nov 20, 2014

Yep, that was the intent. I can't make the .deb target the default Linux build. Linux might be only ~3% of our users, but a generic build that works for everyone is the top priority.

@benfry benfry closed this Nov 20, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment