New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

NullPointerException in initiateToolTip() #3286

Open
benfry opened this Issue May 16, 2015 · 11 comments

Comments

Projects
None yet
3 participants
@benfry
Member

benfry commented May 16, 2015

Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
    at javax.swing.ToolTipManager.initiateToolTip(ToolTipManager.java:478)
    at javax.swing.ToolTipManager.mouseEntered(ToolTipManager.java:435)
    at processing.mode.java.pdex.JavaTextArea$MouseHandler.mouseEntered(JavaTextArea.java:749)
    at java.awt.AWTEventMulticaster.mouseEntered(AWTEventMulticaster.java:300)
    at java.awt.Component.processMouseEvent(Component.java:6534)
    at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
@benfry

This comment has been minimized.

Show comment
Hide comment
@benfry

benfry May 16, 2015

Member

I may have broken this one when removing some extraneous listener code, but it looks like one of the mouse listeners in the list is null. Not sure how that's possible.

Member

benfry commented May 16, 2015

I may have broken this one when removing some extraneous listener code, but it looks like one of the mouse listeners in the list is null. Not sure how that's possible.

@Manindra29

This comment has been minimized.

Show comment
Hide comment
@Manindra29

Manindra29 May 16, 2015

Member

Is there a consistent way to reproduce this?

Member

Manindra29 commented May 16, 2015

Is there a consistent way to reproduce this?

@benfry

This comment has been minimized.

Show comment
Hide comment
@benfry

benfry May 16, 2015

Member

This was reported by @shiffman over here: #3265

Member

benfry commented May 16, 2015

This was reported by @shiffman over here: #3265

@shiffman

This comment has been minimized.

Show comment
Hide comment
@shiffman

shiffman May 18, 2015

Member

I'm not able to make this error happen anymore now that the debugger issues were resolved. Shall I close?

Member

shiffman commented May 18, 2015

I'm not able to make this error happen anymore now that the debugger issues were resolved. Shall I close?

@Manindra29

This comment has been minimized.

Show comment
Hide comment
@Manindra29

Manindra29 May 18, 2015

Member

This kind of error was reported before in #2926. But I believe it was taken care of. I can't think of why the Debugger issue would be related to the tooltip one. We can close this one and reopen #2926. It would be nice if there was a way to reproduce the error.

Member

Manindra29 commented May 18, 2015

This kind of error was reported before in #2926. But I believe it was taken care of. I can't think of why the Debugger issue would be related to the tooltip one. We can close this one and reopen #2926. It would be nice if there was a way to reproduce the error.

@benfry

This comment has been minimized.

Show comment
Hide comment
@benfry

benfry May 18, 2015

Member

I may have bumped something that fixed it. We can close for now and reopen (one of them) if it reappears.

Member

benfry commented May 18, 2015

I may have bumped something that fixed it. We can close for now and reopen (one of them) if it reappears.

@benfry benfry closed this May 18, 2015

@shiffman

This comment has been minimized.

Show comment
Hide comment
@shiffman

shiffman Jun 26, 2015

Member

I'm seeing the tooltip error again. I haven't pinpointed it precisely, but I believe it's appearing during error checking (I was changing things quickly in code and lots of errors were appearing/disappearing.) Should I re-open?

Member

shiffman commented Jun 26, 2015

I'm seeing the tooltip error again. I haven't pinpointed it precisely, but I believe it's appearing during error checking (I was changing things quickly in code and lots of errors were appearing/disappearing.) Should I re-open?

@Manindra29 Manindra29 reopened this Jun 26, 2015

@Manindra29

This comment has been minimized.

Show comment
Hide comment
@Manindra29

Manindra29 Jun 26, 2015

Member

This is unlikely to have anything to do with the error checking. This is being caused due to a bug in the tooltip handling for variable/methods tooltips.

Member

Manindra29 commented Jun 26, 2015

This is unlikely to have anything to do with the error checking. This is being caused due to a bug in the tooltip handling for variable/methods tooltips.

@benfry

This comment has been minimized.

Show comment
Hide comment
@benfry

benfry Jun 26, 2015

Member

@Manindra29 are you working on this one?

Member

benfry commented Jun 26, 2015

@Manindra29 are you working on this one?

@Manindra29

This comment has been minimized.

Show comment
Hide comment
@Manindra29

Manindra29 Jun 27, 2015

Member

No, I'm not at the moment.

Member

Manindra29 commented Jun 27, 2015

No, I'm not at the moment.

JakubValtar added a commit to JakubValtar/processing that referenced this issue Nov 9, 2015

@benfry

This comment has been minimized.

Show comment
Hide comment
@benfry

benfry Feb 13, 2016

Member

Let's see if this is fixed by #4113 in 3.0.2.

Member

benfry commented Feb 13, 2016

Let's see if this is fixed by #4113 in 3.0.2.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment