New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

PNG transparency broken with createGraphics() (regression in 3.0a9 from 3.0a5) #3317

Closed
JukePlz opened this Issue May 24, 2015 · 1 comment

Comments

Projects
None yet
2 participants
@JukePlz

JukePlz commented May 24, 2015

On 3.05a loading a PNG with transparent pixels used to work but 3.09a the image displays with a black background on draw.

trans
Left: 3.09a Right: 3.05a (correct behavior)

Test case:

PImage ball;
PGraphics pgBall;

void setup()
{
  size (50, 50);

  ball = loadImage("ball.png");

  pgBall = createGraphics(50, 50);
  pgBall.beginDraw();
  pgBall.image(ball, 0, 0);
  pgBall.endDraw();
}

void draw()
{
  image(pgBall, 0, 0);
}

png used.
ball

@benfry benfry changed the title from PGraphic ignores PNG transparency to PNG transparency broken with createGraphics() (regression in 3.0a9 from 3.0a5) Jun 1, 2015

@benfry benfry added this to the 3.0 final milestone Jun 16, 2015

@benfry

This comment has been minimized.

Show comment
Hide comment
@benfry

benfry Jun 16, 2015

Member

Fixed for 3.0 beta 1, same issue as #3378

Member

benfry commented Jun 16, 2015

Fixed for 3.0 beta 1, same issue as #3378

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment