New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

add library fails with "Could not write to temporary directory" #3548

Closed
Diex opened this Issue Aug 7, 2015 · 5 comments

Comments

Projects
None yet
3 participants
@Diex

Diex commented Aug 7, 2015

when trying to install new libraries to new sketchbook folder, installation fails:
"Could not write to temporary directory."

mac osx 10.7
tried Ani and ControlP5.

@Diex

This comment has been minimized.

Show comment
Hide comment
@Diex

Diex Aug 7, 2015

just figure it out: after first run, restart processing, the folders are created into sketchbook.
examples libraries modes
then add library runs ok.

Diex commented Aug 7, 2015

just figure it out: after first run, restart processing, the folders are created into sketchbook.
examples libraries modes
then add library runs ok.

@benfry

This comment has been minimized.

Show comment
Hide comment
@benfry

benfry Aug 7, 2015

Member

What version of Processing? We don't support OS X 10.7 anymore.

Member

benfry commented Aug 7, 2015

What version of Processing? We don't support OS X 10.7 anymore.

@hype

This comment has been minimized.

Show comment
Hide comment
@hype

hype Aug 8, 2015

@benfry I had the same issue on 10.10.4.

  1. download processing
  2. when you install it prompts you for install folder I picked /Documents/Processing_3_0b1
  3. it's at this point it created the folder but it didn't create the folders "libraries, modes or tools"
  4. so trying to add libraries fail as the folders don't exist yet ?
  5. as soon as I quit processing... the "libraries, modes and tools" folders showed up.
  6. restart processing... THEN... add libraries like minim, controlp5... etc.

hype commented Aug 8, 2015

@benfry I had the same issue on 10.10.4.

  1. download processing
  2. when you install it prompts you for install folder I picked /Documents/Processing_3_0b1
  3. it's at this point it created the folder but it didn't create the folders "libraries, modes or tools"
  4. so trying to add libraries fail as the folders don't exist yet ?
  5. as soon as I quit processing... the "libraries, modes and tools" folders showed up.
  6. restart processing... THEN... add libraries like minim, controlp5... etc.
@Diex

This comment has been minimized.

Show comment
Hide comment
@Diex

Diex Aug 8, 2015

processing 3.

:)

Diex commented Aug 8, 2015

processing 3.

:)

@benfry benfry closed this in 77e513b Aug 8, 2015

@benfry

This comment has been minimized.

Show comment
Hide comment
@benfry

benfry Aug 8, 2015

Member

Fixed for beta 2, thanks for the reports.

Member

benfry commented Aug 8, 2015

Fixed for beta 2, thanks for the reports.

@benfry benfry changed the title from add library fails to add library fails with "Could not write to temporary directory" Aug 9, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment