New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

autocomplete timing errors #3812

Closed
shiffman opened this Issue Sep 17, 2015 · 5 comments

Comments

Projects
None yet
3 participants
@shiffman
Member

shiffman commented Sep 17, 2015

I am not able to get code completion to work properly in 0245. It is working properly for me in 3.0b5. It appears to be some sort of timing problem, as sometimes the correct completion menu pops up, but quite a bit of time as passed since I hit cntrl-space. There is some very awkward video documentation of this here:

https://www.youtube.com/watch?v=LOcSnePMfb0&feature=youtu.be&t=1076

Are others seeing this or just me?

@benfry

This comment has been minimized.

Show comment
Hide comment
@benfry

benfry Sep 17, 2015

Member

Yes; confirmed. I saw it Tuesday and @JakubValtar and I are trying to track it down.

Member

benfry commented Sep 17, 2015

Yes; confirmed. I saw it Tuesday and @JakubValtar and I are trying to track it down.

@benfry

This comment has been minimized.

Show comment
Hide comment
@benfry

benfry Sep 21, 2015

Member

Possibly a regression in 2450880

Member

benfry commented Sep 21, 2015

Possibly a regression in 2450880

benfry added a commit that referenced this issue Sep 21, 2015

@benfry

This comment has been minimized.

Show comment
Hide comment
@benfry

benfry Sep 21, 2015

Member

@shiffman Can you try the current source?

Member

benfry commented Sep 21, 2015

@shiffman Can you try the current source?

@shiffman

This comment has been minimized.

Show comment
Hide comment
@shiffman

shiffman Sep 22, 2015

Member

It's working better for me now in that the severe delay/getting stuck issue is resolved. However, and I can't pinpoint exactly why this occurs (speed/timing of my typing?), I am sometimes seeing a syntax error which then I think kills the code completion. It is working ~75% of the time and I'm getting an error ~25%. Here is a video showing you what I'm seeing (though you will have to use your imagination as to when I am hitting cntrl-space.)

https://www.dropbox.com/s/nkizev14xiv6tvp/code_completion.mov?dl=0

I also just noticed if I turn off "continously check for errors" the code completion works without fail.

Member

shiffman commented Sep 22, 2015

It's working better for me now in that the severe delay/getting stuck issue is resolved. However, and I can't pinpoint exactly why this occurs (speed/timing of my typing?), I am sometimes seeing a syntax error which then I think kills the code completion. It is working ~75% of the time and I'm getting an error ~25%. Here is a video showing you what I'm seeing (though you will have to use your imagination as to when I am hitting cntrl-space.)

https://www.dropbox.com/s/nkizev14xiv6tvp/code_completion.mov?dl=0

I also just noticed if I turn off "continously check for errors" the code completion works without fail.

@benfry

This comment has been minimized.

Show comment
Hide comment
@benfry

benfry Sep 22, 2015

Member

Pull request to fix this one is on its way from @JakubValtar for 3.0 beta 7.

Member

benfry commented Sep 22, 2015

Pull request to fix this one is on its way from @JakubValtar for 3.0 beta 7.

@benfry benfry closed this Sep 22, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment