Skip to content
This repository
Browse code

update debian readme (build dependencies were incomplete / wrong)

  • Loading branch information...
commit d02d4482c094079a75b4dc211a3910c9e6cca471 1 parent 5186841
Bernd Kreuss authored October 07, 2012

Showing 1 changed file with 7 additions and 22 deletions. Show diff stats Hide diff stats

  1. 29  README_DEBIAN.markdown
29  README_DEBIAN.markdown
Source Rendered
... ...
@@ -1,33 +1,23 @@
1 1
 To the Debian packager
2 2
 ======================
3  
-There are not yet any special arrangements that make it easy to
4  
-package it for Debian but I like to add them and help making this
5  
-process as uncomplicated as possible. This also applies to other
6  
-package systems. I have not yet made a Debian source package myself,
7  
-I have read parts of the instructions, it seems there are a lot of
8  
-things to do to get it right, probably easy for someone who has done
9  
-this before but not for me unless someone helps me to do it.
10  
-
11  
-You will probably make patches to the makefile or rearrange things,
12  
-please tell me what is needed to make this easier.
13 3
 
14 4
 Build requirements
15 5
 ------------------
16 6
 ### Pidgin Plugin
17 7
 * libpurple-dev
18  
-* fp-compiler 2.6 (Free Pascal 2.6 is the current stable release of fpc)
  8
+* fpc (>= 2.6.0) (Free Pascal 2.6 is the current stable release of fpc)
19 9
 
20  
-### Standalone version (2.0)
  10
+### Standalone version (2.0) (does not exist yet)
21 11
 * gtk2
22  
-* fp-compiler 2.6
23  
-* lazarus 1.0
  12
+* fpc (>= 2.6.0)
  13
+* lazarus (>= 1.0.0), lcl (>= 1.0.0), lcl-utils (>= 1.0.0)
24 14
 
25 15
 or alternatively
26 16
 
27 17
 * qt4
28 18
 * libqt4pas-dev
29  
-* fp-compiler 2.6
30  
-* lazarus 1.0
  19
+* fpc (>= 2.6.0)
  20
+* lazarus (>= 1.0.0), lcl (>= 1.0.0), lcl-utils (>= 1.0.0)
31 21
 
32 22
 Runtime requirements
33 23
 --------------------
@@ -35,7 +25,7 @@ Runtime requirements
35 25
 * tor
36 26
 * libpurple
37 27
 
38  
-### Standalone version (2.0)
  28
+### Standalone version (2.0) (does not exist yet)
39 29
 * tor
40 30
 * gtk2
41 31
 
@@ -79,8 +69,3 @@ and also the torchat icons (the blue globe in several different
79 69
 sizes) into libpurples appropriate pixmap folders (this is optional,
80 70
 it will also run without the icons but a full install should include
81 71
 them).
82  
-
83  
-Please submit patches of how the makefile should do this in order to
84  
-make it properly work for creating a deban installer (do we need a
85  
-special make target for Debian or does the debian installer use the
86  
-install target?)

0 notes on commit d02d448

Please sign in to comment.
Something went wrong with that request. Please try again.