Skip to content

Installation

project-owner edited this page Oct 14, 2018 · 10 revisions

peppyalsa ALSA plugin should be installed in order to make PeppyMeter functional.

The following command should be executed in terminal to install PeppyMeter (assuming Raspbian OS and current folder /home/pi):

> git clone https://github.com/project-owner/PeppyMeter.git

Pygame library is the only dependency of PeppyMeter. This library is pre-installed on some OSs. To check if Pygame is installed on your machine start Python interpreter and run the following command in the interpreter:

> import pygame

If you don't see any import exceptions that means that Pygame is installed on your machine. If you see exception you have to install Pygame:

sudo apt-get install python3-pygame

<<Previous | Next>>

You can’t perform that action at this time.