Skip to content
Permalink
Branch: master
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
407 lines (390 sloc) 13.7 KB

+++ title = "18.12-U4 Available" menutitle = "18.12-U4 Available" description = "" date = "2019-02-13" draft = false pre = " " +++

Package update 4 for 18.12-RELEASE is now available.

There have also been a couple more minor updates to the automatic Xorg setup routines which Project Trident provides:

  1. The failover drivers (vesa/scfb) should be a bit more reliable as they are no longer associated with a particular GPU device (that association was reported to cause trouble on some systems).
  2. The Intel video drivers ("modesetting" and "intel") on Project Trident have always had the 3D acceleration disabled by default. This updates adds a new option which can be placed into /etc/rc.conf to enable the 3D acceleration for those Intel drivers. If you experience graphical distortion or screen artifacts with the 3D acceleration enabled, you can just remove the option to return back to the functional but non-accelerated driver.
    • Place this line into /etc/rc.conf to enable 3D acceleration, and then reboot the system to trigger the auto-configuration routines again:
    • disable_intel_accel="NO"
    • This can be performed by running the following command: sudo sysrc disable_intel_accel=NO

As far as packages go, this update is relatively minor compared to some of the previous updates. For the full list of changes, see the lists at the bottom of this announcement.

  • telegram-desktop : 1.5.4_1 -> 1.5.11
  • npm : 6.4.1_1 -> 6.7.0 (all flavors of the npm package have been updated)
  • zsh : 5.7_1 -> 5.7.1
  • u-boot-* : 2018.11 -> 2019.01 (about 40 different system architecture flavors)

Package Changes From 18.12-RELEASE-U3

For a full list of packages that are available with this release, please visit the download page!

Summary of changes

  • New Packages (57):
  • Removed Packages (20):
  • Updated Packages (284):

New Packages (57):

  • atf-rk3399 : v2.0
  • atf-sun50i_a64 : 2.0.20181123
  • figtree : 1.4.4
  • flamethrower : 0.9
  • fldigi : 4.1.00_1
  • fusefs-sandboxfs : 0.1.0
  • ghq : 0.9.0
  • graphlan : 1.1.3
  • hermit-font : 2.0
  • ldap-account-manager : 6.3_1
  • libnumbertext : 1.0.5
  • libplacebo : 1.7.0_1
  • lizardfs : 3.12.0
  • mmve : 0.2.0
  • mous : 2.0.1_1
  • nekobi-lv2 : g20180825_1
  • nimble : 0.9.0_1
  • ntfy : 2.4.4
  • nuspell : 2.1.0
  • p5-Perl-PrereqScanner-NotQuiteLite : 0.9903
  • p5-Quota : 1.7.2
  • p5-Regexp-Trie : 0.02
  • php71-pear-geshi-geshi : 1.0.9.0
  • php72-pear-geshi-geshi : 1.0.9.0
  • php73-pear-geshi-geshi : 1.0.9.0
  • prodigal : 2.6.3.2
  • prodigy-lig : 1.0.0.3
  • pulseeffects : 4.4.7
  • py27-aws-xray-sdk : 2.3.0
  • py27-datatest : 0.9.3
  • py27-glfw : 1.7.1
  • py27-keepkey : 6.0.2
  • py27-mail-parser : 3.9.1
  • py27-msgpack05 : 0.5.6
  • py27-pycoin : 0.80
  • py27-pyjade : 4.0.0
  • py27-sphinx-tabs : 1.1.10
  • py36-aws-xray-sdk : 2.3.0
  • py36-ckcc-protocol : 0.7.2
  • py36-datatest : 0.9.3
  • py36-glfw : 1.7.1
  • py36-keepkey : 6.0.2
  • py36-mail-parser : 3.9.1
  • py36-msgpack05 : 0.5.6
  • py36-pass-audit : 1.0.1_1
  • py36-pycoin : 0.80
  • py36-pyjade : 4.0.0
  • py36-sphinx-tabs : 1.1.10
  • rubygem-batch-loader12 : 1.2.2
  • shaderc : 2018.0
  • so-synth-lv2 : 1.4.1
  • src : 20190012520
  • stegosaurus-lv2 : g20180904
  • u-boot-firefly-rk3399 : 2019.01
  • u-boot-pine64-lts : 2019.01
  • u-boot-tools : 2019.01
  • webcamoid : 8.1.0_9

Removed Packages (20):

  • atf-allwinner
  • dovecot-pigeonhole04
  • dovecot22
  • dunelegacy
  • fusefs-wdfs
  • gnustep-examples
  • icinga
  • icinga-classicweb
  • icinga-core
  • icli
  • iroffer
  • narcissu2
  • pnp-icinga
  • ponscripter-sekai
  • py27-abipy
  • py27-pymatgen
  • qtile
  • rubygem-temple07
  • tamago-emacs27_nox
  • weatherspect

Updated Packages (284):

  • ags : 3.4.1.15 -> 3.4.3.0
  • aom : 1.0.0.1273 -> 1.0.0.1297
  • ap24-mod_cloudflare : 0.0.2016.6.0 -> 2016.10.0
  • bind9-devel : 9.13.4.a0.2019.01.25 -> 9.13.4.a0.2019.02.01
  • bn-freebsd-doc : 52737,1 -> 52793,1
  • broccoli : 1.97_1,1 -> 1.101,1
  • ca_root_nss : 3.42_1 -> 3.42.1_1
  • calibre : 3.38.1 -> 3.39.1
  • catch : 2.5.0_1 -> 2.6.0
  • cenon : 4.0.3_2 -> 4.0.2_4,1
  • cgribex : 1.7.5 -> 1.9.0
  • check_ssl_cert : 1.80.1 -> 1.81.0
  • citra-qt5 : s20190124 -> s20190203
  • citra : s20190124 -> s20190203
  • cmake : 3.13.3 -> 3.13.4
  • cmake-doc : 3.13.3 -> 3.13.4
  • cmake-gui : 3.13.3 -> 3.13.4
  • cmrtlib : 18.4.0 -> 18.4.1
  • copyq : 3.7.2_1 -> 3.7.3
  • da-freebsd-doc : 52737,1 -> 52793,1
  • dash.el-emacs26_canna : 2.14.1_1 -> 2.15.0
  • dash.el-emacs26_nox : 2.14.1_1 -> 2.15.0
  • dash.el-emacs26 : 2.14.1_1 -> 2.15.0
  • dash.el-emacs27_nox : 2.14.1_1 -> 2.15.0
  • dash.el-emacs27 : 2.14.1_1 -> 2.15.0
  • davical : 1.1.7_1 -> 1.1.8
  • de-freebsd-doc : 52737,1 -> 52793,1
  • de-mythes : 2019.01.26 -> 2019.02.03
  • docker : 18.06.0 -> 18.09.1
  • docker-compose : 1.22.0 -> 1.23.2
  • docker-compose-py27 : 1.22.0 -> 1.23.2
  • docker-machine : 0.16.0 -> 0.16.1
  • dovecot : 2.3.4_5 -> 2.3.4.1
  • dxa65 : 0.1.3 -> 0.1.4
  • el-freebsd-doc : 52737,1 -> 52793,1
  • elixir-excoveralls : 0.10.4 -> 0.10.5
  • emacs-devel : 27.0.50.20190110,2 -> 27.0.50.20190203,2
  • emacs-devel-nox : 27.0.50.20190110,2 -> 27.0.50.20190203,2
  • en-freebsd-doc : 52737,1 -> 52793,1
  • es-freebsd-doc : 52737,1 -> 52793,1
  • etherape : 0.9.16_1 -> 0.9.18
  • filezilla : 3.36.0_1 -> 3.40.0
  • flightgear : 2018.3.1_2 -> 2018.3.2
  • flightgear-data : 2018.3.1 -> 2018.3.2
  • form : 4.2.0_1 -> 4.2.1
  • fpdns : 0.10.0.20130404_1 -> 0.10.0.20190131
  • fr-freebsd-doc : 52737,1 -> 52793,1
  • freebsd-doc-all : 52737,1 -> 52793,1
  • gcc7-devel : 7.4.1.s20190124 -> 7.4.1.s20190131
  • gcc8-devel : 8.2.1.s20190125 -> 8.2.1.s20190201
  • gcc9-devel : 9.0.1.s20190127 -> 9.0.1.s20190203
  • geos : 3.6.3_1 -> 3.7.1
  • gitea : 1.7.0 -> 1.7.1
  • gnustep-back : 0.25.1_2 -> 0.27.0
  • gnustep-base : 1.25.0_7 -> 1.26.0_1
  • gnustep-ftp : 0.5_5 -> 0.6
  • gnustep-gui : 0.25.1_7 -> 0.27.0
  • gohugo : 0.53 -> 0.54.0
  • gramps : 4.2.8 -> 5.0.1
  • grass7 : 7.4.4 -> 7.6.0
  • grim : 1.0 -> 1.1
  • groupoffice : 6.3.59 -> 6.3.61
  • gsoap : 2.8.74 -> 2.8.78
  • hu-freebsd-doc : 52737,1 -> 52793,1
  • ikos : 2.1.69_1 -> 2.1.82
  • it-freebsd-doc : 52737,1 -> 52793,1
  • ja-freebsd-doc : 52737,1 -> 52793,1
  • jailkit : 2.19_2 -> 2.20
  • jenkins : 2.162 -> 2.163
  • kanboard : 1.2.6 -> 1.2.7
  • keepass : 2.38 -> 2.41
  • keepass-plugin-keepassrpc : 1.7.3.1_1 -> 1.8.0
  • ko-freebsd-doc : 52737,1 -> 52793,1
  • kubectl : 1.13.2 -> 1.13.3
  • libewf : 20140804 -> 20140806
  • libfilezilla : 0.13.0_1 -> 0.15.1
  • libfmt : 4.1.0_2 -> 5.3.0
  • libfsntfs : e.20190103 -> e.20190104
  • libobjc2 : 1.8.1_2 -> 2.0
  • libva-intel-media-driver : 18.4.0 -> 18.4.1
  • libvshadow : 20181216 -> 20190127
  • lightdm : 1.24.0_2 -> 1.28.0_1
  • lightdm-gtk-greeter : 2.0.2_2 -> 2.0.6
  • lnav : 0.8.2_3 -> 0.8.4
  • materialdesign-ttf : 3.3.92 -> 3.4.93
  • mkl-dnn : 0.17.2 -> 0.17.3
  • mn-freebsd-doc : 52737,1 -> 52793,1
  • mongodb34 : 3.4.16_4 -> 3.4.19
  • mongodb36 : 3.6.6_4 -> 3.6.10
  • msktutil : 1.0_2 -> 1.1
  • mysql-connector-java : 8.0.14 -> 8.0.15
  • ncdu : 1.13 -> 1.14
  • nip2 : 8.7.0_2 -> 8.7.1
  • nl-freebsd-doc : 52737,1 -> 52793,1
  • npm : 6.4.1_1 -> 6.7.0
  • npm-node10 : 6.4.1_1 -> 6.7.0
  • npm-node6 : 6.4.1_1 -> 6.7.0
  • npm-node8 : 6.4.1_1 -> 6.7.0
  • nss : 3.42 -> 3.42.1
  • nuster : 2.0.5.18 -> 2.0.7.18
  • nzbhydra2 : 2.3.3 -> 2.3.4
  • OS-runtime : 13.0.20190205164624 -> 13.0.20190212210720
  • osrm-backend : 5.17.2_5 -> 5.22.0
  • p5-Astro-SpaceTrack : 0.124 -> 0.125
  • p5-DBD-LDAP : 0.22 -> 1.00
  • p5-Devel-MAT-Dumper : 0.39 -> 0.40
  • p5-Encode : 2.99 -> 3.00
  • p5-FFI-Platypus : 0.74 -> 0.80
  • p5-Geo-Point : 0.97 -> 0.98
  • p5-HTTP-BrowserDetect : 3.20 -> 3.21
  • p5-Math-MPFR : 4.07 -> 4.08
  • p5-Minion : 9.07 -> 9.09
  • p5-Module-CPANTS-Analyse : 0.99 -> 1.00
  • p5-Mojolicious : 8.11 -> 8.12
  • p5-Prima : 1.53 -> 1.54
  • p5-WWW-Mechanize-Pluggable : 1.12_1 -> 1.14
  • p5-XML-Feed : 0.55 -> 0.57
  • p5-XML-LibXML : 2.0132,1 -> 2.0133,1
  • pdfpc : 4.3.1.0 -> 4.3.2
  • perl5-devel : 5.29.7.24 -> 5.29.7.35
  • php71-matomo : 3.7.0 -> 3.8.1
  • php71-pecl-swoole : 4.2.8_1 -> 4.2.13
  • php72-matomo : 3.7.0 -> 3.8.1
  • php72-pecl-swoole : 4.2.8_1 -> 4.2.13
  • php73-matomo : 3.7.0 -> 3.8.1
  • php73-pecl-swoole : 4.2.8_1 -> 4.2.13
  • phpmailer6 : 6.0.6 -> 6.0.7
  • phpunit6-php71 : 6.5.13 -> 6.5.14
  • phpunit6-php72 : 6.5.13 -> 6.5.14
  • phpunit6-php73 : 6.5.13 -> 6.5.14
  • phpunit7-php71 : 7.5.2 -> 7.5.3
  • phpunit7-php72 : 7.5.2 -> 7.5.3
  • phpunit7-php73 : 7.5.2 -> 7.5.3
  • pikopixel : 1.0.b9.c_1,1 -> 1.0.b9.e,1
  • pl-freebsd-doc : 52737,1 -> 52793,1
  • pl-hunspell : 20190125 -> 20190202
  • pmd : 6.10.0 -> 6.11.0
  • poudriere-trueos : 20181202 -> 2019020601
  • pt-freebsd-doc : 52737,1 -> 52793,1
  • py27-artifacts : 20181213 -> 20190113
  • py27-azure-cli : 2.0.56 -> 2.0.57
  • py27-azure-cli-acs : 2.3.15 -> 2.3.16
  • py27-azure-cli-core : 2.0.56 -> 2.0.57
  • py27-azure-cli-vm : 2.2.13 -> 2.2.14
  • py27-azure-mgmt-containerregistry : 2.6.0 -> 2.7.0
  • py27-ddtrace : 0.20.2 -> 0.20.3
  • py27-dfdatetime : 20181025 -> 20190116
  • py27-dfvfs : 20181215 -> 20190128
  • py27-dfwinreg : 20180712 -> 20190122
  • py27-distro : 1.2.0 -> 1.4.0
  • py27-django_polymorphic : 2.0.2 -> 2.0.3
  • py27-django-extensions : 2.1.3 -> 2.1.5
  • py27-django-hijack : 2.1.9 -> 2.1.10
  • py27-django-star-ratings : 0.6.1 -> 0.7.0
  • py27-dtfabric : 20181128 -> 20190120
  • py27-marshmallow-sqlalchemy : 0.15.0 -> 0.16.0
  • py27-msgpack : 0.5.6 -> 0.6.1
  • py27-oslo.privsep : 1.31.1 -> 1.32.0
  • py27-oslo.utils : 3.40.1 -> 3.40.2
  • py27-paho-mqtt : 1.1 -> 1.2
  • py27-plaso : 20181219 -> 20190131
  • py27-ptyprocess : 0.5.1 -> 0.6.0
  • py27-pytest-flake8 : 1.0.3 -> 1.0.4
  • py27-python-gitlab : 1.6.0 -> 1.7.0
  • py27-pytsk : 20190103 -> 20190121
  • py27-represent : 1.5.1 -> 1.6.0
  • py27-scrypt : 0.8.6 -> 0.8.7
  • py36-artifacts : 20181213 -> 20190113
  • py36-azure-cli : 2.0.56 -> 2.0.57
  • py36-azure-cli-acs : 2.3.15 -> 2.3.16
  • py36-azure-cli-core : 2.0.56 -> 2.0.57
  • py36-azure-cli-vm : 2.2.13 -> 2.2.14
  • py36-azure-mgmt-containerregistry : 2.6.0 -> 2.7.0
  • py36-ddtrace : 0.20.2 -> 0.20.3
  • py36-dfdatetime : 20181025 -> 20190116
  • py36-dfvfs : 20181215 -> 20190128
  • py36-dfwinreg : 20180712 -> 20190122
  • py36-distro : 1.2.0 -> 1.4.0
  • py36-django_polymorphic : 2.0.2 -> 2.0.3
  • py36-django-extensions : 2.1.3 -> 2.1.5
  • py36-django-hijack : 2.1.9 -> 2.1.10
  • py36-django-star-ratings : 0.6.1 -> 0.7.0
  • py36-dtfabric : 20181128 -> 20190120
  • py36-ixautomation : 18.12.11 -> 19.02.06
  • py36-loompy : 2.0.16_1 -> 2.0.17
  • py36-marshmallow-sqlalchemy : 0.15.0 -> 0.16.0
  • py36-msgpack : 0.5.6 -> 0.6.1
  • py36-oslo.privsep : 1.31.1 -> 1.32.0
  • py36-oslo.utils : 3.40.1 -> 3.40.2
  • py36-paho-mqtt : 1.1 -> 1.2
  • py36-plaso : 20181219 -> 20190131
  • py36-ptyprocess : 0.5.1 -> 0.6.0
  • py36-pymatgen : 2018.10.18 -> 2019.1.24
  • py36-pytest-flake8 : 1.0.3 -> 1.0.4
  • py36-python-gitlab : 1.6.0 -> 1.7.0
  • py36-pytsk : 20190103 -> 20190121
  • py36-represent : 1.5.1 -> 1.6.0
  • py36-scrypt : 0.8.6 -> 0.8.7
  • pycharm-ce : 2018.3.3 -> 2018.3.4_1
  • pyotherside-qt5 : 1.5.3_1 -> 1.5.4
  • qownnotes : 18.07.2_1 -> 19.2.0_1
  • qpdfview : 0.4.17.b1_5 -> 0.4.18.b1
  • racer : 2.1.16_1 -> 2.1.17
  • racket : 7.1 -> 7.2
  • racket-minimal : 7.1 -> 7.2
  • rav1e : s20190129 -> s20190204
  • recoll : 1.24.3 -> 1.24.5
  • rpcs3 : 0.0.5.7767 -> 0.0.6.7788
  • rpi-firmware : 1.20180619 -> 1.20181112
  • ru-freebsd-doc : 52737,1 -> 52793,1
  • ruby-build : 20181225 -> 20190130
  • rubygem-aws-sdk : 2.11.212 -> 2.11.213
  • rubygem-aws-sdk-core : 2.11.212 -> 2.11.213
  • rubygem-aws-sdk-resources : 2.11.212 -> 2.11.213
  • rubygem-batch-loader : 1.2.2 -> 1.3.0
  • rubygem-gemdiff : 2.5.1 -> 2.5.2
  • rubygem-google-cloud-core : 1.2.7 -> 1.3.0
  • rubygem-grape_logging : 1.8.0 -> 1.8.1
  • rubygem-sshkit : 1.18.1 -> 1.18.2
  • rust-bindgen : 0.47.0 -> 0.47.1
  • rust-nightly : 1.34.0.20190131 -> 1.34.0.20190205
  • sdl2_image : 2.0.2 -> 2.0.4
  • sdl2_mixer : 2.0.1_1 -> 2.0.4
  • simgear : 2018.3.1 -> 2018.3.2
  • sk-mythes : 2019.01.27 -> 2019.02.03
  • sleuthkit : 4.6.4_1 -> 4.6.5
  • sway : 1.0.b.2.291 -> 1.0.r1
  • swayidle : 1.1.18 -> 1.2
  • swaylock : 1.2.46 -> 1.3
  • synth : 2.07 -> 2.08
  • telegram-desktop : 1.5.4_1 -> 1.5.11
  • tmate-slave : g20171113,1 -> g2018112801,1
  • tr-freebsd-doc : 52737,1 -> 52793,1
  • traefik : 1.7.7 -> 1.7.8
  • trident-core : 201902051047 -> 201902121606
  • trident-installer : 201902051046 -> 201902121605
  • u-boot-a13-olinuxino : 2018.11 -> 2019.01
  • u-boot-a64-olinuxino : 2018.11 -> 2019.01
  • u-boot-bananapi : 2018.11 -> 2019.01
  • u-boot-bananapim2 : 2018.11 -> 2019.01
  • u-boot-beaglebone : 2018.11 -> 2019.01
  • u-boot-chip : 2018.11 -> 2019.01
  • u-boot-cubieboard : 2018.11 -> 2019.01
  • u-boot-cubieboard2 : 2018.11 -> 2019.01
  • u-boot-cubox-hummingboard : 2018.11 -> 2019.01
  • u-boot-duovero : 2018.11 -> 2019.01
  • u-boot-nanopi_a64 : 2018.11 -> 2019.01
  • u-boot-nanopi_m1plus : 2018.11 -> 2019.01
  • u-boot-nanopi_neo_air : 2018.11 -> 2019.01
  • u-boot-nanopi_neo : 2018.11 -> 2019.01
  • u-boot-olimex-a20-som-evb : 2018.11 -> 2019.01
  • u-boot-olinuxino-lime : 2018.11 -> 2019.01
  • u-boot-orangepi_r1 : 2018.11 -> 2019.01
  • u-boot-orangepi-one : 2018.11 -> 2019.01
  • u-boot-orangepi-pc : 2018.11 -> 2019.01
  • u-boot-orangepi-pc-plus : 2018.11 -> 2019.01
  • u-boot-orangepi-pc2 : 2018.11 -> 2019.01
  • u-boot-orangepi-plus-2e : 2018.11 -> 2019.01
  • u-boot-orangepi-zero : 2018.11 -> 2019.01
  • u-boot-pandaboard : 2018.11 -> 2019.01
  • u-boot-pcduino3 : 2018.11 -> 2019.01
  • u-boot-pine64 : 2018.11 -> 2019.01
  • u-boot-pinebook : 2018.11 -> 2019.01
  • u-boot-riotboard : 2018.11 -> 2019.01
  • u-boot-rpi-0-w : 2018.11 -> 2019.01
  • u-boot-rpi : 2018.11 -> 2019.01
  • u-boot-rpi2 : 2018.11 -> 2019.01
  • u-boot-rpi3 : 2018.11 -> 2019.01
  • u-boot-sinovoip-bpi-m3 : 2018.11 -> 2019.01
  • u-boot-sopine : 2018.11 -> 2019.01
  • u-boot-wandboard : 2018.11 -> 2019.01
  • u-boot-zedboard : 2018.11 -> 2019.01
  • u-boot-zybo : 2018.11 -> 2019.01
  • unbound : 1.8.3 -> 1.9.0
  • unifi-devel : 5.9.32 -> 5.10.11
  • urbackup-server : 2.2.11_3 -> 2.3.7
  • vanguards-tor : 0.2.2 -> 0.3.0
  • vips : 8.7.1_2 -> 8.7.4
  • wl-clipboard : 1.0.0.40 -> 1.0.0.43
  • wlroots : 0.2.193 -> 0.3
  • zh_cn-freebsd-doc : 52737,1 -> 52793,1
  • zh_tw-freebsd-doc : 52737,1 -> 52793,1
  • znc : 1.7.1_3 -> 1.7.2
  • zsh : 5.7_1 -> 5.7.1
You can’t perform that action at this time.