Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

relax the gemspecs to allow Rails 3.1 or 3.2..

  • Loading branch information...
commit e4593cb9f80a063320ac6f3a37a91354b0305b02 1 parent 777a28e
Chris Beer authored
Showing with 7 additions and 7 deletions.
  1. +2 −2 blacklight.gemspec
  2. +5 −5 test_support/bin/test.sh
View
4 blacklight.gemspec
@@ -20,14 +20,14 @@ Gem::Specification.new do |s|
# PRODUCTION GEM REQUIREMENTS
# ---------------------------------------
- s.add_dependency "rails", "~> 3.1.1"
+ s.add_dependency "rails", "~> 3.1"
s.add_dependency "nokogiri", "~>1.5" # XML Parser
s.add_dependency "unicode" # provides C-form normalization of unicode characters, as required by refworks.
s.add_dependency "marc", "~> 0.4.3" # Marc record parser
s.add_dependency "rsolr", "~> 1.0.6" # Library for interacting with rSolr.
s.add_dependency "rsolr-ext", '~> 1.0.3' # extension to the above for some rails-ish behaviors - currently embedded in our solr document ojbect.
s.add_dependency "kaminari" # the pagination (page 1,2,3, etc..) of our search results
- s.add_dependency "sass-rails", "~> 3.1.1"
+ s.add_dependency "sass-rails", "~> 3.1"
s.add_development_dependency "jettywrapper", ">= 1.2.0"
s.add_dependency "compass", ">= 0.12.alpha.2"
end
View
10 test_support/bin/test.sh
@@ -51,7 +51,7 @@ fi
rvm use "$@" --create
check_errs $? "rvm failed. please run 'rvm install $@', and then re-run these tests."
-if ! gem query -n rails -v ">=3.1.1" --installed > /dev/null; then
+if ! gem query -n rails -v "~>3.1" --installed > /dev/null; then
gem install --no-rdoc --no-ri 'rails'
fi
@@ -63,8 +63,8 @@ rails new test_app
cd test_app
echo "
source 'http://rubygems.org'
-gem 'rack', '1.3.3'
-gem 'rails', '~> 3.1.1'
+gem 'rack'
+gem 'rails', '~> 3.1'
platforms :jruby do
gem 'jruby-openssl'
gem 'activerecord-jdbcsqlite3-adapter'
@@ -78,8 +78,8 @@ gem 'blacklight', :path => '../../'
gem 'jquery-rails'
group :assets do
- gem 'sass-rails', '~> 3.1.1'
- gem 'coffee-rails', '~> 3.1.1'
+ gem 'sass-rails', '~> 3.1'
+ gem 'coffee-rails', '~> 3.1'
gem 'uglifier'
gem 'compass', '0.12.alpha.2'
Please sign in to comment.
Something went wrong with that request. Please try again.