Objective-C | Swift - ProjectorKit
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
Carthage/Checkouts
Examples
ProjectorKit.xcodeproj
ProjectorKit
ProjectorKitTests
.gitignore
.gitmodules
Cartfile.private
Cartfile.resolved
Makefile
ProjectorKit.podspec
README.md

README.md

ProjectorKit

Projector (Objective-C) SDK

Prequisites

  • Xcode 8 or later
  • Applications can target iOS 10.0 or later

Installation

Cocoapods

  • In your Podfile, add the Projector Podspec to the top of your Podfile.

    source 'git@github.com:projectorhq/podspecs.git'

  • Then add ProjectorKit to your target.

    pod 'ProjectorKit', '~> 0.1.0'

  • From the command line, run pod install.

  • Use the .xcworkspace file generated by Cocoapods to work on your project.

Carthage

  • Add github "projectorhq/ProjectorKit" to your Cartfile.

  • Run carthage update

  • Drag the ProjectorKit.framework from the Carthage/Build/iOS directory to the Linked Frameworks and Libraries section of your Xcode target's Build Phases.

  • Add a New Run Script Phase to your target's Build Phases. Add the following to the script content:

    /usr/local/bin/carthage copy-frameworks

    and add the framework path to the Input Files section:

    $(SRCROOT)/Carthage/Build/iOS/ProjectorKit.framework